Linux Kernel Programming IDE (LinK+ IDE)

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

https://sourceforge.net/projects/linkplustest/files/repository/

Learn more...
Solution Description

LinK+ IDE is a simple IDE for Linux Kernel Developers and Lovers. It is based on Eclipse IDE customized for Linux kernel programming. It reduces the development time and executes code in an elegant fashion. This IDE supports Linux kernel configuration, compilation & emulation, system call development and device driver development. LinK+ IDE includes various templates in the category of character, block and network device driver subsystems for device driver development. It includes various bus infrastructure templates and also provides Linux device driver code completion, code assistance & code navigation for developers.

Additional Details

Eclipse Versions: Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

Platform Support: Linux/GTK

Organization Name: C-DAC , Hyderabad

Development Status: Beta

Date Created: Friday, December 26, 2014 - 06:08

License: EPL

Date Updated: Wednesday, December 14, 2022 - 09:48

Submitted by: dileep kumar panjala

Screenshot
Date Ranking Installs Clickthroughs
April 2024 465/670 8 8
March 2024 570/694 4 9
February 2024 681/687 1 6
January 2024 547/691 4 15
December 2023 0/0 0 7
November 2023 580/686 4 9
October 2023 540/673 6 10
September 2023 473/663 10 6
August 2023 481/673 8 6
July 2023 510/668 6 11
June 2023 522/669 6 4
May 2023 569/671 4 4
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Linux Kernel Programming IDE (LinK+ IDE).

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

In reply to by Prerit Oberai

I am using Fedora-32 (Kernel 5.6.19). I faced similar issue while installing Link+. Finally, I am able to install Link+  on Kepler Eclipse-Build: 20130614-0229  (eclipse-standard-kepler-R-linux-gtk-x86_64.tar.gz). I have not started building module yet. Hope it works well :)

 

Was not able install from the market place

It is threwing the error " the following solution are not compatiable with version of eclipse

Eclipse version :Version: Neon.3 Release (4.6.3)

please suggest the reason

Tried also the tgz the folder did not had the installer