Enide (Studio) 2015 - Node.js, JavaScript, Java and Web Tools

Add this URL to your Eclipse Installation to reach this solution's update site.

Oxygen (4.7), Neon (4.6), Mars (4.5), Photon (4.8), 2018-09 (4.9), 2018-12 (4.10), 2019-03 (4.11), 2019-06 (4.12), 2019-09 (4.13), 2019-12 (4.14), 2020-03 (4.15), 2020-06 (4.16), 2020-09 (4.17), 2020-12 (4.18), 2021-03 (4.19)

https://nodeclipse.github.io/updates/

Learn more...
Solution Description

Nodeclipse "Enide Studio 2015" is Tool Suite for Node.js, JavaScript, Java Development. This is the most feature-rich pack. Unless there is the latest version download for your OS, recommended install via drag-n-drop of Install image onto Eclipse main toolbar Check https://nodeclipse.github.io/

See also Gradle IDE Pack and Enide Studio 2014 - Node.js, JavaScript and Java.

Additional Details

Eclipse Versions: Oxygen (4.7), Neon (4.6), Mars (4.5), Photon (4.8), 2018-09 (4.9), 2018-12 (4.10), 2019-03 (4.11), 2019-06 (4.12), 2019-09 (4.13), 2019-12 (4.14), 2020-03 (4.15), 2020-06 (4.16), 2020-09 (4.17), 2020-12 (4.18), 2021-03 (4.19)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Nodeclipse/Enide

Development Status: Production/Stable

Date Created: Wednesday, October 14, 2015 - 05:15

License: EPL

Date Updated: Friday, January 15, 2021 - 10:11

Submitted by: Paul Verest

Subscribe to Enide (Studio) 2015 - Node.js, JavaScript, Java and Web Tools RSS-feed

Date Ranking Installs Clickthroughs
July 2024 127/651 168 7
June 2024 138/681 209 19
May 2024 134/682 241 13
April 2024 129/687 263 13
March 2024 142/694 245 9
February 2024 118/687 280 8
January 2024 124/691 282 8
December 2023 118/671 286 9
November 2023 141/686 272 7
October 2023 117/673 361 7
September 2023 106/663 374 5
August 2023 98/673 385 4
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 3

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Enide (Studio) 2015 - Node.js, JavaScript, Java and Web Tools.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Several Eclipse versions ago, I was able to install this plugin for my Eclipse version. Plugins are a constant source of frustration in the Eclipse ecosystem, but I can usually manage.

This plugin was developed by a team in China, and they lost access to github.io unless they used a VPN. As a result, they moved their hosting within China and nothing was updated in the Eclipse Marketplace, so this plugin was last updated on January 15th, 2021 and will likely never be updated again.

I switched over to the Wild Web Developer plugin, and it does OK for JavaScript and Node.JS, but there are some missing configuration items (specifically a native JavaScript or Node.js editor where I can alter configuration items). It had been long enough since I tried to fix something in that configuration that I forgot ENIDE was no longer available, so I had to go down the same research rabbit hole to be reminded that yeah, they're in China and the rest of the world isn't.

It would be nice if Eclipse would detect when a plugin doesn't match my editor version and doesn't show it in search results when I search within my IDE Marketplace. This would allow unmaintained and old plugins to stop showing up in my marketplace search results. Instead they still show up as the top result when I search for Node.