DBeaver

Add this URL to your Eclipse Installation to reach this solution's update site.

2024-03 (4.31), 2023-12 (4.30), 2023-09 (4.29), 2023-06 (4.28), 2023-03 (4.27), 2022-12 (4.26), 2022-09 (4.25), 2022-06 (4.24), 2022-03 (4.23), 2021-12 (4.22), 2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9)

https://dbeaver.io/update/ce/latest/

Learn more...
Solution Description

DBeaver is free universal SQL client/database tool for developers and database administrators. It can work with any database server which has JDBC or ODBC driver. It supports pluggable extensions.

Features: database schema browser, metadata editor (tables, columns, keys, indexes), SQL statements/scripts execution, SQL highlighting, autocompletion, formatting; result set/table view/edit/search; BLOB/CLOB view/edit support; GIS spatial data viewer, scrollable resultsets; transactions management; database metadata and full-text search; ER diagrams; server sessions management, transaction locks management, SSH/SOCKS support; automatic drivers download; stored procedures debugger; data import/export/migration; task management, database health monitoring dashboards; spatial data viewer; git integration; office formats support; etc.

Includes drivers for: MySQL, MariaDB, Oracle, DB2, PostgreSQL, SQL Server, Sybase, Apache Hive, Drill, Presto, Trino, Phoenix, Exasol, Informix, Teradata, Vertica, Netezza, Firebird, Derby, H2, H2GIS, WMI, Snowflake, Greenplum, AWS Redshift, AWS Athena, SAP HANA, MaxDB, NuoDB, MS Access, SQLite, CSV, DBF, Firebird, TimescaleDB, Yellowbrick, CockroachDB, OrientDB, MonetDB, Google BigQuery, Google Spanner, Apache Hive/Impala/Spark, Apache Ignite, MapD, Azure SQL, CrateDB, Elasticsearch, Ocient, Ingres, OmniSci, Yugabyte, IRIS, Data Virtuality, Denodo, DuckDB, Babelfish, OceanBase, Salesforce, EnterpriseDB, Apache Druid, Apache Kylin, Azure Databricks, OpenSearch, TiDB, TDEngine, Materialize, JDBCX, Dameng, Altibase, StarRocks, CUBRID.

Supports Color Theme and Darkest Dark themes.

Additional Details

Eclipse Versions: 2024-03 (4.31), 2023-12 (4.30), 2023-09 (4.29), 2023-06 (4.28), 2023-03 (4.27), 2022-12 (4.26), 2022-09 (4.25), 2022-06 (4.24), 2022-03 (4.23), 2021-12 (4.22), 2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: DBeaver Corp

Development Status: Production/Stable

Date Created: Sunday, November 4, 2012 - 11:30

License: Apache 2.0

Date Updated: Sunday, April 7, 2024 - 13:19

Submitted by: Serge Rider

Subscribe to DBeaver RSS-feed

Screenshot
Date Ranking Installs Clickthroughs
April 2024 28/633 727 16
March 2024 28/694 1708 71
February 2024 29/687 1383 347
January 2024 28/691 1594 92
December 2023 29/671 1436 24
November 2023 24/686 1880 30
October 2023 25/673 2317 37
September 2023 26/663 2000 33
August 2023 26/673 1995 21
July 2023 26/668 1930 34
June 2023 27/669 2072 18
May 2023 24/671 2178 29
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for DBeaver.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

I needed to build a large Java project.
After several builds, I encountered an OutOfMemoryError.
After analyzing the Dump file, we found a huge instance of org.jkiss.dbeaver.model.navigator.DBNModel that was over 1GByte.
This problem occurs with dbeaver version 4.2.2 and above.
My guess,
DBNEvent is accumulated in eventCache in org.jkiss.dbeaver.model.navigator.DBNModel$EventProcessingJob and it is OOME.
DBNModel.java has been refactored in 4.2.2 to add the internal class EventProcessingJob.
It seems that if you build a Java project after 4.2.2, the eventCache will continue to accumulate DBNEvents.
Commit ID: dbe4097035c407ab276e621773eed924c814f291
https://github.com/dbeaver/dbeaver/commit/dbe4097035c407ab276e621773eed924c814f291
What can I provide to help resolve this issue?

Cannot complete the install because one or more required items could not be found.
  Software being installed: DBeaver IDE 23.2.1.202309260508 (org.jkiss.dbeaver.ide.feature.feature.group 23.2.1.202309260508)
  Missing requirement: DBeaver Google BigQuery Model 1.0.121.202309260508 (org.jkiss.dbeaver.ext.bigquery 1.0.121.202309260508) requires 'osgi.bundle; org.slf4j.api 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: DBeaver Databases 1.0.106.202309260508 (org.jkiss.dbeaver.db.feature.feature.group 1.0.106.202309260508)
    To: org.eclipse.equinox.p2.iu; org.jkiss.dbeaver.ext.bigquery [1.0.121.202309260508,1.0.121.202309260508]
  Cannot satisfy dependency:
    From: DBeaver IDE 23.2.1.202309260508 (org.jkiss.dbeaver.ide.feature.feature.group 23.2.1.202309260508)
    To: org.eclipse.equinox.p2.iu; org.jkiss.dbeaver.db.feature.feature.group [1.0.106.202309260508,1.0.106.202309260508]

But I have a need to reinstall Eclipse 2021-06 from scratch and I can't seem to successfully install DBeaver 22.0.1 (but this all worked fine when I first installed 2021-06 several months ago).  Should I be installing an older version of DBeaver?  If so, how do I do that?

Cannot invoke "org.eclipse.core.runtime.IPath.toFile()" because the return value of "org.eclipse.core.resources.IProject.getLocation()" is null

Reason:
Cannot invoke "org.eclipse.core.runtime.IPath.toFile()" because the return value of "org.eclipse.core.resources.IProject.getLocation()" is null

 

 

Could you please help me how to remove or uninstall this one since now I am not able to do anything on Eclipse

 

 

While trying to install this plugin I received a pop-up asking if I trust a DBeaver Corp certificate, issued by Symantec, that expired 10/18/2019. If I don't trust this certificate the plugin does not install.

What is this certificate for, and why am I required to trust and expired certificate?

In reply to by Mike McAngus

Thank you for bringing this up. Indeed, we used an outdated certificate to sign jars of recent community versions. We will fix it in the next DBeaver release.

Note: generally most of 3rd party extensions/libraries don't have any certificate at all. DBeaver signs jars only if they are built by DBeaver Corp. Many 3rd party dependencies are still unsigned and there is nothing we can do about it.

How to change the language of the interface of DBeaver integration to Eclipse ?

I've tried editing dbeaver.ini with "-nl en", did not work.

I've checked Window>Preferences, but the User Interface section of DBeaver stand-alone version is not present in the Eclipse integration.

Anyone can help please ? I just want it in English, not the language of my Windows. Thank you.

In reply to by Serge Rider

Thank you Serge for your reply.

I edited eclipse.ini instead of dbeaver.ini, as you adviced, and DBeaver is fully in english now.

I had to add this line in eclipse.ini : -Duser.language=en

Right here :

--add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=11
-Dosgi.dataAreaRequiresExplicitInit=true
-Xms256m
-Xmx2048m
-Duser.language=en

Thanks a lot for solving my issue.

 

 

Really great tool !!

I see there is git plugin integration, any documentation out there available for this?

Been using this plug-in for years (I used DBEdit earlier).  Some of the UI choices are interesting, but the functionality is quite good.

I use DBeaver as SQL editor only. And don`t need connections to DB.

So I can`t remove actions "Commit", "Rollback", "Active datasource", etc. from toolbar.

 

Reproduce:

1. Open menu "Window/Perspective/Customize Perspective..."

2. Try check off "Tool Bar Visibility/DataSource Selector". I get dialog:

'DataSource Selector' cannot be made visible because it is in the unavailable 'null' action set.

Would you like to switch to the Action Set Availability tab?

and any choice get nothng.

 

Hi!
We are very pleased with DBeaver and worked fine with older DBv. and Eclipse versions but with Photon the DBeaver cannot install properly due to a provisioning operation error. I choosed the Debug, DB2 and Oracle extensions: Cannot complete the install because one or more required items could not be found. Please help us to resolve this problem, does anybody else have this issue?

Cannot complete the install because one or more required items could not be found.
Software being installed: DBeaver Runtime 5.2.3.201810201753 (org.jkiss.dbeaver.runtime.feature.feature.group 5.2.3.201810201753)
Missing requirement: DBeaver Core Plug-in 5.2.3.201810201753 (org.jkiss.dbeaver.core 5.2.3.201810201753) requires 'osgi.bundle; org.eclipse.nebula.widgets.gallery 0.0.0' but it could not be found
Cannot satisfy dependency:
From: DBeaver Core 5.2.3.201810201753 (org.jkiss.dbeaver.core.feature.feature.group 5.2.3.201810201753)
To: org.eclipse.equinox.p2.iu; org.jkiss.dbeaver.core [5.2.3.201810201753,5.2.3.201810201753]
Cannot satisfy dependency:
From: DBeaver Runtime 5.2.3.201810201753 (org.jkiss.dbeaver.runtime.feature.feature.group 5.2.3.201810201753)
To: org.eclipse.equinox.p2.iu; org.jkiss.dbeaver.core.feature.feature.group [5.2.3.201810201753,5.2.3.201810201753]

i am using all default connection settings.

Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
  Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
    Connection refused: connect
    Connection refused: connect

 

Please help me with this. How to resolve this

I found this plugin by searching for Mongo, and there is no Mongo support in the Eclipse plugin - only the Enterprise Edition of the standalone application.  

In reply to by Sharon Snyder

Currently Eclipse plugin version includes only CE plugins. For Mongo and other NoSQL features you need to download standalone version.

We going to release EE Eclipse plugin later in this year (it is complicated because of big number of dependencies in 3rd party NoSQL drivers).

An incredible tools dealing wiht multiple db. It 's enrish of SQL source code management and help me developing and organizing trigger and store procedure effectively .

Today I've a Problem with the autoincrement-BUG.
Google it has shown me, that DBeaver still is on 2.3, but in my eclipse-Update-Page-Settings I have a Link like:
dbeaver.jkiss.org/update/2.0/

But to upgrade it, i need to add a NEW Link:
dbeaver.jkiss.org/update/2.3/

I think this isn't the way eclipse work with update-Pages. Cause if the whole url change by each new version, eclipse can't know this.
Please make your upgrades Noticeable by eclipse update-Process.

Amazing! Use it all the time now. Very well coded and so useful.

Can you add support for multiple results though?

select * from table1

select * from table2

and run them together.

I'm using Sybase. :) (Unfortunately)

I try toadExtension and dbeaver.
What i realy love on dbeaver... the chance to use ssh-tunnel for mysql-connection. This is a must-have for me, cause i don't open mysql-ports on a production-system... and i don't wanna manage ssh-tunnnel-connection outside of my eclipse (that all need time - and time is money ;)

Hi, thanks for a greate tool.
But please change version compatibility info to 3.7, 3.8, 4.2.
Thanks =)

excellent interface, many supported databases, active project(5 updates for 2 last months). I like this. Thanks, dbeaver team!:)