Darkest Dark Theme with DevStyle

Add this URL to your Eclipse Installation to reach this solution's update site.

2024-06 (4.32), 2024-03 (4.31), 2023-12 (4.30), 2023-09 (4.29), 2023-06 (4.28), 2023-03 (4.27), 2022-12 (4.26), 2022-09 (4.25), 2022-06 (4.24), 2022-03 (4.23), 2021-12 (4.22), 2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), 2024-06 (4.33)

https://devstyle.codetogether.io

Neon (4.6)

https://devstyle.codetogether.io

Learn more...
Solution Description

Darkest Dark theme from DevStyle - a free plugin providing an enhanced set of experiences for Eclipse. Included:

  • Darkest Dark theme - #1 in the Marketplace:
    True dark theme with flat replacement icons
    A great experience over Windows, Mac and Linux
     
  • Included with DevStyle:
    New light and dark color themes
    All new startup experience for Eclipse
    Inline search for text editors

​Entirely free to use!  Get DevStyle today.

Categories: IDE, UI

Additional Details

Eclipse Versions: 2024-06 (4.32), 2024-03 (4.31), 2023-12 (4.30), 2023-09 (4.29), 2023-06 (4.28), 2023-03 (4.27), 2022-12 (4.26), 2022-09 (4.25), 2022-06 (4.24), 2022-03 (4.23), 2021-12 (4.22), 2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), 2024-06 (4.33), Neon (4.6)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: CodeTogether Inc.

Development Status: Production/Stable

Date Created: Tuesday, January 31, 2017 - 12:51

License: Commercial - Free

Date Updated: Tuesday, June 18, 2024 - 08:14

Submitted by: Tim Webb

Screenshot
Date Ranking Installs Clickthroughs
July 2024 5/646 7172 34
June 2024 6/681 10827 75
May 2024 6/682 10796 49
April 2024 5/687 12345 57
March 2024 4/694 14353 82
February 2024 5/687 11373 322
January 2024 5/691 10676 75
December 2023 6/671 9424 59
November 2023 6/686 11696 50
October 2023 5/673 12951 76
September 2023 4/663 13968 59
August 2023 5/673 12590 66
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 215

Count Error Message
135 Cannot continue the operation. There is another install operation in progress.
22 Cannot complete the install because one or more required items could not be…
16 Cannot complete the install because one or more required items could not be…
6 Cannot complete the install because one or more required items could not be…
6 Cannot complete the install because one or more required items could not be…
4 Cannot complete the install because one or more required items could not be…
3 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because one or more required items could not be…
2 操作を続行できません。 別のインストール操作が進行中です。
2 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because of a conflicting dependency. Software…
2 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because of a conflicting dependency. Software…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 无法继续操作。正在执行另一个安装操作。
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Your original request has been modified. "DevStyle (includes Darkest Dark…
1 Cannot complete the install because one or more required items could not be…
Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Darkest Dark Theme with DevStyle.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

As title say i have these problems, until now everything was normal.
Info logs not working when i have mouse over something in mycode.
Javadoc for methods doensnt working.
Error logs also dissapeared while hover, and i have only the red indicator at left.
First time i am encounter this, and i am using this plugin for months..
I checked this without devStyle enabled,everything fine.
I try also a fresh install of Eclipse again the same.

 

 

In reply to by teo kats

Teo, sorry about that. We did release an update yesterday which had the problems you describe, but we followed up with a second update a few hours later which included the fix. Your installation would probably have already updated by now, but if not, please check for an update and restart to get back to a much improved DevStyle.

I haven't managed to get eclipse (2018-12) working with devstyle for a while now. As soon as you install the theme project explorer goes blank and eclipse pretty much stops working with no dialogs or context menu. Only solution was to go back to 2018-09. Any ideas?

In reply to by Dik Rana

Dik,

Sorry you've had problems with DevStyle on the latest eclipse. I did a quick test with DevStyle on RC2 on Windows 10 but didn't see any problems. Which OS are you using and are there any modifications to the OS or windowing system (e.g. a desktop theme)? It would be great if you could raise the issue on our forums (just click the "?" in the description) as that is a better platform for support than this reviews section of the MarketPlace. It would be great to get this sorted before the official release of eclipse 4.10.

In reply to by Tony Weddle

I'm also having this problem. My system:

NAME="Ubuntu"
VERSION="18.04.2 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.2 LTS"
VERSION_ID="18.04"

java version "1.8.0_201"
Java(TM) SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.201-b09, mixed mode)

 

Since we're coming up to January and Oracle's decision to charge people for Java I've been investigating ways to be an "open" Java developer... Everything seems be running great (which is the good news) although Darkest Dark (which I love) did warn me about Open JDK and Third Party fonts, then suggested I move to Oracle JDK (which kind of defeats the purpose)..

 

Best regards, Ben

Installing this feature into Eclipse Photon broke the installation in the following way:

  • when launching Eclipse, after the Photon splash screen a square window is shown, barely sufficient to show:
    • two icons (Welcome & Styles) plus
    • the Text "Hello\nWelcome t".
    • resizing of the window is not possible.
  • within this window the only responsive element is the close button ("X")
  • game over.

FWIW, I'm on Kubuntu.

PS: I could get back into the game by invoking Eclipse with "-clear -clean", which should never be necessary just to get into the IDE

In reply to by Stephan Herrmann

Stephan, sorry that you couldn't launch without the -clean option once but it's great you persevered. I hope you're enjoying DevStyle now.

Would you be able to work with us to figure out what happened in your case? I've tried with a clean install of eclipse on a clean install of Kubuntu 18.04 but I'm sure that wasn't your situation. It may be related to the state of the workspace or the state of the eclipse configuration at the time. We could confirm this if you could do a fresh install of DevStyle onto a fresh install of eclipse, with a fresh workspace. If that all works, then could you let us have your eclipse configuration from the existing setup to help us replicate it? The configuration can be obtained by going to Help>About>Installation Details>Configuration and then copy it to the clipboard to paste into a new text file. If possible, could you provide that information on the support forums, rather than what is designed as a review platform? You'd be able to attach files in the forums at: https://www.genuitec.com/forums/topics/darkest-dark/ .

Thanks for reporting this, hopefully, we can get to the root of the problem.

Currently, I’m using the dark theme with my own editor color scheme. However, every time I close Eclipse 2018-19 and re open it, all my Syntax Coloring settings reset (not the colors themselves but rather my preset bold/italics settings). For example, I like to have the keyword “return” in bold but even though I have exported/imported my settings they still will change upon launch. Interestingly, I tried saving my settings without your plugin installed and they remained upon restart. In the end, I’m not sure what’s going on and it’s very frustrating.

In reply to by Sebastian Nunez

Sebastian, thanks for installing DevStyle and sorry for the problems with syntax styling; that does sound very frustrating, as you say. I'm not sure why you're exporting and importing settings, this shouldn't be needed for a single workspace and your editor settings should be honored. I assume you mean eclipse 2018-09 and I haven't been able to replicate the problem with that build. In my case, I've installed eclipse-javascript-2018-09 and then ensured that the return keyword was set to bold in my JavaScript editor preferences (it was actually the default setting). Then I installed DevStyle from the MarketPlace and restarted. I still see that return keyword preference set to bold, and it is retained after a couple of restarts. Could you detail the steps you took, to help us replicate (including any DevStyle preferences). Also, the OS you're using might be relevant.

If you could raise the issue on our support forum at https://www.genuitec.com/forums/topics/devstyle/theme-problems/ that would also allow you to attach your eclipse error log, which may contain errors related to the problem (it would help if you could clear the log then reproduce the problem, to ensure the log is concentrated on the issue).

In reply to by Sebastian Nunez

Sebastian, we did see something similar early this year. Although we weren't able to track down the problem then (though there was a possibility that Oomph tracking settings changes might have been part of the problem), the issue was solved by starting eclipse with a new workspace and importing projects into it. A new workspace is always a good check as corruption in a workspace does occasionally occur.

After I decided to give a chance for the pluging, even with the agressive license, I just can't use my Eclipse any more. When I open it it stays like this: https : //i.imgur.com/0OcrreI.png

Terrible.

In reply to by Thiago Berne

Thiago, thanks for giving it a go. Sorry that your first experience was terrible. It seems that another user sees the same thing though this is the first we've heard of this particular issue, despite thousands of installs. The other user is running Kubuntu, though we couldn't replicate with a straightforward install. The other person, Stephan, says he managed to sort it by launching once with the -clean flag. Though this shouldn't be needed, can you try this to see if it fixes it? I would also have suggested trying a fresh workspace, as a test. It may be that the state of the workspace or configuration, with other plugins and settings weren't properly coped with by the initial launch of DevStyle and it would be great if we could track this down to fix it for other users. If possible, could you raise the issue on the support forums, rather than what is designed as a review platform? You'd be able to attach files in the forums at: https://www.genuitec.com/forums/topics/darkest-dark/ and it may be helpful to attach the eclipse configuration at the point of install.

Alternatively, if you can post the OS and windowing system here, along with the build and package of eclipse, that may help us replicate it. Also, if there are some major plugins you've installed, it may give us more clues.

Thanks for any help you can provide and sorry, again, for having a really bad first experience. I hope you can give it another go.

In reply to by Thiago Berne

Thiago, thanks for the information. So we know that a common element is Kubuntu but, unfortunately, there isn't much else to go on to investigate the problem. However, I'm going to see if we can, at least, make that Welcome window resizeable, and continue trying to replicate the problem. I hope you revisit the plugin and perhaps try the -clean option if this same issue arises.

In reply to by Tony Weddle

Same here, also on Kubuntu.

It's trying to show some kind of welcome wizard, only on the 1st run after installing DevStyle.

Solution is to run it from the command line just once, then it displays correctly and you get past the welcome wizard.

Thereafter you can launch it from the desktop icon just fine.

(Would be great if the dev can just make the wizard window resizable.)

In reply to by Stephan Herrmann

Thanks, Stephan. It's likely the -clean option that did it. There isn't a -clear option for eclipse, that I'm aware of, although there is a -clearPersistedState option but, as far as I can tell, abbreviated options don't work (unfortunately, eclipse doesn't let you know if it doesn't recognize an option, it just ignores it).

The theme looks amazing but when there is a bug or a word misspelt in my programs, the error icon on the incorrect line that used to show up in the classic theme (displays an error message when the cursor is hovering over it) is not displayed anymore. is there any way i could get that back? I'm using Eclipse Java Oxygen, version 3a, release 4.7.3a.

In reply to by Nathan Drake

Nathan, sorry you're having a problem. It's difficult to think of how a theme could alter behavior in that way and we haven't been able to reproduce the problem so far. Can you ensure you're using the same editor you were before installing DevStyle? Perhaps leave the editor open and then switch back to the Classic theme (you'd need a restart) and see if you get that behavior back. You can also check which default editor is set for the file by right clicking on the file and selecting Open With (the default editor will have a highlighted icon).

If you've installed DevStyle as part of another plugin feature, you may be seeing a different editor behavior. If you continue to see this problem, is it possible for you to raise a new topic for it on our forums? Here is the forum home URL: https://www.genuitec.com/forums/ . You should use the appropriate forum for the product you've installed (or just DevStyle>Theme Problems if it still seems like a theme issue).

The following block in license made me give up installing it....

 

9.0 Consent to Collect, Store, and Use Information. Licensor respects privacy rights and recognizes the importance of protecting any information collected about you. Solely for the purpose of improving Licensor Services to you hereby authorize and consent to the collection, storage and use of aggregate information and data related to or derived from your use of the Software and any information or data (including personally identifiable information) that you elect to provide to Licensor in connection with your use of the Software. By installing, accessing or using the Software, you consent to these information collection and usage terms, including (where applicable) the transfer of data into a country outside of the European Union and/or the European Economic Area or the United States of America. Licensor assumes no obligation to protect confidential or proprietary information that you elect to provide to Licensor (other than personally identifiable information) from disclosure, and Licensor will be free to reproduce, use, and distribute the Information (other than personally identifiable information) to others without restriction.

In reply to by Thiago Berne

Thiago, thank you for your candid feedback. Apart from information collected during user-initiated support requests, we do not collect any personally identifiable information.

On review of this clause, we realize that it contains rather over zealous boilerplate jargon that must be tightened to only specify what is actually being collected by DevStyle. Like our other products, we will also be adding a preference allowing you to opt out of metrics collection. Both these changes will make it to a release in the near future. Thanks!

Does anyone know how to keep Eclipse randomly turning characters white when using a Dark theme?  It happens to Darkest Dark and the default, so I suspect its an Eclipse issue.

Thanks.

In reply to by Steve Pruitt

Can you provide some examples of where and when the random coloring change occurs? We might be able to do something about it with Darkest Dark (and other DevStyle dark themes) if we have more details. The release of eclipse and the OS being used would also help. If you post on our support forums, you can add a screenshot to give us a better understanding. Support forums are here: https://www.genuitec.com/forums/topics/devstyle/

I've been using Darkest Dark for a while, with Eclipse Photon on CentOS 7 and MATE desktop, and had agiven up writing down the places where the theme was broken to the point of near unusability.  There were buttons which had white text on light-grey background etc., or search fields black text on a dark-grey background). 

HOWEVER the latest release (2017 CI 14 - cf., the Genuitec delivery log page) has solved all the problems that made the theme almost unusable.  I am very impressed.

There are a couple of things which are still not quite right, but I'll add these to the Genuitec forum for consideration.

Thank you for the nice plugin!  I'm now confident that this is something I'll use into the future.

In reply to by Roger Duthie

Thanks for the kind comments Roger. As you can imagine, this kind of endeavor can be very complex and, with multiple platforms, not to mention uncountable plugins, to accommodate, it can be very difficult to get it completely right 100% of the time but we have put a lot of effort in to correct reported problems even though this is completely free to use. So it's very gratifying to see that our efforts are being noticed.

Thanks again and, yes please, raise issues on the support forums, which is the best place, rather than our trying to deal with them on this review page.

In reply to by Arpit Parasana

Thanks for your comments, Arpit. Regarding the file change indicator for SVN files, I see a star decoration for changed files in my test, so I must have a different setup to you. Could you please raise the issue in our support forums: https://www.genuitec.com/forums/topics/devstyle/theme-problems/ ? Please include as much detail as possible, including the SVN plugin you're using, the version of eclipse, the DevStyle theme and your OS and version. Our support forums are a better way of addressing problems, rather than the comments section here and we should be able to get to the cause of the problem there.

"Heap status" on the bottom right corner on this theme has a black progress bar and text, so when progress bar overlaps the text, cannot read the text, as everything is dark.

In reply to by Arpit Parasana

Arpit, if possible, could you raise the issue in our support forum at: https://www.genuitec.com/forums/topics/devstyle/theme-problems/ ? It's not clear what plugin is providing the heap status for you, as it isn't a standard part of eclipse. I do see something similar in the heap status available with MyEclipse and will raise a bug report for that (though the text is just readable). If you're not referring to MyEclipse, please give as much detail as possible in the support forum mentioned above.

In reply to by Arpit Parasana

Arpit, apologies for my last reply to this issue. I was confusing a couple of features. Yes, there is a problem with the contrast between the heap status text and the color of the free space area, making the text difficult to read. I've raised a bug report for that. Sorry for the inconvenience.

I just love the new 'Deep Black' theme within DevStyle!!! It is so cool and breath-taking that I got it installed on my Oxygen, Photon and even STS (Spring Tools Suite) and Angular-IDE!!! You may need to update DevStyle  to its latest version in order to see it and try it out, but one thing is for sure: you are going to love it too!!! ^_^

The new "Deep Black" theme is great. It improves readability, providing more contrast between backgrounds and UI / text.

Also congrats to Genuitec for actively listening to users and bug reports.

First of all, congrats for the great work.

After upgrading DevStyle to 1.11.0.201805291134 version, the horizontal scrollbar in editors is appearing like eclipse default instead of black and slim like DevStyle style. The vertical scrollbar still shown correctly.

With same config in previous version (1.11.0.201805291134) it works correctly and both scrollbars was shown acordling to theme.

Can you help me? Some suggestions? It's a known bug?