Remote System Explorer (SSH, Telnet, FTP and DStore protocols)

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

https://download.eclipse.org/releases/kepler/

Learn more...
Solution Description

Remote System Explorer is result of Eclipse Target Management team work. It support SSH, Telnet, FTP and DStore protocols.

The purpose of the entry is to let install it with one drag-and-drop by using Install button.

Example of such usage is Nodeclipse Plugins List

Categories: Tools

Additional Details

Eclipse Versions: Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Paul Verest

Development Status: Production/Stable

Date Created: Friday, October 25, 2013 - 01:37

License: EPL

Date Updated: Wednesday, December 14, 2022 - 09:48

Submitted by: Paul Verest

Date Ranking Installs Clickthroughs
February 2024 80/685 423 13
January 2024 85/691 453 11
December 2023 81/671 467 11
November 2023 79/686 608 10
October 2023 71/673 607 18
September 2023 80/663 532 16
August 2023 84/673 483 13
July 2023 87/668 482 11
June 2023 76/669 590 25
May 2023 95/671 512 15
April 2023 83/667 559 13
March 2023 82/686 719 16
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Remote System Explorer (SSH, Telnet, FTP and DStore protocols).

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Failed to connect to sshd: Algorithm negotiation failed.

The error occurs because the client and server cannot agree on encryption algorithms. ssh-rsa host keys (SHA1 based RSA) are disabled on the server.

How to configure the client so that it supports the ssh-ed25519 and rsa-sha2-256/rsa-sha2-512 algorithms?

Hi I need this updated to be compatible with with 2020-03.. need this to perform my work duties, as i don't have permission to select older versions of eclipse and there are no other workarounds that I know of for ssh. 

I'm using Remote systems for some times but finaly I'm looking to change because it doesn't stores ssh/ftp passwords, I check the checkbox but that does no diffrence, it's so stupid.

Just got it off of the Kepler Distro..   Started it up and viola, I'm able to browse, explore, SSH into the Linux server.

Thanks for keeping this updated.

I am using Eclipse remote system explorer to connect to remote servers, the terminal keep displaying weird characters, and duplicate whatever i write.

view this screenshot imgur.com/uuHHono