old Nodeclipse CoffeeScript Viewer (Editor before Eclipse 4.3.1)

Add this URL to your Eclipse Installation to reach this solution's update site.

2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), 2019-06 (4.12), 2019-09 (4.13), 2019-12 (4.14), 2020-03 (4.15), 2020-06 (4.16), 2020-09 (4.17), 2020-12 (4.18), 2021-03 (4.19)

https://nodeclipse.github.io/updates/coffeescript/

Learn more...
Solution Description

CoffeeScript Editor let's you edit *.coffee files with some advanced features. Highlights include - syntax highlighting - variable autocompletion in the current namespace - correct autoindent This entry includes Nodeclipse EditBox. Known problems: - outline, error warnings are causing more confusion than really help. - There is problem since Eclipse 4.3.1 release https://github.com/Nodeclipse/coffeescript-eclipse/issues/19 Get 4.3.0, e.g. as Enide Studio 0.5.x http://marketplace.eclipse.org/content/enide-studio Help us if you know Eclipse XTEXT. History Plugin was created by Adam Schmideg and blessed to be with Nodeclipse. We were looking for new owner familiar with XText technology. http://www.eclipse.org/forums/index.php/mv/msg/541004/1127312/#msg_1127… - 0.3.0 is refresh release with coffee icon and switch to maven /tycho build. Check README on GitHub for history and future considerations. https://github.com/Nodeclipse/coffeescript-eclipse - 0.4.0 Merged Pull Request #23 from Matt Tucker "When indenting, respect Eclipse editor preferences for tabs/spaces" Listed in Nodeclipse Plugins List

Categories: Editor, IDE, Languages, Tools

Additional Details

Eclipse Versions: 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), 2019-06 (4.12), 2019-09 (4.13), 2019-12 (4.14), 2020-03 (4.15), 2020-06 (4.16), 2020-09 (4.17), 2020-12 (4.18), 2021-03 (4.19)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Nodeclipse organization

Development Status: Beta

Date Created: Saturday, August 17, 2013 - 06:21

License: EPL

Date Updated: Friday, January 15, 2021 - 10:13

Submitted by: Paul Verest

Date Ranking Installs Clickthroughs
February 2024 0/0 0 13
January 2024 0/0 0 16
December 2023 0/0 0 9
November 2023 0/0 0 6
October 2023 0/0 0 10
September 2023 0/0 0 3
August 2023 0/0 0 9
July 2023 0/0 0 3
June 2023 0/0 0 7
May 2023 0/0 0 7
April 2023 0/0 0 7
March 2023 669/686 1 9
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for old Nodeclipse CoffeeScript Viewer (Editor before Eclipse 4.3.1).

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Keeps freezing up when saving files, too.

Kepler, Ubuntu Precise.

In reply to by richard.j.mitc…

It is first time a performance issue is mentioned and I doubt it is related to this plugin.
Use GitHub issue tracker to raise an issue.
You should give OS, Java, Eclipse version info.
Marketplace reviews are not the place for such discussion.