IntelliJ IDEA keymap for Eclipse

Add this URL to your Eclipse Installation to reach this solution's update site.

2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6)

https://raw.githubusercontent.com/IntelliJIdeaKeymap4Eclipse/IntelliJIdeaKeymap4Eclipse-update-site/main

Learn more...
Solution Description

Provides a new entry to Preferences --> General --> Keys (IntelliJ IDEA)

The supported shortcuts can be seen here https://github.com/IntelliJIdeaKeymap4Eclipse/IntelliJIdeaKeymap4Eclipse

Work in progress, not tested on Linux.

Contributions are welcomed. Please provide bug and feature reports via the GitHub page.

Categories: Editor, IDE, Other, UI

Additional Details

Eclipse Versions: 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6)

Platform Support: Windows, Mac, Linux/GTK

Development Status: Mature

Date Created: Tuesday, February 13, 2018 - 15:41

License: EPL 2.0

Date Updated: Saturday, February 27, 2021 - 11:44

Submitted by: IntelliJ IDEA Keymap for Eclipse

Date Ranking Installs Clickthroughs
June 2024 121/665 179 22
May 2024 120/682 275 21
April 2024 135/687 242 17
March 2024 145/694 238 12
February 2024 131/687 228 8
January 2024 112/691 325 15
December 2023 140/671 235 18
November 2023 136/686 286 15
October 2023 123/673 323 12
September 2023 127/663 292 15
August 2023 112/673 321 16
July 2023 108/668 359 12
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for IntelliJ IDEA keymap for Eclipse.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

I had an earlier version of Eclipse and installed this plugin, it worked just fine even when I updated Eclipse to the latest. Now that I have installed 2019-06 (fresh installation) on a new machine, I cannot install the plugin. It returns an error message that it's not compatible. Any tips?