Dart Designer

Add this URL to your Eclipse Installation to reach this solution's update site.

2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1)

https://dartdesigner.github.io/p2/releases/v0.4.0/

Learn more...
Solution Description

Dart Designer is a graphical tool for Dart Developers. It allows you to specify your Dart application directly from Eclipse thanks to several kinds of diagrams (Class, Explorer, Library, Module, Route, Package). It also comes with support for AngularDart. It can also be downloaded as a stand alone product from its official website. Release notes

Categories: Modeling, Modeling Tools, Tools, Web

Additional Details

Eclipse Versions: 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Obeo

Development Status: Production/Stable

Date Created: Wednesday, August 6, 2014 - 13:05

License: EPL

Date Updated: Thursday, November 10, 2022 - 05:11

Submitted by: Stephane Begaudeau

Screenshot
Date Ranking Installs Clickthroughs
March 2024 0/0 0 0
February 2024 624/687 2 20
January 2024 0/0 0 22
December 2023 544/671 4 28
November 2023 649/686 1 12
October 2023 631/673 2 12
September 2023 556/663 4 16
August 2023 553/673 4 19
July 2023 543/668 5 16
June 2023 647/669 1 7
May 2023 579/671 3 8
April 2023 0/0 0 10
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Dart Designer.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client