Spring Tools 4 (aka Spring Tool Suite 4)

Add this URL to your Eclipse Installation to reach this solution's update site.

2024-06 (4.32)

https://cdn.spring.io/spring-tools/release/TOOLS/sts4/update/e4.32/

2024-03 (4.31)

https://cdn.spring.io/spring-tools/release/TOOLS/sts4/update/e4.31/

2023-12 (4.30)

https://cdn.spring.io/spring-tools/release/TOOLS/sts4/update/e4.30/

Learn more...
Solution Description

Spring Tools 4

Spring Tools 4 is the next generation of Spring tooling for your favorite coding enrivonment. Largely rebuilt from scratch, it provides world-class support for developing Spring-Boot-based enterprise applications, whether you prefer Eclipse, Visual Studio Code, or Eclipse Theia.

Getting Started

Spring Tool Suite 4 makes it easy to get started. A direct and easy-to-use integration of the Spring Initializr and the famous Spring Guides allows you to go from nothing to a running Spring Boot app in seconds.

Navigate your Spring code at the speed of light

Understanding and quickly navigating source code is essential for coding. The new Spring Tools 4 understands your Spring-Boot-based source code and allows you to quickly get an overview and navigate to the important pieces of your Spring apps. Finding Spring elements and navigating to them has never been easier.

Smart Code Editing

Code completion is a critical part of working with source code. The all-new Spring Tools 4 provides smart code completions for the Spring elements in your app.

Runtime Information In Your Editor

Spring Tools 4 now bridges the gap between your source code and running Spring Boot applications. By taking advantage of the Spring Boot Actuators, we enriched the source code with detailed information from the running app (e.g., exact bean wiring information, conditional reports, configuration, details, and more).

Categories: IDE

Additional Details

Eclipse Versions: 2024-06 (4.32), 2024-03 (4.31), 2023-12 (4.30)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Broadcom

Development Status: Production/Stable

Date Created: Friday, July 11, 2014 - 12:41

License: EPL

Date Updated: Monday, June 17, 2024 - 11:07

Submitted by: Martin Lippert

Date Ranking Installs Clickthroughs
June 2024 1/665 16049 26
May 2024 1/682 22708 46
April 2024 2/687 21883 67
March 2024 2/694 23743 98
February 2024 2/687 20741 71
January 2024 1/691 24074 63
December 2023 1/671 21360 32
November 2023 1/686 24213 41
October 2023 1/673 25119 56
September 2023 1/663 26158 82
August 2023 2/673 24515 57
July 2023 2/668 25624 49
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 458

Count Error Message
319 Cannot continue the operation. There is another install operation in progress.
29 Cannot complete the install because one or more required items could not be…
21 Cannot complete the install because one or more required items could not be…
7 Cannot complete the install because one or more required items could not be…
7 Cannot complete the install because one or more required items could not be…
7 Cannot complete the install because one or more required items could not be…
6 Cannot complete the install because one or more required items could not be…
5 无法继续操作。正在执行另一个安装操作。
5 操作を続行できません。 別のインストール操作が進行中です。
4 Cannot complete the install because one or more required items could not be…
4 Cannot complete the install because one or more required items could not be…
4 Cannot complete the install because one or more required items could not be…
4 Cannot complete the install because one or more required items could not be…
4 Cannot complete the install because one or more required items could not be…
4 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because one or more required items could not be…
2 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 No se puede completar la instalación porque no se han podido encontrar uno o…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because of a conflicting dependency. Software…
1 Cannot complete the install because of a conflicting dependency. Software…
1 Cannot complete the install because of a conflicting dependency. Software…
1 Cannot complete the install because of a conflicting dependency. Software…
1 Cannot complete the install because of a conflicting dependency. Software…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because one or more required items could not be…
1 Cannot complete the install because of a conflicting dependency. Software…
1 Cannot complete the install because one or more required items could not be…
Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Spring Tools 4 (aka Spring Tool Suite 4).

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Cannot complete the install because of a conflicting dependency.
 Software being installed: Spring Boot Language Server Feature 4.21.1.202401312010 (org.springframework.tooling.boot.ls.feature.feature.group 4.21.1.202401312010)
 Software currently installed: JustJ OpenJDK Hotspot JRE Complete 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full.feature.group 16.0.2.v20210721-1149)
 Only one of the following can be installed at once: 
   JustJ Adoptium OpenJDK Hotspot JRE Complete for Linux x86 64 bit 17.0.1.v20211116-1657 (org.eclipse.justj.openjdk.hotspot.jre.full.linux.x86_64 17.0.1.v20211116-1657)
   JustJ OpenJDK Hotspot JRE Complete for Linux x86 64 bit 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full.linux.x86_64 16.0.2.v20210721-1149)
 Cannot satisfy dependency:
   From: JustJ OpenJDK Hotspot JRE Complete 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full 16.0.2.v20210721-1149)
   To: org.eclipse.equinox.p2.iu; a.jre.javase 0.0.0
 Cannot satisfy dependency:
   From: JustJ OpenJDK Hotspot JRE Complete 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full.feature.group 16.0.2.v20210721-1149)
   To: org.eclipse.equinox.p2.iu; org.eclipse.justj.openjdk.hotspot.jre.full [16.0.2.v20210721-1149,16.0.2.v20210721-1149]
 Cannot satisfy dependency:
   From: JustJ OpenJDK Hotspot JRE Complete 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full.feature.group 16.0.2.v20210721-1149)
   To: org.eclipse.equinox.p2.iu; org.eclipse.justj.openjdk.hotspot.jre.full.linux.x86_64 [16.0.2.v20210721-1149,16.0.2.v20210721-1149]
 Cannot satisfy dependency:
   From: Spring Boot Language Server Feature 4.21.1.202401312010 (org.springframework.tooling.boot.ls.feature.feature.group 4.21.1.202401312010)
   To: org.eclipse.equinox.p2.iu; org.springframework.tooling.ls.eclipse.gotosymbol 0.0.0
 Cannot satisfy dependency:
   From: Goto Symbol Popup 4.21.1.202401312010 (org.springframework.tooling.ls.eclipse.gotosymbol 4.21.1.202401312010)
   To: osgi.bundle; org.springsource.ide.eclipse.commons.livexp 3.9.2.201711101829
 Cannot satisfy dependency:
   From: Eclipse Integration Commands - Livexp 4.21.1.202401312010 (org.springsource.ide.eclipse.commons.livexp 4.21.1.202401312010)
   To: osgi.ee; (&(osgi.ee=JavaSE)(version=17))

Cannot complete the install because one or more required items could not be found.
  Software being installed: Test 4.16.0.202209151144 (org.springframework.ide.eclipse.boot.refactoring.test 4.16.0.202209151144)
  Missing requirement: Test 4.16.0.202209151144 (org.springframework.ide.eclipse.boot.refactoring.test 4.16.0.202209151144) requires 'osgi.bundle; org.springsource.ide.eclipse.commons.frameworks.test.util 0.0.0' but it could not be found

Any idea how to fix this?

In reply to by dan mul

The error message complains about missing test bundles, which you don't need when installing the Spring Tools into an existing Eclipse installation. You should select the features under the `Spring Tools` category only, that is all you need. And those features don't require the mentioned test bundles. If that doesn't help, please provide more details how you are trying to install the Spring Tools and what you select along the way.

I am currently using the latest Ecipe IDE 2023-03. I tried installing Spring tool suite plugin 4. But getting below error.

An error occurred while collecting items to be installed

session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.docker.client,4.18.0.202303131455.

Unexpected end of ZLIB input stream

Problems downloading artifact: osgi.bundle,org.springframework.tooling.boot.ls,1.45.0.202303131439.

Unexpected end of ZLIB input stream

In reply to by Mani Shankar

This looks like a network glitch when downloading the artifacts or a proxy server getting into the way. Please try again. If this doesn't help, some cache might be causing this broken file to stick around, so please search for the files with those names "org.springframework.ide.eclipse.docker.client" and "org.springframework.tooling.boot.ls" and delete them from the cache. Hope that helps!

I just downloaded the fresh new eclipse 2021-03

And tried to install the Spring Tools 4 (aka Spring Tool Suite 4) 4.16.0.RELEASE

and get an error

 

An error occurred while collecting items to be installed
session context was:(profile=C__Users_USER_eclipse_jee-2021-03_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: org.eclipse.update.feature,org.springframework.boot.ide.main.feature,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile1876944857825585191.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile1876944857825585191.jar
Problems downloading artifact: binary,org.springframework.boot.ide.main.feature_root,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile12070795579585830381.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile12070795579585830381.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.beans.ui.live,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile10121475783448603332.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile10121475783448603332.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile17051854768075728731.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile17051854768075728731.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.dash,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile8460387033181811053.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile8460387033181811053.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.dash.cf,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile15210498082742908282.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile15210498082742908282.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.dash.docker,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile3019042021063636405.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile3019042021063636405.jar
Problems downloading artifact: org.eclipse.update.feature,org.springframework.ide.eclipse.boot.dash.feature,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile11191471768839562602.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile11191471768839562602.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.launch,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile10504280315253181781.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile10504280315253181781.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.refactoring,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile8229219830000694944.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile8229219830000694944.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.restart,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile772916117885769972.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile772916117885769972.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.templates,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile15054241124754490012.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile15054241124754490012.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.validation,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile14662212615252592785.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile14662212615252592785.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.boot.wizard,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile12655096541485575286.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile12655096541485575286.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.buildship30,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile13161971386331894635.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile13161971386331894635.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.docker.client,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile9770843718449998045.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile9770843718449998045.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.imports,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile3386152666453344553.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile3386152666453344553.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.maven.pom,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile15771303302109356316.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile15771303302109356316.jar
Problems downloading artifact: osgi.bundle,org.springframework.ide.eclipse.xml.namespaces,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile11882986681527639459.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile11882986681527639459.jar
Problems downloading artifact: org.eclipse.update.feature,org.springframework.ide.eclipse.xml.namespaces.feature,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile1159917228674937191.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile1159917228674937191.jar
Problems downloading artifact: osgi.bundle,org.springsource.ide.eclipse.commons.cloudfoundry.client.v2,4.16.0.202209151144.
Error reading signed content:C:\Users\USER\AppData\Local\Temp\signatureFile4966800356210815978.jar
An error occurred while processing the signatures for the file: C:\Users\USER\AppData\Local\Temp\signatureFile4966800356210815978.jar

In reply to by Joe Hsu

It looks like you are using an updated Eclipse version (2021-03) here, for which the latest versions of the Spring Tools 4 (on the Eclipse Marketplace) are no longer compatible with. Therefore, you are running into an issue, most likely the installation process tries to install components from a newer Eclipse platform version (alongside the Spring Tools components) that use a newer signing infrastructure - which then results in the above mentioned error.

The best solution here would be to use a more recent Eclipse platform (2022-09 at the time) and install the Spring Tools 4 on top of that Eclipse - or grab the latest ready-to-use distribution from https://spring.io/tools.

If you have to use the 2021-03 Eclipse (for whatever reason), you can install an old version of the Spring Tools 4 using the "Install New Software" menu item and then this update repository: https://download.springsource.com/release/TOOLS/sts4/update/4.12.0.RELE…

It will give you the latest version of the Spring Tools 4 that was compatible with that version of Eclipse - but it is an outdated and no longer supported version, so I don't recommend this option and would strongly recommend to use the latest version instead - if at all possible.

Just downloaded a fresh install of Eclipse Version: 2022-09 (4.25.0) - Build id: 20220908-1902, and fired up Marketplace to install Spring Tools 4 (4.16.0.RELEASE). I only kept the two required components and clicked on Install. As it's downloading, a "Trust" dialog popped up asking me to trust the expired certificates from Pivotal - the expiration dates were 2018 and 2020. Google search turned up nothing. Can I continue installation without trusting the expired certificates?

In reply to by Agumamidi Manvitha

This is usually caused by some stale cache data. You can fix this by going to the Preferenes -> Install/Update -> Available Update Sites, then select the one you mentioned, and press "Reload". This usually solves the problem.

In case this doesn't help, delete the entry from the list of available update sites, restart the IDE, and add the entry back to the list. That should work as a last resort if everything else failed.

  1. Go to Eclipse Marketplace
  2. Search for STS
  3. Select Spring Tools 4 (aka Spring Tool Suite 4) 4.10.0.RELEASE and hit Install
  4. Hit Confirm button 
  5. Get error:

Unable to read repository at

https download.springsource.com/release/TOOLS/sts4/update/e4.19/content.xml.
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I read few of your answers on here, none of which helped.

I tried also placing the above URL (with https and http) in Install New Software and that failed with

Unable to read repository at

https download.springsource.com/release/TOOLS/sts4/update/e4.19/content.xml/content.xml.
Unable to read repository at

https download.springsource.com/release/TOOLS/sts4/update/e4.19/content.xml/content.xml.
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Also tried installing STS4 IDE which worked fine but it keeps removing my Websphere Liberty node from Define New Server dialog when I right click in Servers tab > New Server > IBM > Websphere Liberty, so that is useless as well.

Note, the above urls have removed "://" because this site does not allow comments with extermal urls, also not helpful at all.

Please help

In reply to by Martin Lippert

Thak you Martin.  However, that stackoverlow did not help.  I saw that post before I asked here and I followed it again.  While I have been able to add certificate as described (making below assumptions as the explanation was not clear on that), I am still unable to install STS4 into my Eclipse 2021-03.

Following the SO link you provided:

  1. I navigated in Chrome to https://marketplace.eclipse.org/content/spring-tools-4-aka-spring-tool-… - I assume this is where I should be to export the certificate
  2. Following Stackoverflow link, I exported the certificate and used keytool to add it to my jdk1.8/jre/lib/security/cacerts
  3. I even confirmed it has been added, also using keytool to list certificates
  4. Restarted my machine, restart Eclipse > Help > Market place > search for "STS" > Select STS4 > Install
  5. Got box listing what will be installed > Confirm
  6. My C:/Program Files/Java has two versions jdk 1.8.0_172 and jdk-11.0.10.  I did the above for jdk 1.8.0_172 as that is the jdk in my System Path variable.

And ended up with the same error as described in my original question

 

Hello,

I have eclipse JEE 03-2021 R and  the last plugin Spring 4.

why the "Edit starter" is missing (in sub-menu Spring) when you make a right click on pom.xml file ?

It was very apprecied !!

In reply to by Richard Dutellier

Hey! The "add starters" menu option is indeed gone (since a few releases already), but I got replaced with a new "Add Starters" menu item that you should be, which also allows you to add starter modules from start.spring.io and even brings more goodies from start.spring.io into the IDE here, e.g. additional resources that start.spring.io would generate for you, new properties in your properties file (in case the selected modules include them), etc. Here is a user guide for this new way to add starters to your project: https://github.com/spring-projects/sts4/wiki/Add-Spring-Boot-Starters-T…

Hope that helps and that you like the new wizard!!!

In reply to by Martin Lippert

Hello Martin,
Thank you for your answer.
Yes I know this procedure which you mentioned in the web link.
But I'm sorry, I prefer the old method with the 'Edit starters' option ...
When we choose 'Add starters', why in the graphical interface, you don't add an 'already selected' section in addition to the 'selected' section?
I think it's important to quickly have a graphic visual, rather than making a comparison with the xml file ...
The 2 ways can be complementary ...
Maybe it's hard to implement the code to be able to do this? ^^

In reply to by Richard Dutellier

Hey Richard,

your feedback on this is much appreciated. The reason why we no longer do something like a "pre-selection" is starter modules that you already have on your project is based on the latest generations of the initializr project and the way that works. When you select starter modules in there, the resulting project might not exactly contain those modules exclusively. There is logic in initializr and some of the starter modules to do more sophisticated things, like automatically adding additional other starters for you. And there is no "inverted logic" in there, which infers which starters you would need to select in order to produce the set of starters that you have. Therefore we don't really have a way to implement this "inverted logic". (This gets even more complicated if users edited their pom.xml file (in case you use Maven) manually). Therefore we decided to not implement any logic to pre-select existing starters on your project. Sorry for not being able to bring this pre-selection back. Hope you find the new wizard useful nevertheless. If you have additional suggestions, please raise them as enhancement requests here: https://github.com/spring-projects/sts4/issues.

 

 

In reply to by Richard Dutellier

Actually, identifying dependencies of a project is not that complicated in an IDE, since the Maven integration for Eclipse in this case already does that work for you - and that is what the pom dependency analyzer tool would do as well in case I understood this. The difficult part is to calculate the pre-selection on start.spring.io that would lead to the pom that you analyze. It is not a 1-to-1 mapping (for a good reason actually, from the project-generation perspective).

In reply to by Alex Xavier

Hey! That sounds like an issue with the installation and the underlying bundles being maybe wired in a weird way. The best way forward would be a submit an issue at https://github.com/spring-projects/sts4/issues and tell us exactly which package of Eclipse 2021-03 you installed, which other third-party plugins you added, and how you installed the STS4 components then. I used the Eclipse JEE paclage of 2021-03 and installed STS4 from the Eclipse marketplace and that seemed to work, so we need to take a closer look at your exact setting in which you are trying to install the Spring Tools 4.

As a quick fix for you, feel free to download a ready-to-use distribution of the Spring Tools 4 for Eclipse from https://spring.io/tools. Version 4.10.0 of the Spring Tools 4 for Eclipse are a distribution built on Eclipse 2021-03, so you will get the latest in here as well.

In reply to by HANGYU LI

If you want to install Spring Tools 4 into an existing Eclipse installation, you can choose the "Eclipse Marketplace..." menu entry, then search for Spring, pick the "Spring Tools 4" entry, and press the "Install" button.

The JAR file that you can download from the https://spring.io/tools page is a self-extracting full distribution of the Spring Tools 4 for Eclipse (including an Eclipse 2020-12 with pre-installed Spring Tools 4 extensions). You can download the JAR and double-click it. It will then self-extract the full distribution.

In reply to by Lonnie Phillips

From the brief description it sounds like an installation issue or an incompatibility from under the hood somewhere. I would recommend to file an issue at https://github.com/spring-projects/sts4/issues/ and provide some detais (maybe a few steps to reproduce), and we can continue from there to find out what is going wrong there.

If you are not tied to Eclipse 2020-06, I could also recommend to download a ready-to-use distribution of the latest Eclipse release (2020-12) with all the Spring Tools 4 pre-installed from https://spring.io/tools.

Got the new Eclipse 2020-06 and installed Spring Tools 4 4.6.2.RELEASE and Spring Tools 3 Add-On for Spring Tools 4 3.9.13.CI. Now I am unable to find the Boot Dashboard in the Eclipse > Window > Show View. Is this view still available in the new ST 4 plugin for eclipse?
 

Hey,

I just installed a fresh download of Eclipse version: 2020-06 (4.16.0) and then installed the Spring Tool Suite 4 for Eclipse (4.6.2 update e4.16)  on my Windows 10.

It seems there is no Spring Boot Dashboard which was available in Eclipse 4.15.

How do I make the Spring Boot Dashboard available in Eclipse 4.16?

Any help is greatly appreciated!

 

This plug in is crashing hanging and crashing my Eclipse as of 2020-03-27, I am running Ubuntu 18+ ( b4bit, fully updated/upgraded) as of Mar-27.  This Ubuntu is running in Vmware Station inside Window 10/64bit.

I tried removing eclipse and all the dot file, creating new workspace and as soon as I add this plug in Eclipse crashed come back mainly when I want to highligh and replace a word in JAVA code.  As soon as I remove the plug in and restart Eclipse, all is ok.

In reply to by Alex Atari

That sounds indeed bad. Can you pleaee file a bug at https://github.com/spring-projects/sts4/issues/ for this and tell us how to reproduce this crash? Is it really the JVM that is crashing or is it a freeze at the UI, so that the process isn't responding anymore? Is there something in the Error Log View that relates to the problem? Or is the VM itsel crashing and in case that happens, is there a JVM crash log file tha you could attach? In case the process freezes, there is a setting in the "Preferences -> General -> UI Responsiveness Monitoring" that you could turn on to capture stack traces while the UI seems to be frozen. That would be great and help us a lot to find the underlying issues.

An error occurred while collecting items to be installed
session context was:(profile=_home_stesin_eclipse_jee-2020-03_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,io.projectreactor.reactor-core,3.3.1.202003091750-RELEASE
No repository found containing: osgi.bundle,org.reactivestreams.reactive-streams,1.0.3
No repository found containing: org.eclipse.update.feature,org.springframework.boot.ide.main.feature,4.6.0.202003181317-RELEASE
No repository found containing: binary,org.springframework.boot.ide.main.feature_root,4.6.0.202003181317-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui.live,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.dash,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.dash.cf,3.9.12.202003180620-RELEASE
No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.boot.dash.feature,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.launch,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.refactoring,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.restart,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.templates,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.validation,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot.wizard,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.buildship20,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.buildship30,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.editor.support,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.imports,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.maven.pom,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.ide.eclipse.xml.namespaces,3.9.12.202003180620-RELEASE
No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.xml.namespaces.feature,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springframework.tooling.boot.ls,1.15.0.202003180840
No repository found containing: org.eclipse.update.feature,org.springframework.tooling.boot.ls.feature,4.6.0.202003180840
No repository found containing: osgi.bundle,org.springframework.tooling.bosh.ls,1.15.0.202003180840
No repository found containing: org.eclipse.update.feature,org.springframework.tooling.bosh.ls.feature,4.6.0.202003180840
No repository found containing: osgi.bundle,org.springframework.tooling.cloudfoundry.manifest.ls,1.15.0.202003180840
No repository found containing: org.eclipse.update.feature,org.springframework.tooling.cloudfoundry.manifest.ls.feature,4.6.0.202003180840
No repository found containing: osgi.bundle,org.springframework.tooling.concourse.ls,1.15.0.202003180840
No repository found containing: org.eclipse.update.feature,org.springframework.tooling.concourse.ls.feature,4.6.0.202003180840
No repository found containing: osgi.bundle,org.springframework.tooling.jdt.ls.commons,4.6.0.202003180840
No repository found containing: osgi.bundle,org.springframework.tooling.ls.eclipse.commons,4.6.0.202003180840
No repository found containing: osgi.bundle,org.springframework.tooling.ls.eclipse.gotosymbol,4.6.0.202003180840
No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.cloudfoundry.client.v2,3.9.12.202003180620-RELEASE
No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.core,3.9.12.202003180611-RELEASE
No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.frameworks.core,3.9.12.202003180611-RELEASE
No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.frameworks.ui,3.9.12.202003180611-RELEASE
No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.jdk_tools,3.9.12.202003180611-RELEASE
No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.livexp,3.9.12.202003180611-RELEASE
No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.ui,3.9.12.202003180611-RELEASE

When use JRE1.7 to run my Springboot project, it fail to start with error "Unrecognized VM option 'TieredStopAtLevel=1'" shown in the eclipse console.  But if I use JRE1.8, it's working well.  Unfortunately, JRE1.7 is requested in my project.

I searched settings but can't find place to remove this VM option.

Could you tell me how to fix this issue?

In reply to by Martin Lippert

Thanks your answer, I found the place and remove the option. However, still not working with another error when I run the application.... seems it's stil a problem of JDK. I have synchronized all configuration place in eclipse with JDK1.7.0 (such as project compiler,classpath settings, eclipse preferences etc). Spring boot version I use is 1.5.9 Release.

The error is "Could not find the main class".   then I copy the command and run in the dos window, it says that:"Exception in thread "main" java.lang.UnsupportedClassVersionError: cn/com/MainApplication : Unsupported major.minor version 51.0". I know the 51.0 means the version jdk1.7, but I am using JDK1.7.

Could you give some advice?  Does STS4 support JDk1.7?

 

In reply to by James Balaji

STS4 in general supports implementing and running applications on top of a JDK7. You need to configure the JDK7 runtime environment in the preferences (as you probably did) and select it as the default for the JavaSE7 execution environment. Make sure it appears correctly as the entry in your project classpath containers in the packag explorer.

In addition to that you need to make sure to compile your project on a Java7 level by setting the compiler level in the Java compiler preferences for your project.

Then in the launch configuration, you should make sure that the JDK7 is used to launch the app. This "could not find main class" is usually related to some misconfigured JRE settings in the areas described above.

Hope this helps!

hi Martin, may I have your advice for this installation issue?

Eclipse Version: 2019-12 (4.14.0)
Build id: 20191212-1212

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
org.springframework.tooling.boot.ls_1.15.0.202001210741.jar.
Read timed out
org.springframework.tooling.bosh.ls_1.15.0.202001210741.jar.
Connection reset
Unable to read repository at
org.springframework.tooling.cloudfoundry.manifest.ls_1.15.0.202001210741.jar.
Read timed out
Unable to read repository at
org.springframework.tooling.concourse.ls_1.15.0.202001210741.jar.
Read timed out

In reply to by Simon Wang

This problem is a bit complicated to analyze remotely, since it is not totally clear where this comes from. Here is what you could do to solve this:

  • go to the "Preferences -> Install/Update -> Available Update Sites", select the one for the Spring Tools 4 and press "Reload". Maybe that solves the problem already.
  • If not, remove that update site from the preferences and restart your IDE. Then try the install again.
  • If all that doesn't help, try to install the feautes manually, as described here: https://github.com/spring-projects/sts4/wiki/Installation#install-sprin…

Hope that helps.

I have installed STS 4.4.1 from the Eclipse (4.13 64bit) marketplace and don't see the create new project option after restarting the IDE. There were no error during installation. I have tried with JDK 11 and 13 without success.

In reply to by Pascal Houde

Sorry for the late answer, somehow missed the question here. You could analyze the underlying issue by opening up the console, opne an OSGi Host Console, and type in "ss" for "short status". If there is anything showing up as "INSTALLED", something went wrong with regards to the dependency resolution of bundles. This is hard to debug and to solve. In that case, I would recommend to download a ready-to-use distribution from https://spring.io/tools and go from there. If the list of bundles shows up fine (nothing in the "INSTALLED" state), then the wizard to create a new project using Initializr (e.g.) should show up ("Spring Starter Project") in a "Spring" category.

Have problem with PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException.

Can I download ZIP to local and install ?

I am using Eclipse 4.8 Photon and I want to install Spring Tools Suite. The least support version for Spring Tools Suite is 4.9 and predecessor Spring IDE max support is till 4.5 only.

How to install the STS for the eclipse versions 4.6,4.7, and 4.8?