Telosys code generator for Java, JavaScript, Python, NodeJS, PHP, C#, JavaEE, Spring, JAX-RS, VueJS, Angular, JPA, etc

Add this URL to your Eclipse Installation to reach this solution's update site.

2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), 2021-12 (4.22), 2022-03 (4.23), 2022-06 (4.24), 2022-09 (4.25), 2022-12 (4.26), 2023-03 (4.27), 2023-06 (4.28), 2023-09 (4.29), 2023-12 (4.30), 2024-03 (4.31)

https://www.telosys.org/eclipse/plugin

2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), 2020-09 (4.17), 2020-12 (4.18), 2021-03 (4.19), 2024-03 (4.31)

https://www.telosys.org/eclipse/v323

Learn more...
Solution Description

The "Telosys" plugin is designed to generated any kind of code (Java, PHP, JavaScript, Python, Golang, Scala, etc) for any kind of framework (Spring, AngularJS, JPA, CodeIgniter, etc...)

It works with 2 kinds of models: database model (created from a database schema) and DSL model (specific model designed from scratch and based on text files).

It uses customizable templates to generate the code (templates syntax is based on Velocity)

Telosys provides scaffolding capabilities, it's possible to generate CRUD screens or REST backend in a few minutes.

And everything is Open Source (code and templates).

Web site : https://www.telosys.org

Documentation https://doc.telosys.org

GitHub https://github.com/telosys-eclipse-v3/TelosysToolsPlugin

Twitter : https://twitter.com/telosys

News https://news.telosys.org/

Additional Details

Eclipse Versions: 2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), 2021-12 (4.22), 2022-03 (4.23), 2022-06 (4.24), 2022-09 (4.25), 2022-12 (4.26), 2023-03 (4.27), 2023-06 (4.28), 2023-09 (4.29), 2023-12 (4.30), 2024-03 (4.31), Mars (4.5), Luna (4.4), Kepler (4.3)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Telosys

Development Status: Mature

Date Created: Thursday, December 1, 2011 - 08:50

License: EPL

Date Updated: Friday, October 6, 2023 - 10:49

Submitted by: Laurent Guerin

Screenshot
Date Ranking Installs Clickthroughs
February 2024 144/683 186 18
January 2024 139/691 229 23
December 2023 145/671 215 12
November 2023 144/686 247 10
October 2023 101/673 419 19
September 2023 95/663 437 10
August 2023 88/673 457 10
July 2023 95/668 427 8
June 2023 97/669 457 13
May 2023 88/671 549 10
April 2023 89/667 525 11
March 2023 91/686 580 14
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Telosys code generator for Java, JavaScript, Python, NodeJS, PHP, C#, JavaEE, Spring, JAX-RS, VueJS, Angular, JPA, etc.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

New version 3.2.3 with new annotations for the DSL model
This version also fix bundle installation problem caused by the new GitHub API

It saves many days of workload. 
Very efficient for project bootstrapping.
With the customizable templates I generate exactly what I want.

Hello,
I have just installed telesys eclipse plugin. It looks great.
I followed the tutorials with default db derby.
However, then when I wanted to try it with DB2 it throws error.:
[LOG] ConnectionManager constructor ...
[LOG] DriverLoader constructor ...
[ERROR] DriverLoader constructor : 'libraries' is void !
-----
Exception : org.telosys.tools.commons.TelosysToolsException
Message : DriverLoader constructor : 'libraries' is void !

If someone can help me I will appreciate.

Thanks and Regards

Yılmaz

In reply to by Yılmaz Ay

By the way, my telosys version is 2.1.1 and eclipse version is Neon.
Telosys worked fine with derby without any problems.
Then I tried the same steps with a DB2 database.
At the database connection configuration step it failed, I cannot move further.
However, I already created a db2 database connection in the eclipse itself without any problem. (after uploading db2 jdbc drivers of course)
I am looking forward to your suggestions.

Thanks in advance.

In reply to by Yılmaz Ay

It’s because Telosys cannot found the DB2 JDBC driver. Telosys tries to load the JDBC driver from the project classpath (if the project is a Java project) and from the “TelosysTools/lib” folder. So just add it in the classpath (or in the pom.xml for a Maven project) or copy the jar file in the “lib” folder. In the “.dbcfg” editor click the button “Show libraries” to check if the jar is in the list.

Telosys 2.1.1 used as eclipse plug-in, with mysql connection (connection tested)
"generate repository" return the error:

Exception org.telosys.tools.common.TelosysException: SQLException

Exception com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the tight syntax to use near'match WHERE 1=0 at line 1

In Oracle Long, Integer, Byte, Boolean , Float, BigIntiger, BigDecimal all can be stored as NUMBER with scale and precision. There needs a way of telling this tool based on scale an precision map to configurable Java type. Is there a way

Unfortunately, I get a SQL error when generating the repository with an Oracle Database.

"Cannot generate. Exception org.telosys.tools.commons.TelosysToolsException : SQLException
Exception java.sql.SQLDataException : ORA-01424 : missing or illegal character following the escape character"

=> Do you know if I can get a log with the generated SQL in order to understand where this syntax error may come from ?

Thanks very much.

Here is my configuration :

- Telosys Tools 2.0.4
- Oracle 11.2.0.3.0
- ojdbc6.jar

name = "Oracle - TelosysBookStore DB"
driver = "oracle.jdbc.driver.OracleDriver"
url = "jdbc:oracle:thin:sonar/sonar@192.168.2.53:1521:XE"
isolationLevel = "TRANSACTION_READ_COMMITTED"
poolSize = "3" >


Unfortunately, generating the repository with an Oracle configuration generates the following error :
"Cannot generate. Exception org.telosys.tools.commons.TelosysToolsException : SQLException
Exception java.sql.SQLDataException : ORA-01424 : missing or illegal character following the escape character"

Here is my configuration :
Telosys Tools 2.0.4
Oracle jdbc driver : ojdbc6.jar

name = "Oracle - TelosysBookStore DB"
driver = "oracle.jdbc.driver.OracleDriver"
url = "jdbc:oracle:thin:sonar/sonar@192.168.2.53:1521:XE"
isolationLevel = "TRANSACTION_READ_COMMITTED"
poolSize = "3" >


Thanks for your help.

Antoine Larcher

Unfortunately, getting metadata doesn't work for Oracle Db.
Tried to use it in eclipse helios (Win 7).
Oracle Database 10g Express Edition Release 10.2.0.1.0 - Production