TestNG for Eclipse

Add this URL to your Eclipse Installation to reach this solution's update site.

2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1)

https://testng.org/testng-eclipse-update-site

Learn more...
Solution Description

This plug-in lets you run your TestNG tests from Eclipse. You can run suites, groups or individual methods. Errors are reported in a separate tab that lets you jump to failing tests efficiently. The plug-in also contains several templates to create tests easily.

Categories: Testing

Additional Details

Eclipse Versions: 2018-09 (4.9), Photon (4.8), Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Cédric Beust

Development Status: Production/Stable

Date Created: Thursday, June 24, 2010 - 09:51

License: Apache 2.0

Date Updated: Tuesday, May 30, 2023 - 01:28

Submitted by: Cedric Beust

Screenshot
Date Ranking Installs Clickthroughs
June 2024 2/645 12320 14
May 2024 2/682 22287 172
April 2024 1/687 22253 25
March 2024 1/694 25158 28
February 2024 1/687 22810 288
January 2024 2/691 21962 48
December 2023 2/671 21040 16
November 2023 2/686 21274 26
October 2023 2/673 23525 34
September 2023 2/663 23802 15
August 2023 1/673 26550 25
July 2023 1/668 27304 19
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 234

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for TestNG for Eclipse.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

I tried to download " Testng for Eclipse" from Eclipse Marketplace but an error message appear to me inside it the sintance [[ The following solutions are not compatible with this version of Eclipse ]] ,, So What's the solution for this problem to enable me start using this programme in my work

To import the plugin from eclipse-2018-09 into the latest eclipse-2019-03.
This is the way to import, File -> Export -> Install -> Installed software from existing installation, and then follow the steps.

TestNG is only available only for version till (4.9)2018-09 , you hv not made plug in for 2018-12.that's why it is not showing in marketplace when i keep draging this s/w .plz make available this plug in as it is helpful for many 2018-12 Eclipse IDE users.

I've tried to install TestNG multiple times, on my Mac; but, the guy's web-site has been down.  The entire site (beust.com) returns an HTML 503 error every time you try to install the platform. Hey Beust, have you considered leveraging one of the Cloud providers.  With a static webpage, you just need to publish the code to an Amazon S3 bucket.  Viola, Instant High Availability.

I've been doing a review of some of the basics, in the current situation, Beginning Hibernate.  But, the authors used TestNG rather than JUnit, and just doing the Maven install of the TestNG package doesn't seem to be sufficient to get the tests to run.

In Neon, TestNG options would show up at the top of the auto complete at weird times. The proposals occurred for projects without any testing or inclusion of TestNG. I finally just uninstalled the plugin.

The auto complete problem may be a Neon issue and not a TestNG issue. I will leave the problem to the TestNG people to figure out.