Eclipse Foundation Member
Darkest Dark Theme with DevStyle

Add this URL to your Eclipse Installation to reach this solution's update site.

2018-09 (4.9)
Photon (4.8)
Oxygen (4.7)


Neon (4.6)


Learn more...

Details Group Tabs

Wednesday, October 17, 2018 - 21:46
qguanqunkcn's picture

this is the best plug i have ever see . it make me comfortable ,and no manner of slow 

rduthie's picture

I've been using Darkest Dark for a while, with Eclipse Photon on CentOS 7 and MATE desktop, and had agiven up writing down the places where the theme was broken to the point of near unusability.  There were buttons which had white text on light-grey background etc., or search fields black text on a dark-grey background). 

HOWEVER the latest release (2017 CI 14 - cf., the Genuitec delivery log page) has solved all the problems that made the theme almost unusable.  I am very impressed.

There are a couple of things which are still not quite right, but I'll add these to the Genuitec forum for consideration.

Thank you for the nice plugin!  I'm now confident that this is something I'll use into the future.

tweddlelmg's picture

Thanks for the kind comments Roger. As you can imagine, this kind of endeavor can be very complex and, with multiple platforms, not to mention uncountable plugins, to accommodate, it can be very difficult to get it completely right 100% of the time but we have put a lot of effort in to correct reported problems even though this is completely free to use. So it's very gratifying to see that our efforts are being noticed.

Thanks again and, yes please, raise issues on the support forums, which is the best place, rather than our trying to deal with them on this review page.

jkaiseripy's picture

Hello, can i use this darkest dev style theme for youtube and my website as thumbnail and video.. When i have something to do, like paste the link in the descrption or so on, please tell it me ... Thanks XD ( I like the theme much ! )

tweddlelmg's picture

I'm not really sure what you're requesting, Jonathan but if you want to use it in an eclipse based application that you distribute, then please raise a topic on the Support page linked above and we'll direct you to the right person.

aparasana's picture

Liked overall, would love to have an extra feature where eclipse put a star beside a file which has local file changes that need to be checked out to SVN (like normal theme has). 

tweddlelmg's picture

Thanks for your comments, Arpit. Regarding the file change indicator for SVN files, I see a star decoration for changed files in my test, so I must have a different setup to you. Could you please raise the issue in our support forums: https://www.genuitec.com/forums/topics/devstyle/theme-problems/ ? Please include as much detail as possible, including the SVN plugin you're using, the version of eclipse, the DevStyle theme and your OS and version. Our support forums are a better way of addressing problems, rather than the comments section here and we should be able to get to the cause of the problem there.

aparasana's picture

"Heap status" on the bottom right corner on this theme has a black progress bar and text, so when progress bar overlaps the text, cannot read the text, as everything is dark.

tweddlelmg's picture

Arpit, apologies for my last reply to this issue. I was confusing a couple of features. Yes, there is a problem with the contrast between the heap status text and the color of the free space area, making the text difficult to read. I've raised a bug report for that. Sorry for the inconvenience.

tweddlelmg's picture

Arpit, if possible, could you raise the issue in our support forum at: https://www.genuitec.com/forums/topics/devstyle/theme-problems/ ? It's not clear what plugin is providing the heap status for you, as it isn't a standard part of eclipse. I do see something similar in the heap status available with MyEclipse and will raise a bug report for that (though the text is just readable). If you're not referring to MyEclipse, please give as much detail as possible in the support forum mentioned above.

achanda's picture

I have been looking for a true dark Eclipse for quite some time. I am so glad that I have it now!

emerino's picture

I just love the new 'Deep Black' theme within DevStyle!!! It is so cool and breath-taking that I got it installed on my Oxygen, Photon and even STS (Spring Tools Suite) and Angular-IDE!!! You may need to update DevStyle  to its latest version in order to see it and try it out, but one thing is for sure: you are going to love it too!!! ^_^

mpujos's picture

The new "Deep Black" theme is great. It improves readability, providing more contrast between backgrounds and UI / text.

Also congrats to Genuitec for actively listening to users and bug reports.

icendrero's picture

First of all, congrats for the great work.

After upgrading DevStyle to 1.11.0.201805291134 version, the horizontal scrollbar in editors is appearing like eclipse default instead of black and slim like DevStyle style. The vertical scrollbar still shown correctly.

With same config in previous version (1.11.0.201805291134) it works correctly and both scrollbars was shown acordling to theme.

Can you help me? Some suggestions? It's a known bug?

bfernandestdp's picture

Irina, thank you for the kind words!

We have had a couple of reports of this problem - what editor do you see it in? Our team is investigating, and working on a fix as we speak - we'll update here when one is avialable.

bfernandestdp's picture

Irina, just realized you had said "Java editor" in the subject already. Could you please take a look at this forum thread covering the same issue - it has details on installing a fix as well: https://www.genuitec.com/forums/topic/horizontal-scroll-bar-in-editor/

If you can let us know on the forum (or here) whether it fixes your problems, we'd be much obliged. Thanks!

kkaih3o's picture

After installing the theme, it looks really good!
However, I encountered a problem when creating a new project,
which is that the entire toolchain turned whiteout missing out the available choice of cross GCC and MinGW Gcc.This is comfirmed after changing the settings back to default.

I would loved to continue to use this theme.I'm using photon june2018.

Kai

tweddlelmg's picture

Kai,

Sorry you're seeing this issue. I tried a few ways to replicate it but, so far, haven't been able to. If possible, could you raise the issue on our support forums, so that we can better try to resolve the problem? For theme problems, please use: https://www.genuitec.com/forums/topics/devstyle/theme-problems/

Whether you post on the forums or not, please let us know the OS you're using and which DevStyle color theme you've selected, as well as the actions you're taking on the new project wizard to make sure we're looking at the same window. Additionally, if you've made any personalizations to the desktop in your OS, please mention that.

Thanks for your kind comments on the plugin. We'd sure like to improve it by resolving this issue and hope you can help us do so.

jzhaoa8q's picture

Hi, good plugin overall. I have one issue, when using the Darkest Dark theme, when adding new Java classes, in the new Java file window, the cursor for typing class name is black and it is on black background, which is hard to see. Can we improve this?

 

 

tweddlelmg's picture

Jingfeng Zhao, thanks for your comments on the plugin. I'm assuming that you're using a Mac, as I could only reproduce the issue on that OS. If you're using some other platform, please raise an issue on our support forums at https://www.genuitec.com/forums/topics/devstyle/theme-problems/

If you're on a Mac, the problem is seen in other wizards also but I note it doesn't stop use of those wizards. I've raised the problem with development and we will certainly seek to improve the experience here though there does seem to be a problem with dark themes generally (the standard eclipse Dark theme also exhibits the problem) so there might be an issue with the OS. However, we'll do our best to make this a better experience.

Thanks again for reporting the problem.

tmillerk5x's picture

It reverted my eclipse from photon to oxygen and locks up if i use my existing workplace, using a new workplace makes half of eclipse do nothing when i click on something, have to reinstall eclipse just to remove this

tweddlelmg's picture

Thomas,

We're keen to figure out what happened in your situation, both to help you and in case others come across it. We have thousands of Oxygen and Photon users of the plugin and, as Brian pointed out, we've tested extensively with both eclipse releases, including  with upgraded installs from Oxygen to Photon but have not seen the issue you're reporting. If you'd like to help resolve it, please raise the issue on our support forums where we can investigate it more thorougly as this is not the best forum for the exchanges that might be needed. We look forward to helping you at https://www.genuitec.com/forums/topics/devstyle/

bfernandestdp's picture

Thomas, I'm sorry you had a bad experience with DevStyle. DevStyle is compatible with Photon, and there's no way it can revert your installation back to Oxygen, unless a "downgrade path" was chosen during installation itself, perhaps due to other plugins you may have had installed. Our team has specifically tested multiple Photon installations, even those which had been upgraded from Oxygen, and it works as expected. Unfortunately, the downgrade could have resulted in a corrupted installation, and this is likely the cause of the lockups you experienced.

If you try DevStyle again, please note any issues / alt installation paths that are suggested during installation. We'll be happy to help with any installation issues you may have - you can report them here, or better still, use our support forum: https://www.genuitec.com/forums/topics/devstyle/

yshihouin's picture

Env: Windows 10 64-bit, Eclipse 4.7.3a

Hello, there is one more thing I have found so far after I issued the scrollbar problem.

If I try to scroll down until the end of the file on source code window in general, I can only see horizontally half of the last line number. However, if I execute scrolling on the 'line number panel' directly, it can be fully shown.

Thanks for your cooperation!

tweddlelmg's picture

Yoruichi,

A workaround for this issue is to maximize the editor (double click on the tab for this editor). I hope that helps until we fix this.

yshihouin's picture

Thank you Tony for you workarounds!

I tried maximizing the tabs and also picking out one of them to maximize it individually outside the editor.
However, both did not work well, though I can endure this somehow :)

Thanks again!

tweddlelmg's picture

Yoruichi, I couldn't quite replicate the problem as you described but I do see issues with the last line in some editors with certain themes, and I've rased the issue with the development team, at a hight priority. Thanks for reporting this and sorry you're seeing the issue.

yshihouin's picture

Thank you for your prompt reply, Tony! In my case, I used Darkest Dark theme and some of others.
I am looking forward to the improvements!

gpursehouse's picture

I dunno when this was added but for years there wasn't anything good to theme eclipse so I gave up. This should be merged into the core code! thanks!

tweddlelmg's picture

Thanks for the comment, Gareth, and thanks for taking the time to post it! It's much appreciated.

yshihouin's picture

Thanks for your effort for making this tool.
I just installed it few days ago and was wandering what's inside.

Currently, I'm using Windows 10 64-bit and Eclipse Oxygen.3a Release (4.7.3a).
Whenever I feel that the codes are horizontally too long, I tend to wrap them using Alt + Shift + Y hotkey.
Then, intuitively, a vertical scrollbar is expected to appear if the load of codes exceeds the screen, however, it did not appear.

At first, I thought, it is Eclipse which might have the problem, but after turning off the tool by changing the option in preference menu, I could see that scrollbar appeared well from inactive gray mode to active mode, for instance.

It would be appreciated if this problem is solved.
I send my gratitude in advance!

tweddlelmg's picture

Yoruichi, thanks for using DevStyle and sorry you're seeing this problem, which I've been able to reproduce. I've raised a bug report for the issue and it will be addressed in a later release.

Thanks for reporting the problem.

yshihouin's picture

Thank you for your prompt reply, Tony!

I am pleased that my report was helpful to you.
I look forward to the next release.

mjakobi866's picture

In Window --> Preferences --> DevStyle --> Color Themes, I have the Workbench theme set to "Dark Custom".

Normally, HSL(0,0,0) should be pitch black. However, this results in a light brownish grey workbench collor. Setting HSL to (0,0,100) creates the darkest workbench theme. However, it is still not black. It is a (quite ugly) dark brownish grey.

It would be nice to be able to set the HSL values of the Custom Dark workbench theme to a pitch black colour.

tweddlelmg's picture

mjakobi866, thanks for using DevStyle. Yes, a pure black backround is not currently possible. With some OS themes, it may not be possible to see some UI controls (e.g. drop down box arrows) if using pure black. However, we're looking at how best to address this issue. Thanks for reporting it.

zinvestigator's picture

Thanks for this great plugin! Much appreciated!

1- It is mentioned that theme colors are customizable yet I don't see anywhere which that customization could be acheived.

2- In dissassembly view, background colors of recent asm executions make the actualy op code unreadable.

3- How to change the yellow color of comments in darkest dark color theme?

4- The "switch to C/C++ editor" icon (upper right) is labeled to just C++

tweddlelmg's picture

Thanks for the feedback, zinvestigator.

  1. This article explains customizations of themes: https://www.genuitec.com/docs/workbench/using-devstyle-themes/
    Beyond that, syntax coloring is customizable via editor preferences for the various languages and the default text editor colors. If you'd like something beyond those customizations, please let us know (our support forum is a good place to discuss those requests).
  2. I see the problem and will raise a bug report.
  3. Go to Window->Preferences then the "C/C++"/"Editor"/"Syntax Coloring" page. Open the "Comments" node in the "Element" pane, select the type of comment you want to change, then click the colored rectangle to get a color choice dialog and select your color. Click the OK button.
  4. I'm not sure I understand this issue. Are you referring to the Icon for the C/C++ perspective? If you've opted to no show text for perspectives then you can still hover over the icon to see the text. Yes, the new icon does show only "C++" but then the standard eclipse CDT icon shows only "C", so this may not be what you're referring to.

I hope this helps but if you want to raise new issues or discuss these issues further, please use our support forums, if possible, as this comment section in the MarketPlace is not an ideal space for investigating issues.

carslan's picture

Greate job!

fmuccilli7dv's picture

Sorry to say that, but I'm really disappointed about the popup advertising another product. It breaks the flow of mind and It's really annoying, if not abusive. I'm going to uninstall the plugin if this won't be corrected.

bfernandestdp's picture

Francesco, as I stated earlier in the comments, this is the first popup in 14 months of DevStyle, sent to our users because we strongly believe CodeMix will improve their Eclipse dev experience.

Now typically, a user would see the notification just once, but I realize (from our Twitter conversation) that you are seeing it far more frequently, and I agree this can be frustrating. We will be releasing an update in the next couple of days that will correct this behavior. Thank you for letting us know, and we appreciate your patience.

fmuccilli7dv's picture

Thank you for your answer. I hope that the correction will aim to get rid of popups altogether. I don't think than an IDE could be considered a good place for this kind of notifications. It's disturbing, as we already struggle to avoid popups on web pages.

rohithkarthika's picture

When applying darkest dark theme, The workbench color i schanging to black but the scrollbars are still like the mac's default scrollbars

OS : MacOS High Sierra

Eclipse  : Oxygen (April 2018)

Tried the following

  • Changing the colors in theme
  • -Dswt.enable.themedScrollBar=false

Still not working .Image link attached.

www.dropbox.com/s/5bgp28r8m3ffkeu/screenshot_2018-04-19_14-43-56.png?dl=0

 

bfernandestdp's picture

Rohith, do you have macOS's "Show scroll bars" setting set to "Always"? You can change it to "When scrolling" to resolve this issue. Do let us know if that does not fix it.

rohithkarthika's picture

WOW!! It fixes the issue.Thank you.

But will I be able to switch back to Automatic based on Mouse or Trackpad anytime soon?

jburnham's picture

Oxygen.3 April Updates

Getting popup dialogs with mostly black text Javadoc text.  I can provide a sample if necessary.

twebbcke's picture

Please!  It would be great if you could provide examples -- ideally on our support forums at the Support link above or at https://www.genuitec.com/forums/topics/codemix/ Thanks!

jburnham's picture

and I like the color of my Eclipse layout, much easier on the eyes.  But after getting a popup pushing other products, I uninstalled.  Sorry, I have no tolerance for this type of advertising.  This should be listed in the product description and feels somewhat deceptive.

bfernandestdp's picture

John, this is the first popup in 14 months of DevStyle's existence, put out there as we believe our users would benefit from our new CodeMix plugin.

We respect our users very much, and are happy to provide this very popular plugin entirely free. We'll continue to be very sensitive about not popping up frequently; sorry it rubbed you the wrong way, and hopefully we’ll see you back again!

jzhaon6l's picture

I imported the Solarized light color, it works for the syntax. But if I want to use its background color, I need to check background color in Devstyle setting. This will change the background color at the beginning. But it will change back to default(white/black) color if I change to a different program's window. I am using Eclipse Oxygen at mac High Sierra. Thanks!

tweddlelmg's picture

Sorry that you're seeing a problem, Jun Zhao. I tried to replicate the problem, from your description and couldn't. Could you please raise the issue on our support forums? The support forum is here: https://www.genuitec.com/forums/topics/devstyle/theme-problems/

We'd need to know exactly what settings were used on the DevStyle preferences pages and how you imported the Solarized theme, as well as specific release information for eclipse Oxygen and DevStyle. Some screenshots of the problem would be a big help, too.

Thanks for using DevStyle.