Mend Advise

Add this URL to your Eclipse Installation to reach this solution's update site.

2024-03 (4.31), 2023-12 (4.30), 2023-09 (4.29), 2023-06 (4.28), 2023-03 (4.27), 2022-12 (4.26), 2022-09 (4.25), 2022-06 (4.24), 2022-03 (4.23), 2021-12 (4.22), 2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9)

https://downloads.whitesourcesoftware.com/Advise/Eclipse/published

Learn more...
Solution Description

Get all of the information that you need about open source security vulnerabilities in your software projects in real-time with Mend Advise.

Mend Advise works quickly and unobtrusively in the background, for earlier vulnerability awareness, and faster vulnerability remediation.

How Does it Work? 

Designed for seamless IDE integration, Mend Advise runs quietly in tha background, and  can also be manually activated, checking for known open source security vulnerabilities in your project. It then presents the findings within your Eclipse editor so that it doesn’t interrupt your development workflow. 

Advise alerts on security issues when a component with a known open source vulnerability is referenced. Receive detailed information about each reported security vulnerability including:

  • Severity Level
  • Vulnerable dependencies
  • Detailed Vulnerability data
  • Suggested fixes
  • Quick fix action (when available) 

Learn more about how to work with Mend Advise here.

Have any questions? Visit the Mend Customer Community

Additional Details

Eclipse Versions: 2024-03 (4.31), 2023-12 (4.30), 2023-09 (4.29), 2023-06 (4.28), 2023-03 (4.27), 2022-12 (4.26), 2022-09 (4.25), 2022-06 (4.24), 2022-03 (4.23), 2021-12 (4.22), 2021-09 (4.21), 2021-06 (4.20), 2021-03 (4.19), 2020-12 (4.18), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14), 2019-09 (4.13), 2019-06 (4.12), 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Mend

Development Status: Production/Stable

Date Created: Monday, December 23, 2019 - 09:47

License: Commercial

Date Updated: Wednesday, March 6, 2024 - 10:39

Submitted by: George Azzam

Screenshot
Date Ranking Installs Clickthroughs
April 2024 334/662 21 16
March 2024 248/694 78 18
February 2024 334/687 32 16
January 2024 348/691 31 20
December 2023 408/671 17 16
November 2023 357/686 33 19
October 2023 332/673 38 16
September 2023 361/663 26 17
August 2023 313/673 36 23
July 2023 249/668 62 15
June 2023 264/669 60 13
May 2023 327/671 37 18
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Mend Advise.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Hi, I would like to report that this plugin is not working in any Eclipse 2023 releases. It was used to work last year in Eclipse 2023-03 but I have made tests in new installations of Eclipse 2023-03, 2023-06, 2023-09 and 2023-12 and I get two problems:

  1. The credentials entered at the first use are saved but not recovered after you close Eclipse 2023 and open it again; So you need to enter username and key everytime you open Eclipse 2023;
  2. When selecting the Java project and clicking on Scan Project With Mend Advise, the following error happens in all 2023 Eclipse releases:

    An internal error occurred during: "Collect Dependencies for <project name>".
    'org.eclipse.m2e.core.project.IMavenProjectFacade[] org.eclipse.m2e.core.project.IMavenProjectRegistry.getProjects()'