CDT New Qt Form Wizard

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

https://eclipse-cdt-qt-form-wizard.sourceforge.net/

Learn more...
Solution Description

"New Qt Form" Wizard for CDT (C/C++) environment.
It is a copy of "New Qt Form" dialog from NetBeans IDE.
It creates Qt's *.ui file and optional a *.cpp/*.h wrapper class.

Categories: UI

Tags: CDT, wizard, qt

Additional Details

Eclipse Versions: Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

Platform Support: Windows, Mac, Linux/GTK

Date Created: Thursday, August 8, 2013 - 17:52

Date Updated: Wednesday, December 14, 2022 - 09:48

Submitted by: Kamil Kolaczynski

Screenshot
Date Ranking Installs Clickthroughs
March 2024 0/0 0 0
February 2024 0/0 0 7
January 2024 0/0 0 8
December 2023 0/0 0 7
November 2023 0/0 0 6
October 2023 0/0 0 7
September 2023 0/0 0 8
August 2023 0/0 0 8
July 2023 0/0 0 5
June 2023 0/0 0 5
May 2023 0/0 0 0
April 2023 0/0 0 1
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for CDT New Qt Form Wizard.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Hello,

first of all. It is good to have a IDE like Eclipse. I use Oxygen 4.7.0 on a windows 10 host.

Usually it works very well. But the installation of the CDT new qt form wizard does not work.

When I try to install it then there are some messages:

  1. The following solutions are not available: CDT New Qt Form Wizard1.0.0. Proceed with the installation anyway? I press the  "Yes"-button and it shows some progress on the progress bar.
  2. Then after some times I get the message " "Cannot complete the request. See the error log for detail

What did I wrong?

In reply to by Kurt Struevy

Hello Kamil Kolaczynski

thanks for your hint. But I cannot install this.

I got this message:

The following solutions are not available: CDT New Form Wizard 1.0.0

What is missing?

I use this version:

Eclipse IDE for C/C++ Developers

Version: Photon Release (4.8.0)
Build id: 20180619-1200