Quarkus Tools

Add this URL to your Eclipse Installation to reach this solution's update site.

2023-09 (4.29)

https://download.jboss.org/jbosstools/photon/stable/composite/4.29.1/

2023-06 (4.28)

https://download.jboss.org/jbosstools/photon/stable/composite/4.28.0/

2023-03 (4.27)

https://download.jboss.org/jbosstools/photon/stable/composite/4.27.0/

2022-12 (4.26)

https://download.jboss.org/jbosstools/photon/stable/composite/4.26.0

2022-09 (4.25)

https://download.jboss.org/jbosstools/photon/stable/composite/4.25.0

2022-06 (4.24)

https://download.jboss.org/jbosstools/photon/stable/composite/4.24.0

2022-03 (4.23)

https://download.jboss.org/jbosstools/photon/stable/composite/4.23.0

2021-09 (4.21)

https://download.jboss.org/jbosstools/photon/stable/composite/4.21.3

2021-03 (4.19)

https://download.jboss.org/jbosstools/photon/stable/composite/4.19.1

2020-09 (4.17)

https://download.jboss.org/jbosstools/photon/stable/composite/4.18.0

2020-06 (4.16)

https://download.jboss.org/jbosstools/photon/stable/composite/4.16.0

2020-03 (4.15)

https://download.jboss.org/jbosstools/photon/stable/composite/4.15.0

2019-12 (4.14)

https://download.jboss.org/jbosstools/photon/stable/composite/4.14.0

Learn more...
Solution Description

Quarkus Tools provides easy bootstrapping and code assist for Quarkus.

Categories: Languages

Additional Details

Eclipse Versions: 2023-09 (4.29), 2023-06 (4.28), 2023-03 (4.27), 2022-12 (4.26), 2022-09 (4.25), 2022-06 (4.24), 2022-03 (4.23), 2021-09 (4.21), 2021-03 (4.19), 2020-09 (4.17), 2020-06 (4.16), 2020-03 (4.15), 2019-12 (4.14)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Red Hat, Inc.

Development Status: Production/Stable

Date Created: Tuesday, March 17, 2020 - 06:56

License: Apache 2.0

Date Updated: Monday, June 24, 2024 - 09:32

Submitted by: JBoss Tools

Date Ranking Installs Clickthroughs
June 2024 84/667 306 16
May 2024 83/682 458 32
April 2024 75/687 533 18
March 2024 79/694 524 20
February 2024 81/687 444 19
January 2024 80/691 493 21
December 2023 88/671 408 17
November 2023 86/686 532 29
October 2023 73/673 594 30
September 2023 83/663 513 16
August 2023 75/673 544 19
July 2023 77/668 548 34
View Data for all Listings

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Quarkus Tools.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

With Eclipse 4.27 and plugin version 4.27 when editing application.properties file getting error:

An internal error occurred during: "MicroProfile properties collector".
Could not initialize class org.jboss.tools.quarkus.lsp4e.internal.ls.JavaDoc2MarkdownConverter

In reply to by Sharofiddin Pardayev

Any workaround / fix for this error. I face this. This is very annoying and frustrating. 

Further,  I observed this is happening only while editing ( or trying to save )  application.properties  file.  

Steps to reproduce :  download altest eclise, install quarkus tools from market place. import  a sample quarkus project. 

Select application.properties file -> right click  and observe the default selected editor .  the above mentioned stack overflow exception happen  when the file name is 'application.properties' file and the defualt selected editor for properties file is 'Generic Text Editor'

Further this is happening when the file name is application.properties. If the file name is changed to some thing else for ex. application1.properties,  the above issue is not seen (Microprofile  properties collector stackover flow)  But in this case the default selected text editor is some thing other than 'Generic Text Editor' ( in my case Jobss tools properties editor).

 

 

 

 

In reply to by Lampros Gk

I have the exact same error, even when I use the "Generic Text Editor" or "Text Editor". Every key I type leads to this error. If I'm lucky I can perhaps type 2 or 3 characters before the error pops up, but it's effectively impossible to edit application.properties files. I've tried to remove the content type but it's locked. The only thing that worked was removing the Quarkus Tools plugin completely.

Hello!

I've tried to debug my application after updating my Eclipse version and Quarkus Tools version, but it doesn't work anymore. The application runs but simply does not debug, it doesn't stop on the breakpoints.

I already have made some tests, including using the same code in the older Eclipse version (2022-06) and it works fine, the same code with the same breakpoints.

I tried to install Quarkus Tools on eclipse-jee-2022-09-R-win32-x86_64, and i get this error : 

"The installation cannot be completed as requested"

(The feature JBoss Tools Usage Reporting would be installed while the Quarkus tools no)

Do you know why?

THanks in advance.

Here is the orginal error message : 

Cannot complete the install because of a conflicting dependency.
  Software being installed: Quarkus Tools 1.7.0.v20220622-0658 (org.jboss.tools.quarkus.feature.feature.group 1.7.0.v20220622-0658)
  Software currently installed: M2E - Maven Integration for Eclipse 2.0.4.20220904-1703 (org.eclipse.m2e.feature.feature.group 2.0.4.20220904-1703)
  Only one of the following can be installed at once: 
    M2E Maven Integration for Eclipse Core 2.0.3.20220904-1703 (org.eclipse.m2e.core 2.0.3.20220904-1703)
    M2E Maven Integration for Eclipse Core 1.18.4.20220208-0831 (org.eclipse.m2e.core 1.18.4.20220208-0831)
  Cannot satisfy dependency:
    From: JDT MicroProfile Extension 0.4.0.20220324-1655 (org.eclipse.lsp4mp.jdt.core 0.4.0.20220324-1655)
    To: osgi.bundle; org.eclipse.m2e.lifecyclemapping.defaults 0.0.0
  Cannot satisfy dependency:
    From: M2E - Maven Integration for Eclipse 2.0.4.20220904-1703 (org.eclipse.m2e.feature.feature.group 2.0.4.20220904-1703)
    To: org.eclipse.equinox.p2.iu; org.eclipse.m2e.core [2.0.3.20220904-1703,2.0.3.20220904-1703]
  Cannot satisfy dependency:
    From: Default Build Lifecycle Mapping Metadata 1.17.1.20210115-1536 (org.eclipse.m2e.lifecyclemapping.defaults 1.17.1.20210115-1536)
    To: osgi.bundle; org.eclipse.m2e.core [1.16.0,2.0.0)
  Cannot satisfy dependency:
    From: Quarkus Tools 1.7.0.v20220622-0658 (org.jboss.tools.quarkus.feature.feature.group 1.7.0.v20220622-0658)
    To: org.eclipse.equinox.p2.iu; org.eclipse.lsp4mp.jdt.core 0.0.0

 

 

Installing from the Marketplace, the following error is reported:

The following solutions are not available: Quarkus Tools 4.19.1.Final (id=org.jboss.tools.quarkus.feature .feature.group, org.jboss.tools.usage.feature .feature.group, site=.../download.jboss.org/jbosstools/photon/stable/composite/4.19.1)

Please correct or replace link with previous version