GlassFish Tools

Add this URL to your Eclipse Installation to reach this solution's update site.

2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), 2019-06 (4.12), 2019-09 (4.13), 2019-12 (4.14), 2020-03 (4.15), 2020-06 (4.16), 2020-09 (4.17), 2020-12 (4.18), 2021-03 (4.19)

https://download.eclipse.org/glassfish-tools/1.0.0/repository/

Neon (4.6)

http://download.oracle.com/otn_software/oepe/neon

Mars (4.5)

http://download.oracle.com/otn_software/oepe/mars

Luna (4.4)

http://download.oracle.com/otn_software/oepe/luna

Kepler (4.3)

http://download.oracle.com/otn_software/oepe/kepler

Juno (4.2, 3.8)

http://download.oracle.com/otn_software/oepe/juno

Learn more...
Solution Description

Tools for developing applications for GlassFish.

  • Integrates with Eclipse Web Tools.
  • Supports open source GlassFish 5, 4 and 3.1.
  • Support the latest Eclipse GlassFish 5.1, the reference implementation of the Jakarta EE specification

Download latest Eclipse GlassFish Tools from: https://projects.eclipse.org/projects/webtools.glassfish-tools

These features are also part of Oracle Enterprise Pack for Eclipse (OEPE).

IMPORTANT: Please consult the following table regarding the minimum version of Java required to run GlassFish Tools.

  • Photon - Java 8
  • Oxygen - Java 8
  • Neon - Java 8
  • Mars - Java 8
  • Luna - Java 8
  • Kepler - Java 7
  • Juno - Java 6

Even if the correct version of Java is installed, Eclipse may find an earlier version upon launch, if it exists somewhere else on the system. To verify the version of Java that Eclipse is using, go to Help -> About -> Installation Details -> Configuration.

If you find that Eclipse is using a wrong Java install, edit eclipse.ini file and add the following two lines to the start of the file:

-vm [path-to-jre]

Categories: Application Server

Additional Details

Eclipse Versions: 2019-03 (4.11), 2018-12 (4.10), 2018-09 (4.9), Photon (4.8), Oxygen (4.7), 2019-06 (4.12), 2019-09 (4.13), 2019-12 (4.14), 2020-03 (4.15), 2020-06 (4.16), 2020-09 (4.17), 2020-12 (4.18), 2021-03 (4.19), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Oracle

Development Status: Production/Stable

Date Created: Friday, May 1, 2015 - 12:05

License: EPL

Date Updated: Thursday, February 11, 2021 - 15:56

Submitted by: Konstantin Komissarchik

Date Ranking Installs Clickthroughs
February 2024 380/687 22 19
January 2024 371/691 24 10
December 2023 363/671 26 13
November 2023 459/686 12 15
October 2023 386/673 23 17
September 2023 372/663 24 16
August 2023 376/673 21 31
July 2023 334/668 28 18
June 2023 384/669 22 9
May 2023 309/671 45 19
April 2023 315/667 40 19
March 2023 0/0 0 16
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for GlassFish Tools.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

The repository used in the marketplace to install the Glassfish plugin is outdated.

The repository used is http://download.eclipse.org/glassfish-tools/1.0.0/repository/  which will install the plugin for the old Oracle Glassfish version.(Glassfish 5.0  -- Java EE 8)

In order to use Glassfish 5.1 (the Jakarta EE 8 version), you have to install a newer version of the Glassfish plugin which is in another p2 repository: http://download.eclipse.org/glassfish-tools/1.0.1/repository/

 

The Glassfish-tools plugin defines incomplete glassfish system libraries with Glassfish 5.1

JavaEE api jars have been renamed in Glassfish 5.1

for example:

Gassfish 5.0 Gassfish 5.1 javax.ejb-api.jar jakarta.ejb-api.jar javax.el.jar jakarta.el.jar javax.persistence.jar jakarta.persistence.jar ... ...

 

The Glassfish tools plugin, however, use the same glassfish System Librairies (javax.persistence.jar) for Glassfish 5.0 and Glassfish 5.1.

In consequence eclipse JavaEE projects targeting Glassfish 5.1 don't have a correct build classpath (most of the javaEE api jar are missing...)

I guess someone should modify the GlassFishInstall.java file

Hi,

I don't see GF 5 support available in eclipse.Please let me know when would it be available or is there any work around ?

found there is oracle archive for bundles of all Oracle tools for eclipse.

the last version that supports glassfish 2.1 - is 12.1.1.2.1 - March 2013.

http*s://www.oracle*.com/technetwork/devel*oper-tools/eclipse/downl*oads/oepe-ar…
remove star from url

I downloaded oepe-12.1.1.2.1-kepler-repository.zip then in to the new version of eclipse 2018-09 - 4.9 I installed from the repository only glass fish tools - and it worked

Im trying to add the plugin in eclipse photon, but I got an error: "the following solutions are not available: Glassfish Tools" and I dont know what is going wrong

Hi Konstantin,

the new versions of payara changed the way the use the validation apis. When I try to change my project from Payara 171 to 174 my projects wont compile because the javax.validation and org.hibernate.validator classes are not found. Checking the Systemclasspath of my Glassfish runtime I can't find the validation-api.jar and hibernate-validator-payara-p1.jar which are in modules. Even if I rename validation-api.jar to bean-validator.jar it is added to zhe classpath!

When I deploy my project on the new server it works perfectly, so I guess this is just a matter of adding the jars to the Glassfish System Classpath.

br

Thomas

Altough Eclipse Oxygen offers support for Java 9. If this plugin is used in Oxygen 1a install with JDK 9, Glassfish will fail with:

An internal error occurred during: "Stopping GlassFish 4 [domain1]".
Can't find bundle for base name sun.util.logging.resources.logging, locale

I've tested it with Glassfish and Payara, and I also can confirm that it works with JDK 8, however I'm not sure if this is the right place to report the bug, I did it through Eclipse automatic error reporting too.

Glassfish server by itself will indeed run, but you won't be able to see server's log.

The Plugin itself works. But there is one thing that makes docker not working.

As of the Docker-Container is a kind of a remote server, I just specify the lokal glassfish as the environment, and then need to set admin user, admin pw, admin port and debug port. But the Add On just provides the "normal" domain-path setting for "localhost". Then I tryed adding a new hostname to hosts file, but that did not work too. As soon as the Add On knows, that the given domain / IP resolvs to the local host, there is just the one way: Domain path! And that doesn't work with docker.

 

Would be nice if that would be supported too

The adapter can be installed successfully with a problem. Once it is installed, Eclipse restarted, the GlassFish is still not in the list when you try to add GlassFish as a server. My Eclipse Mars2 works fine with WebSphere and JBoss adapters.

Hi, i have installed Version: Mars.2 Release (4.5.2). And when i try the Glassfish tools, i have this message from the marketplace:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,oracle.eclipse.tools.glassfish,8.6.1.201603011333
No repository found containing: org.eclipse.update.feature,oracle.eclipse.tools.glassfish,8.6.1.201603011333
No repository found containing: osgi.bundle,oracle.eclipse.tools.glassfish.ui,8.6.1.201603011333
No repository found containing: osgi.bundle,oracle.eclipse.tools.javaee.doc.integration,8.6.1.201603011333
No repository found containing: osgi.bundle,oracle.eclipse.tools.util,8.6.1.201603011333
No repository found containing: osgi.bundle,oracle.eclipse.tools.util.jver,8.6.1.201603011333

someone else has this problem ?

In reply to by Alejandro Guerrero

I was able to install GlassFish tools into a Mars.2 Java EE distro just now. This type of error indicates a network issues. Typically these are intermittent as Eclipse was able to get part way through the installation sequence before failing. So try again. If you are seeing this issue consistently, post on the support forum. We will need to gather more information regarding your setup and network configuration.

I have plug-in 8.5.1 installed. I was able to assign GlassFish Server Open Source Edition 4.1 by selecting ..\glassfish4\glassfish as installation directory. "glassfish4" is not recognized!
Does this solve your problem?

I wasted hours today trying to get Eclipse Mars to work with Glassfish 4.1. I can only reason that the adapter doesn't exist yet for this combination. Thanks Eclipse!