Android Development Tools for Eclipse

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

https://dl-ssl.google.com/android/eclipse/

Learn more...
Solution Description

Android Development Tools (ADT) is a plugin for the Eclipse IDE that is designed to give you a powerful, integrated environment in which to build Android applications.

ADT extends the capabilities of Eclipse to let you quickly set up new Android projects, create an application UI, add packages based on the Android Framework API, debug your applications using the Android SDK tools, and even export signed (or unsigned) .apk files in order to distribute your application.

Developing in Eclipse with ADT is highly recommended and is the fastest way to get started. With the guided project setup it provides, as well as tools integration, custom XML editors, and debug output pane, ADT gives you an incredible boost in developing Android applications.

Additional Details

Eclipse Versions: Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

Platform Support: Windows, Mac, Linux/GTK

Organization Name: Google, Inc.

Development Status: Production/Stable

Date Created: Wednesday, May 9, 2012 - 10:58

License: Apache 2.0

Date Updated: Monday, February 4, 2019 - 13:50

Submitted by: Eric Cloninger

Date Ranking Installs Clickthroughs
February 2024 64/665 423 16
January 2024 77/691 512 15
December 2023 87/671 420 8
November 2023 90/686 495 15
October 2023 87/673 517 22
September 2023 89/663 478 14
August 2023 100/673 379 11
July 2023 91/668 442 9
June 2023 94/669 483 8
May 2023 91/671 540 13
April 2023 86/667 541 10
March 2023 94/686 568 9
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Android Development Tools for Eclipse.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

i try install ADT from Eclipse version Enterprise, but receive notification Version not compalible.

i try find ADT from Marketplace but cannot find Android Development Tools for Eclipse.

i need anyone can help me, i want Eclipse and Android SDK + virtual Android, i don't want Android Studio. Because i not like Kotlin and not like Android Studio.

In reply to by Hưng Nguyễn

you can try to use these software

jdk-8u261-windows-x64.exe -> www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

eclipse-java-2018-09-win32-x86_64.zip -> www.eclipse.org/downloads/packages/release/2018-09/r

android-sdk_r24.4.1-windows.zip -> dl.google.com/android/android-sdk_r24.4.1-windows.zip

ADT-23.0.7.zip -> dl.google.com/android/ADT-23.0.7.zip

Don't download build-tools which version is greater than 25.0.3

It's been a long time since Google stopped updating ADT

When you create new android project,and the min version choose API 14

Please forgive me for using poor English, because I am a Chinese

Iuse Eclipse Mars 2 (Eclipse IDE for Java EE developers, 4.5.2.20160218-0600) and the latest version of ADT plugin (23.0.7.2120684). I run the IDE in Windows 8.1.

When I insert TimePicker control in a layout in the Android Common XML Editor Eclipse the IDE hangs. I have to kill the process in TaskManager. If I insert it by drag and dropping in Graphical layout editor it hangs immediately. If I add it in text editor it hangs when I an trying to switch to Graphical layout editor or it hangs after fiew minutes after the insertion if I do nothing else whith this file.

What is the cause and can I overcome this some way?

Thank you for any reply!

 

I follow this guide Google Plugin for Eclipse 4.6 (Neon) Installation Instructions URL: https: //developers.google.com /eclipse/docs/install-eclipse-4.6 but this error occured "This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plug-in"
It does not support API 24 (Android 7.0) and API 23 (Android 6.0)

So this lets you build android apps using Eclipse? because i heard that eclipse no longer supports ADT you would have to use Android Studio but if this works i am def going to install it. But first, does this work with eclipse still??

Hi all.
I try to install Ecplise Neon ADt via eclipse-installer, but it seems that DT cannot manage a Marshmallow development.
Do I miss something?

MZ

In reply to by Dominic Cerisano

Hello, so i am just wondering if you actually got ADT working through eclipse? i know that neon 4.6 version lets you install an IDE FOR ANDROID DEVELOPERS. but let me know if you found out how to even develop android apps through Eclipse IDE?

I've installed Android Developer Tools pluging to Eclipse Mars but i could not see Android SDK Manager menu item under Eclipse Window menu. I just see AVD manager panel when i run my android aplication.So i can not customize my AVD manager devices easly.