IBM WebSphere MQ Explorer V8

Add this URL to your Eclipse Installation to reach this solution's update site.

Kepler (4.3), Juno (4.2, 3.8)

https://public.dhe.ibm.com/software/integration/wmq/explorer/v8/updates/

Learn more...
Solution Description

Note: This is no longer the latest version. For the latest features, including support for Eclipse 4.4, see:
https://marketplace.eclipse.org/content/ibm-mq-explorer-version-9

MQ Explorer enables you to explore and configure all IBM MQ objects and resources, including Java Message Service (JMS), and publish and subscribe.

This is free to install, support is available to licensed IBM MQ customers - see the license agreement for details.

Installation notes
If you get installation errors mentioning the "org.eclipse.draw2d" plugin, please install Eclipse GEF first from the Eclipse update site.

Additional Details

Eclipse Versions: Kepler (4.3), Juno (4.2, 3.8)

Platform Support: Windows, Linux/GTK

Organization Name: IBM

Development Status: Production/Stable

Date Created: Thursday, July 18, 2013 - 10:17

License: Commercial - Free

Date Updated: Wednesday, December 14, 2022 - 09:48

Submitted by: Matt Chapman

Date Ranking Installs Clickthroughs
May 2024 549/662 3 6
April 2024 665/687 1 11
March 2024 0/0 0 13
February 2024 618/687 2 6
January 2024 609/691 2 12
December 2023 664/671 1 8
November 2023 0/0 0 13
October 2023 645/673 1 12
September 2023 0/0 0 15
August 2023 634/673 1 9
July 2023 642/668 1 8
June 2023 0/0 0 4
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for IBM WebSphere MQ Explorer V8.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Cannot complete the install because of a conflicting dependency.
Software being installed: IBM WebSphere MQ Explorer 8.0.0.201510171438 (com.ibm.mq.explorer.feature.feature.group 8.0.0.201510171438)
Software currently installed: WebSphere IBM Integration Bus Toolkit - Integration Bus MQTT nodes 1.1.0.v20160310-1307 (MQTTNodesFeature.feature.group 1.1.0.v20160310-1307)
Only one of the following can be installed at once:
MQ Runtime Plug-in 10.0.400.v20160310-1307 (com.ibm.mq.runtime 10.0.400.v20160310-1307)
com.ibm.mq.runtime 8.0.0.201510171438
Cannot satisfy dependency:
From: MQTTNodes Plug-in 1.1.0.v20160310-1307 (MQTTNodes 1.1.0.v20160310-1307)
To: bundle com.ibm.etools.mft.ibmnodes 0.0.0
Cannot satisfy dependency:
From: WebSphere IBM Integration Bus Toolkit - Integration Bus MQTT nodes 1.1.0.v20160310-1307 (MQTTNodesFeature.feature.group 1.1.0.v20160310-1307)
To: MQTTNodes [1.1.0.v20160310-1307]
Cannot satisfy dependency:
From: MQ 10.0.400.v20160310-1307 (com.ibm.etools.mft.connector.mq 10.0.400.v20160310-1307)
To: bundle com.ibm.mq.runtime [10.0.0,11.0.0)
Cannot satisfy dependency:
From: com.ibm.etools.mft.flow.dnd.service 10.0.400.v20160310-1307
To: bundle com.ibm.etools.mft.connector.mq 10.0.0
Cannot satisfy dependency:
From: Integration Bus Builtin Message Nodes 10.0.400.v20160310-1307 (com.ibm.etools.mft.ibmnodes 10.0.400.v20160310-1307)
To: bundle com.ibm.etools.mft.flow.dnd.service [10.0.0,11.0.0)
Cannot satisfy dependency:
From: IBM WebSphere MQ Explorer 8.0.0.201510171438 (com.ibm.mq.explorer.feature.feature.group 8.0.0.201510171438)
To: com.ibm.mq.runtime [8.0.0.201510171438]

I get below error on install -

!SUBENTRY 1 org.eclipse.epp.mpc.ui 4 0 2015-08-24 15:47:03.513
!MESSAGE
!STACK 0
java.net.MalformedURLException
at java.net.URL.(URL.java:623)
at java.net.URL.(URL.java:486)
at java.net.URL.(URL.java:435)
at org.eclipse.epp.internal.mpc.ui.operations.AbstractProvisioningOperation.addRepositories(AbstractProvisioningOperation.java:75)
at org.eclipse.epp.internal.mpc.ui.operations.ResolveFeatureNamesOperation.run(ResolveFeatureNamesOperation.java:46)
at org.eclipse.epp.internal.mpc.ui.wizards.FeatureSelectionWizardPage$4.run(FeatureSelectionWizardPage.java:303)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Caused by: java.lang.NullPointerException
at java.net.URL.(URL.java:528)
... 6 more

An error occurred while installing the items
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]com.ibm.mq.explorer.doc 8.0.0.201404291817, action=).
Failed to prepare partial IU: [R]com.ibm.mq.explorer.doc 8.0.0.201404291817.

In reply to by Andy Ericksen

Hi Andy-
I have had the same problem and i followed the below steps to make it work.

Steps:
1) Go to Help -> Install New Software
2) provide this link " The Eclipse Project Updates - downloaddoteclipsedotorg/eclipse/updates/4.4" in the "Work with" section
3) Check the "Eclipse Tests, Examples, and Extras" category and click next
4) check "Eclipse 2.0 Style Plugin Support" and install it.
5) After restarting Eclipse, install Websphere MQ explorer again and this time the installation will succeed.

This is the error i get - An error occurred while installing the items
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]com.ibm.mq.explorer.doc 8.0.0.201404291817, action=).
Failed to prepare partial IU: [R]com.ibm.mq.explorer.doc 8.0.0.201404291817.

Hi,

I was able to install the plugin and even used it once last week.
But I am getting the following message when I open the MQ Explorer perspective:

An internal error occurred during: "Initializing MQ Explorer"
com/ibm/misc/BASE64Encoder

Can you help me solve this?

Thanks,
Joseph

I have just installed Eclipse Kepler. I have tried dragging and dropping this plug-in onto my Eclipse session and get a similar error to the 2 users above, i.e.:
Cannot complete the install because one or more required items could not be found.
Software currently installed: IBM WebSphere MQ Explorer Translations 7.5.0.201306280318 (com.ibm.mq.explorer.feature.nl1.feature.group 7.5.0.201306280318)
Missing requirement: WebSphere MQ Explorer Cluster Plug-in 7.5.0.201306280318 (com.ibm.mq.explorer.clusterplugin 7.5.0.201306280318) requires 'bundle org.eclipse.draw2d [3.2.0,5.0.0)' but it could not be found
Cannot satisfy dependency:
From: com.ibm.mq.explorer.clusterplugin.nl1 7.5.0.201306280318
To: bundle com.ibm.mq.explorer.clusterplugin 0.0.0
Cannot satisfy dependency:
From: IBM WebSphere MQ Explorer Translations 7.5.0.201306280318 (com.ibm.mq.explorer.feature.nl1.feature.group 7.5.0.201306280318)
To: com.ibm.mq.explorer.clusterplugin.nl1 [7.5.0.201306280318]

Cannot complete the install because one or more required items could not be found.
Software currently installed: IBM WebSphere MQ Explorer Translations 7.5.0.201306280318 (com.ibm.mq.explorer.feature.nl1.feature.group 7.5.0.201306280318)
Missing requirement: WebSphere MQ Explorer Cluster Plug-in 7.5.0.201306280318 (com.ibm.mq.explorer.clusterplugin 7.5.0.201306280318) requires 'bundle org.eclipse.draw2d [3.2.0,5.0.0)' but it could not be found
Cannot satisfy dependency:
From: com.ibm.mq.explorer.clusterplugin.nl1 7.5.0.201306280318
To: bundle com.ibm.mq.explorer.clusterplugin 0.0.0
Cannot satisfy dependency:
From: IBM WebSphere MQ Explorer Translations 7.5.0.201306280318 (com.ibm.mq.explorer.feature.nl1.feature.group 7.5.0.201306280318)
To: com.ibm.mq.explorer.clusterplugin.nl1 [7.5.0.201306280318]

I have standard version of Eclipse2.0..

John, Were you able to install it?

I get

Cannot complete the install because one or more required items could not be found.
Software currently installed: IBM WebSphere MQ Explorer Translations 7.5.0.201306280318 (com.ibm.mq.explorer.feature.nl1.feature.group 7.5.0.201306280318)
Missing requirement: WebSphere MQ Explorer Cluster Plug-in 7.5.0.201306280318 (com.ibm.mq.explorer.clusterplugin 7.5.0.201306280318) requires 'bundle org.eclipse.draw2d [3.2.0,5.0.0)' but it could not be found
Cannot satisfy dependency:
From: com.ibm.mq.explorer.clusterplugin.nl1 7.5.0.201306280318
To: bundle com.ibm.mq.explorer.clusterplugin 0.0.0
Cannot satisfy dependency:
From: IBM WebSphere MQ Explorer Translations 7.5.0.201306280318 (com.ibm.mq.explorer.feature.nl1.feature.group 7.5.0.201306280318)
To: com.ibm.mq.explorer.clusterplugin.nl1 [7.5.0.201306280318]