Flex Maven Integration for Flash Builder

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

https://downloads.sourceforge.net/project/flexmojosm2e/repository/

Learn more...
Solution Description

Provides a m2e connector for Flex maven projects build with the net.flexmojos.oss:flexmojos-maven-plugin (version 5 and 6) to Flash Builder.

Supports Right-click on project, Maven > Update project...

The connector will synchronize the project settings in a pom first fashion:

Important note: You need Flash Builder 4.7 to work. (Can work with 4.* as well but not tested).

  • Adds Flash, Flex, Air nature to project,
  • Adds source, test, and resources paths to project source paths,
  • Adds Flex framework version to project (will generates "Flex 4.9.0" for flex-framework:4.9.0.1425567),
  • Adds other SWC dependencies from local .m2 repository to project library paths.
  • Adds locales related compiler arguments.
  • Configures Air manifest path for certificates.

Known limitations:

This is an Alpha release, developed and tested with Flexmojos 6 and Flash Builder 4.7. Moreover, the connector only support Flex projects for now and provide very basic integration.

Support promise:

The Plug-In in its final will support all options covered by Flash Builder 4.7 project settings for every project types covered by Flexmojos, it will support future Maven-Flex-Plugin developed by Apache. This may result in a new/separate project or being integrated into this m2e connector.

Why to contribute ?

Flex is not dead, and it might be even more true with FalconJS compiler, which will target Flex application to Javascript. Apache community is vibrant, and development on Eclipse is fun. The project is fully managed with Maven and Tycho (brings OSGi support to maven modules) and emphasize best practices through development.

You might have a look at the github repository located at: https://github.com/sylvainlecoy/flexmojos-m2e-connector.

Categories: Build and Deploy

Additional Details

Eclipse Versions: Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)

Platform Support: Windows, Mac

Organization Name: Sylvain Lecoy

Development Status: Alpha

Date Created: Tuesday, January 29, 2013 - 10:36

License: EPL

Date Updated: Monday, February 4, 2019 - 13:52

Submitted by: Missing name Mising name

Date Ranking Installs Clickthroughs
February 2024 405/683 16 4
January 2024 408/691 18 11
December 2023 396/671 19 5
November 2023 332/686 40 8
October 2023 409/673 20 8
September 2023 538/663 5 3
August 2023 461/673 10 5
July 2023 501/668 7 2
June 2023 457/669 12 2
May 2023 459/671 13 4
April 2023 497/667 7 3
March 2023 470/686 15 6
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for Flex Maven Integration for Flash Builder.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Hi, I'm trying to install in Mac OSX - Eclipse JEE Juno with Flash Builder plugin, and wasn't able to do it due to following error:

eclipse.buildId=M20120914-1800
java.version=1.6.0_45
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=es_ES
Framework arguments: -product org.eclipse.epp.package.jee.product -keyring /Users/carlosrovira/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -product org.eclipse.epp.package.jee.product -keyring /Users/carlosrovira/.eclipse_keyring -showlocation

If there's some workaround that I could test let me know to help improving this needed Eclipse plugin

Thanks

In reply to by Carlos Rovira

Hello Carlos and first thank you for the report.

The error you give me isn't really informative, can I redirect you to the github where I created the issue you encounter and give me more information ? I haven't myself a Mac OSX to try installing it, however I am sure I can help you to fix the problem.

https://github.com/sylvainlecoy/flexmojos-m2e-connector/issues/1.

Thanks,

Sylvain