Eclipse Foundation Member
Mylyn WikiText Eclipse Project

Add this URL to your Eclipse Installation to reach this solution's update site.

Oxygen (4.7)
Neon (4.6)
Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)

Learn more...

Details Group Tabs

Installs Last Update: 
Wednesday, March 21, 2018 - 18:43
mmisingname0wo's picture

Update to

Mylyn WikiText

 fails in

Eclipse Java EE IDE for Web Developers.

Version: Oxygen.2 Release (4.7.2)

Build id: 20171218-0600


amergey's picture

I setup an owygen install with oomph at this time it installs with wikitext 3.0.13.

When I try to perform the setup, it tries to update to wikitext 3.0.18, wich fails with same error, it complains about missing jsoup (but I already have jsoup from previous install) 

amergey's picture

As a workaround I have added orbit mars repository

and then I manage to install wikitext, org.jsoup deps is probably missing from owygen repos

mlpez's picture


I can't update the plugin because i get a dependency error:

Cannot complete the install because one or more required items could not be found.
Software currently installed: Mylyn WikiText (
Missing requirement: Mylyn WikiText (org.eclipse.mylyn.wikitext requires 'package org.jsoup [1.7.0,2.0.0)' but it could not be found
Cannot satisfy dependency:
From: Mylyn WikiText Editors (
To: org.eclipse.mylyn.wikitext []
Cannot satisfy dependency:
From: Mylyn WikiText (
To: []

How I can update the plugin?

Thanks in advance.

atregnaghi's picture

I have removed all mylyn parts and tried to install the wiki text plugin standalone by market place and run into similar problems.

I installed the plugin (I am using oxygen) by following workaround 

  1. Open Help->Install new software ->
  2. Select wanted MyLyn WikiText plugin there 
  3. Finish installation