Mylyn Mantis Connector 3.11.0

Bookmark and Share
Update site

Add this URL to your Eclipse Installation to reach this Solution's Update Site.
Learn more...

Details Group Tabs

Reviews

Login  to post comments.

Cannot install it to eclipse luna

I have been using this plugin for several years. However I was unable to install it on eclipse luna. I am getting the following error. Tried nearly everthing. Install eclipse again, install mylyn-commons bundle. Nothing worked for me. I get the following error.

Missing requirement: Mylyn Mantis Connector Core 3.10.0.201311082300 (com.itsolut.mantis.core 3.10.0.201311082300) requires 'bundle org.eclipse.mylyn.commons.soap [3.7.0,4.0.0)' but it could not be found

Hi Burhan.

Hi Burhan.

The error has now been fixed, try installing again from the same update site.

Thanks for your understanding,

Robert

Connector UI 3.9.0 get a IllegalStateException

Installed it in Eclipse Helios 3.6.1 with Mylyn 3.7.1 and Connector UI 3.9.0 and got a IllegalStateException, when trying to add a new repository.

I check url (.../api/soap/mantisconnect.php) and wsdl but don't work.

Error in Install Plugin Eclipse - Cannot satisfy dependency

I received the similar message error in the install this plugin (please see: http://marketplace.eclipse.org/node/455094)

The my message is:

Cannot complete the install because one or more required items could not be found.
Software being installed: Mylyn Tasks Connector: Mantis 3.9.0.201206242005 (com.itsolut.mantis_feature.feature.group 3.9.0.201206242005)
Missing requirement: Mylyn Mantis Connector Core 3.9.0.201206242005 (com.itsolut.mantis.core 3.9.0.201206242005) requires 'bundle org.eclipse.mylyn.commons.soap [3.7.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: Mylyn Mantis Connector UI 3.9.0.201206242005 (com.itsolut.mantis.ui 3.9.0.201206242005)
To: bundle com.itsolut.mantis.core 0.0.0
Cannot satisfy dependency:
From: Mylyn Tasks Connector: Mantis 3.9.0.201206242005 (com.itsolut.mantis_feature.feature.group 3.9.0.201206242005)
To: com.itsolut.mantis.ui [3.9.0.201206242005]

What's i do now?

Hi Daniel,

Hi Daniel,

It looks like you're running an old Mylyn version . For the current ( 3.9.0 ) connector version you need Mylyn Version >= 3.7.0 .

Robert

Problem installing with eclipse luna

Hi,

I face exactly the same issue :
[...]
Missing requirement: Mylyn Mantis Connector Core 3.10.0.201311082300 (com.itsolut.mantis.core 3.10.0.201311082300) requires 'bundle org.eclipse.mylyn.commons.soap [3.7.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
[...]

It looks like org.eclipse.mylyn.commons.soap doesn't exists anymore in the last version of mylyn (3.12.0 see : http://www.eclipse.org/mylyn/).

Hi Pascal,

Hi Pascal,

Sorry for noticing so late, your comment was nested under an older one. This should now be fixed with version 3.10.1, please upgrade and let me know if things don't work as expected.

For the future, I suggest you use the user forum on MantisBT.org, as I can watch it using RSS feeds and respond faster.

Thanks,

Robert

now works for eclipse 3.5x

Submitted by Kent on

good plugin, but not works eclipse 3.5

Does not work at all.

Submitted by bugmenot on

Installed it in Eclipse 3.5.1 and got a null pointer exception, when trying to add a new repository.

Are you by any chance using

Are you by any chance using the 3.1.0 version of the connector and Mylyn 3.2 ? You need to update to Mylyn 3.3 or downgrade to the 3.0.6 version of the connector.

Robert