Code Conjurer

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

IMPORTANT: Requires the latest Eclipse 3.7 Indigo and a user account at merobase.com (enter information in CC preferences).

Code Conjurer is a software reuse tool developed at the chair for software engineering at the University of Mannheim.

The Eclipse plug-in brings the power of the merobase.com software search engine to the popular Eclipse IDE. If enabled, a background agent monitors the programming activities of a Java developer and searches for appropriate reusable software artifacts that fit the current class under development.

Since version 2.1 Code Conjurer supports (experimental) test-driven searches. More information on that is available at the project's website.

Learn more at
http://www.code-conjurer.org
or at
https://sourceforge.net/projects/codeconjurer/

IMPORTANT: Code Conjurer 2.x requires the latest Eclipse 3.7 Indigo release or later. It cannot be installed on outdated Eclipse 3.6 or earlier. Update your Eclipse before you try to install it.

Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Tue, 2011-08-09 11:52
Development Status: 
Production/Stable
License: 
EPL
Date Updated: 
Thu, 2018-08-23 15:04
Screenshots
Metrics
DateRankingInstallsClickthroughs
December 2018811/8872 (0%)10
November 2018864/9392 (0%)12
October 2018NA0 (0%)13
September 2018852/9412 (0%)9
August 2018919/9391 (0%)5
July 2018927/9401 (0%)9
June 2018NA0 (0%)18
May 2018936/9541 (0%)8
April 2018NA0 (0%)11
March 2018849/9614 (0%)7
February 2018889/9402 (0%)12
January 2018908/9451 (0%)5
View Data for all Listings
Errors

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Code Conjurer.

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Tuesday, December 11, 2018 - 15:01