AnyEdit Tools

Add this URL to your Eclipse Installation to reach this solution's update site.

Oxygen (4.7)
Neon (4.6)
Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)


Learn more...

Details Group Tabs

Installs Last Update: 
Sunday, April 22, 2018 - 06:39
ahmann's picture

Can't install with eclipse 4.8 (STS 4.0.0.M10)

aloskutov's picture

Please file a bug for STS (no idea what it is). AnyEdit supports default 4.8 distribution from eclipse.org.

I use AnyEdit on Eclipse 4.8 without any issues since very beginning of 4.8.

ahmann's picture

Ups ... then tha'ts my fault :) Sorry Andrey!

STS = the famous "Spring Tool Suite" :)

I will try it again ...

Ciao

ahmann's picture

I tried again ...

Cannot complete the install because one or more required items could not be found.
Software currently installed: AnyEditTools 2.7.1.201709201439 (AnyEditTools.feature.group 2.7.1.201709201439)
Missing requirement: AnyEdit Tools 2.7.1.201709201439 (de.loskutov.anyedit.AnyEditTools 2.7.1.201709201439) requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' but it could not be found
Cannot satisfy dependency:
From: AnyEditTools 2.7.1.201709201439 (AnyEditTools.feature.group 2.7.1.201709201439)
To: org.eclipse.equinox.p2.iu; de.loskutov.anyedit.AnyEditTools [2.7.1.201709201439,2.7.1.201709201439]

 

aloskutov's picture

So why not open a bug at the famous STS bug tracker? This is obviuosly not a problem of a plugin if the STS runtime platform is not able to install it. As said, AnyEdit works on *all* supported Eclipse releases up to latest 4.8 nightly, and I guess that this STS thingy is simply broken: "requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' but it could not be found".

tcohenp6u's picture

maybe add a cabability to search in unicode

mpakalpati's picture

Great tool and giving me immense pleasure while coding

dseligson's picture

The ability to compare open files alone is the biggest timesaver. Lots of other cool utilities.
I'm glad this package is still supported for the archaic version of Eclipse that I'm still using :-)

longaro's picture

very usefull plugin. Used for a long time without any problems

djainyrr's picture

This is a simple, reliable and handy plugin. It works like a charm on my Eclipse CDT with the Lua Development Tools plugin.

Great job!

ggrovesn0n's picture

First plugin I install on any new Eclipse instance, even tailored versions like Aptana and Flash Builder.

rmisingname7mw's picture

Very useful plugin