Eclipse Foundation Member
Spring Tools 4 (aka Spring Tool Suite 4)

Add this URL to your Eclipse Installation to reach this solution's update site.

2018-09 (4.9)


2018-12 (4.10)


Learn more...

Details Group Tabs

Details

Spring Tools 4

Spring Tools 4 is the next generation of Spring tooling for your favorite coding enrivonment. Largely rebuilt from scratch, it provides world-class support for developing Spring-based enterprise applications, whether you prefer Eclipse, Visual Studio Code, or Atom IDE.

Getting Started

Spring Tool Suite 4 makes it easy to get started. A direct and easy-to-use integration of the Spring Initializr and the famous Spring Guides allows you to go from nothing to a running Spring Boot app in seconds.

Navigate your Spring code at the speed of light

Understanding and quickly navigating source code is essential for coding. The new Spring Tools 4 understands your Spring-based source code and allows you to quickly get an overview and navigate to the important pieces of your Spring apps. Finding Spring elements and navigating to them has never been easier.

Smart Code Editing

Code completion is a critical part of working with source code. The all-new Spring Tools 4 provides smart code completions for the Spring elements in your app.

Runtime Information In Your Editor

Spring Tools 4 now bridges the gap between your source code and running Spring Boot applications. By taking advantage of the Spring Boot Actuators, we enriched the source code with detailed information from the running app (e.g., exact bean wiring information, conditional reports, configuration, details, and more).

Looking for the old Spring Tool Suite 3?

If you are looking for the previous generation of Spring Tools for Eclipse, also known as Spring Tool Suite 3 or Spring IDE, you should look at the "Spring Tools 3 Add-On" entry in the marketplace here: https://marketplace.eclipse.org/content/spring-tools-3-add-aka-spring-tool-suite-3

Categories:
Additional Details
Eclipse Versions: 
2018-12 (4.10), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Fri, 2014-07-11 12:41
Development Status: 
Production/Stable
License: 
EPL
Date Updated: 
Thu, 2018-12-06 04:15
Metrics
DateRankingInstallsClickthroughs
December 20186/8847232 (3.34%)49
November 20186/93919695 (3.18%)126
October 20187/94318237 (2.88%)387
September 20182/94133147 (6.34%)125
August 20181/93934504 (6.73%)71
July 20181/94036476 (6.72%)70
June 20181/94735300 (7.13%)83
May 20181/95439494 (7.19%)75
April 20181/94639186 (7.09%)102
March 20181/96137419 (6.79%)58
February 20182/94029183 (6.27%)91
January 20181/94531179 (6.19%)84
View Data for all Listings
Errors

Unsuccessful Installs in the last 7 Days: 357

CountError Message
129Cannot continue the operation. There is another install operation in progress.
21Cannot complete the install because one or more required items could not be found....
21Cannot complete the install because one or more required items could not be found....
20Cannot complete the install because one or more required items could not be found....
14Cannot complete the install because one or more required items could not be found....
12Cannot complete the install because one or more required items could not be found....
12Cannot complete the install because one or more required items could not be found....
10Cannot complete the install because one or more required items could not be found....
8Cannot complete the install because one or more required items could not be found....
5Cannot complete the install because one or more required items could not be found....
5Cannot complete the install because of a conflicting dependency....
5Cannot complete the install because one or more required items could not be found....
4Cannot complete the install because one or more required items could not be found....
4Cannot complete the install because one or more required items could not be found....
4Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Your original request has been modified....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
11 ???????????????????????????????????????...
1Your original request has been modified....
1The copies of profile C__Users_HM001_eclipse_jee-2018-09_eclipse are not in sync.
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1操作を続行できません。 別のインストール操作が進行中です。
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
11 ?????????????????????????????????...
11 ?????????????????????????????????...
1Cannot complete the install because one or more required items could not be found....
11 ?????????????????????????????????...
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
Download last 500 errors (CSV)
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Spring Tools 4 (aka Spring Tool Suite 4).

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Wednesday, December 12, 2018 - 00:14
sdentu's picture

Warning: You are installing software that contains unsigned content. The authenticity or validity of this software cannot be established. Do you want to continue with the installation?
  /Users/francesco/.p2/pool/plugins/org.eclipse.lsp4j_0.6.0.v20181119-0912.jar
  /Users/francesco/.p2/pool/plugins/org.eclipse.lsp4j.jsonrpc_0.6.0.v20181119-0912.jar
 

Can I proceed?

mlippert's picture

Yes, you can proceed. We are grabbing an unsigned snapshot version of those plugins for the latest version of the Spring Tools 4 and hope to be able to go back to signed versions for the next version. Until then, you can proceed and install those unsigned bundles.

sdentu's picture

Warning: You are installing software that contains unsigned content. The authenticity or validity of this software cannot be established. Do you want to continue with the installation?
.p2/pool/plugins/org.eclipse.lsp4j_0.6.0.v20181119-0912.jar
.p2/pool/plugins/org.eclipse.lsp4j.jsonrpc_0.6.0.v20181119-0912.jar
 

I haven't found any mention to this error: can I proceed or not? 

mlippert's picture

Yes, you can proceed. We are grabbing an unsigned snapshot version of those plugins for the latest version of the Spring Tools 4 and hope to be able to go back to signed versions for the next version. Until then, you can proceed and install those unsigned bundles.

iishkulov's picture

Unable to install from market place. Getting message "No repository found at .../download.springsource.com/release/TOOLS/sts4/update/e4.9/."

The problem is that ulr leads me to cloudflare and asks to enter CAPTURE.

mlippert's picture

Yeah, Cloudflare caches the content for us, so that is fine, but the capture is strange and should not happen. But the URL is not meant to be used in a browser, so not sure where the capture appears...?!?

I would recommend to remove the update site URL from the preferences, restart STS, and try again. If that doesn't help, you could also try to go to "Install New Software" yourself (in your Eclipse installation) and select the update site there to see if that works. You could also try to use a slightly different one (http://download.springsource.com/release/TOOLS/sts4/update/latest/ or http://dist.springsource.com/release/TOOLS/sts4/update/e4.9/) - as a third option to try.

cralexcomp's picture

Tried the third option and finally worked !!!!!!!!!!!! WHAAAA so happy :)

sedmunds's picture

I just get the message "No repository found at .../download.springsource.com/release/TOOLS/sts4/update/e4.9/." when I try to install with Eclipse Marketplace.

mlippert's picture

This is usually caused by a network glitch and stale cached data afterwards. Please go to the "Preferences -> Install/Update -> Available Update Sites" and remove to corresponding update site from that list (not disable it but remove it completely). Then restart and retry. That should solve the issue.

Another option would be to go to https://spring.io/tools and download a ready-to-use distribution of Spring Tools 4 for Eclipse, it is based on the latest Eclipse 2018-09 release and comes with the Spring Tools 4 pre-installed.

mschoepf's picture

I just installed a fresh download of Spring Tool Suite 4 for Eclipse from spring.io on my mac (highSierra) but cannot open the Spring perspective (a small red square appears in front of Spring selection element).

No change after manually deinstalling/installing Spring Tools 4 (aka Spring Tool Suite 4) and running -clean.

Any help is greatly appreciated!

 

mlippert's picture

Spring Tools 4 don't contain any Spring perspective anymore, the major elements got added to the regular Java perspective, since that is what most people use for daily Spring Boot app development. So if you open an existing workspace that had the Spring perspective open from STS3 with STS4, you should close that perspective and continue with the Java one instead.

pcogbill's picture

Using Photon on Windows 10, downloading org.springframework.tooling.cloudfoundry.manifest.ls is failing because it is not available via HTTP and only HTTPS. I have changed the location in Prefences > Install/Update > Available Software Sites to use HTTPS, but it gets switched back to HTTP and duplicates the listing. I have tried reloading and it does not work either. Any ideas? Can I manually download the manifest and put it someplace?

mlippert's picture

Downloading an individual bundle is possible, but it doesn't really help much, since you can't easily install that into your Eclipse. What happens if you go to "Install New Software" and put the HTTPS version of the URL in there? Does that work?

I am not aware of any mechanism that replaces the HTTPS automatically with the HTTP one and I am sure that the P2 repository that contains this bundle is available via the HTTP as well as tne HTTPS version of the URL. So maybe some network specific settings/proxies in your environment?

You could also try and download the whole STS 3.9.5 update site for Eclipse 4.8 from here: https://spring.io/tools/sts/all - and add that as a local update site to your installation (just an additional option to try).

ssauravp3j's picture

I am trying to install STS quick search on Eclipse Oxygen for MAC. I am getting the error 

No repository found at http:/download.springsource.com/release/TOOLS/update/e4.7/.

Is location of repository changed. How can I install?

 

mlippert's picture

The repository location hasn't changed, I guess there is an issue with stale data in the cache somewhere. You can go to the preferences, select the update location, and press "Reload", that usually helps. If not, remove the update site from the preferences, restart Eclipse, and add it back again (Preferences -> Install/Update -> Available Update Sites).

mrajn2b's picture

An error occurred while collecting items to be installed
session context was:(profile=_home_manish_eclipse_jee-neon_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at dist.springsource.com/release/TOOLS/update/3.9.2.RELEASE/e4.6/plugins/javax.jms_1.1.0.v201205091237.jar.
Connection reset

mlippert's picture

This looks like a typical network or repository caching issue. I would recommend to go to the Preferences -> Install/Update -> Available Updtae Sites, select the one that is used ("dist.springsource.com/release/TOOLS/update/e4.6" and/or "dist.springsource.com/release/TOOLS/update/3.9.2.RELEASE/e4.6/") and press "reload". That refreshes the internal repository caches. Then try again the install. You could also delete all those STS-related update sites from that preference and try again the marketplace entry. That should solve the issue.

pdelange's picture

I'm an admitted n00b; error is below. If there is a better place to be posting/seeking help with this please advise!

Cannot complete the install because of a conflicting dependency.
  Software being installed: Spring IDE Roo Support 3.7.3.201602250914-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.7.3.201602250914-RELEASE)
  Software currently installed: Eclipse Platform 4.7.2.v20171130-0510 (org.eclipse.platform.feature.group 4.7.2.v20171130-0510)
  Only one of the following can be installed at once:
    Browser Support 3.6.100.v20170418-1342 (org.eclipse.ui.browser 3.6.100.v20170418-1342)
    Browser Support 3.4.200.v20131003-1453 (org.eclipse.ui.browser 3.4.200.v20131003-1453)
  Cannot satisfy dependency:
    From: AspectJ Development Tools 2.2.4.e44x-20150610-1600 (org.eclipse.ajdt.feature.group 2.2.4.e44x-20150610-1600)
    To: org.eclipse.contribution.weaving.jdt 0.0.0
  Cannot satisfy dependency:
    From: JDT Weaving 2.2.4.e44x-20150610-1600 (org.eclipse.contribution.weaving.jdt 2.2.4.e44x-20150610-1600)
    To: bundle org.eclipse.ui.browser [3.4.0,3.6.0)
  Cannot satisfy dependency:
    From: Eclipse Platform 4.7.2.v20171130-0510 (org.eclipse.platform.feature.group 4.7.2.v20171130-0510)
    To: org.eclipse.ui.browser [3.6.100.v20170418-1342]
  Cannot satisfy dependency:
    From: Spring IDE Roo Support 3.7.3.201602250914-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.7.3.201602250914-RELEASE)
    To: org.eclipse.ajdt.feature.group 2.0.1

mlippert's picture

Not sure how exactly you are trying to install the Spring Roo support (and why) and from which update site, but using the STS product update site from here (http://dist.springsource.com/release/TOOLS/update/e4.7/) should work. Otherwise I would recommend to download a ready-to-use STS distribution from that site and use the Dashboard to install the Spring IDE Roo extension from there.

vbandlamudi's picture

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=C__eclipse_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
Error reading signed content.
Exception in opening zip file: C:\Users\Venkatesh\.p2\pool\plugins\org.aspectj.ajde_1.8.13.201710301818.jar

mlippert's picture

MIght be a corrupted download or stale cache data in the p2 pool. I would suggest to delete the file, open Eclipse again, check the preferences if the STS update site already landed there and if so, select it and press "reload", just to make sure caches are invalidated. Then try again. Another option would be to use the update site directly or download a ready-to-use Eclipse distribution with the STS tools pre-installed via https://spring.io/tools.

adegenhardt's picture

When I select Gradle in new proyect, plugin show this error:

Can not import using Gradle (Buildship 1.x) because Buildship Gradle Tooling version 1.x is not installed.

mlippert's picture

In case you select Gradle as the build environment when importing or creating new Spring projects, you need to have some kind of Gradle support installed in your Eclipse environment. We strongly recommend to use Buildship 2 for this. The error message indicates that you probably don't have that support installed.

You can get Buildship from the Eclipse Marketplace (right from within Eclipse using the Help menu). Once you have that installed and select Gradle in the import wizard, the error should not appear anymore.

jamaltheen20's picture

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at dist.springsource.com/release/TOOLS/update/3.8.4.RELEASE/e4.5/plugins/org.springsource.ide.eclipse.commons.cloudfoundry.client_3.8.4.201703310458-RELEASE.jar.
Read timed out
Unable to read repository at dist.springsource.com/release/TOOLS/update/3.8.4.RELEASE/e4.5/plugins/org.springsource.ide.eclipse.commons.cloudfoundry.client.v2_3.8.4.201703310634-RELEASE.jar.
Read timed out

mlippert's picture

The mentioned artifacts are available, so it looks like there is some stale cache data somewhere. I would recommend to go to the Preferences -> install/Update -> Available Update Sites, select the one for STS (or multiple ones if you have more than one), and press "Reload". That should cause the cached data to be refreshed.

If this doesn't help, you could try to remove the update site from that list (in the preferences), restart Eclipse, and add it back to that list.

Hope this helps!!!

jamaltheen20's picture

I tried the both steps but same error arised.

thank you for the quick reply.

mlippert's picture

In that case I would remove all STS-related update sites from the preferences and restart STS. Then go to the "Install New Software" dialog and put http://download.springsource.com/release/TOOLS/update/e4.5 into the update site URL field (if you are running Eclipse 4.5). Then select the components you want to install and continue. Make sure you have the main Eclipse Neon update in your preferences and active, so that missing components will be fetched from threre.

tmutuguppesripathiul1's picture

Thanks a lot. This helped me. I used e4.7 for Eclipse Oxygen and I could resolve the issue.

mlippert's picture

Glad to hear I could help and that you got this working!!!

fcadili's picture

I've installed in an eclipse J2ee platform 4.6.3 (neon 3) the STS 3.8.4.201703310634-RELEASE first downloading it from update site (...release/TOOLS/update/e4.6/) and then from the marketplace but Spring plugins aren't loaded properly .

I've looked for any of the custom spring elements inside eclipse environment, for instance spring perspective, or spring nature, spring preferences, but I found none of them.

Have I downgrade my eclipse j2ee installation to 4.6.2 or 4.6.1?
My previous spring installation is based on eclipse j2ee mars 2 and works fine even if it is a bit old.

Francesco

mlippert's picture

Do you see any error? Maybe in the error log? I need a bit more details about the problem, since the general install should just work fine. An alternative approach would be to download the ready-to-use STS distribution from https://spring.io/tools, which is a Neon.3 Eclipse with STS components pre-installed.

If you want to dive deeper into debugging what went wrong with the install, you could open a console view, switch to the OSGi Host Console, and type "ss" for "short status" to see which bundles are installed and what state they are in. If some of them are in the state "INSTALLED", something is wrong and we could dive deeper from there.

fcadili's picture

I think I found an answer to my problems: the update site ****://download.springsource.com/release/TOOLS/update/e4.6 works fine but ****://dist.springsource.com/release/TOOLS/update/e4.6/ seams not work.

The dig gives for download.springsource.com:
;; ANSWER SECTION:
download.springsource.com. 261 IN CNAME dgkephn8a5i01.cloudfront.net.
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.241
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.230
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.77
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.85
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.248
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.34
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.127
dgkephn8a5i01.cloudfront.net. 21 IN A 54.230.95.211

whereas for dist.springsource.com:
;; ANSWER SECTION:
dist.springsource.com. 233 IN A 104.16.65.137
dist.springsource.com. 233 IN A 104.16.69.137
dist.springsource.com. 233 IN A 104.16.67.137
dist.springsource.com. 233 IN A 104.16.66.137
dist.springsource.com. 233 IN A 104.16.68.137

Francesco

mlippert's picture

download.springsource.com is the CDN version of dist.springsource.com (so the various IPs make absolute sense), but both should work and should serve the same content. The network route to both will be different, but the served content is the same. I still think that stale cache data causes dist.springsource.com to not work for you case.

fcadili's picture

At least I installed STS on eclipse J2EE neon 3. The working sequence was:
1. install STS from market place on a clean up version of eclipse J2EE. (The installation form the updated site didn't work since I got a fatal exception at eclipse restart.)
2. Then install the other plugins.

Thank you. Francesco

mlippert's picture

Do you see any error message in the Error Log view that could be related? Or did the installation went smoothly and afterwards, you don't see anything in Eclipse? Isn't there a Spring perspective that you could select?

sdhir30g's picture

Trying to install in Eclipse neon using update site and get following error:
An error occurred while collecting items to be installed
session context was:(profile=C__Program Files_eclipse_jee-neon_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.net4j.jms.api,3.0.0.v20110215-1551
No repository found containing: osgi.bundle,org.springframework.roo.wrapping.protobuf-java-lite,2.3.0.0001

mlippert's picture

I am wondering which marketplace entry you chose. I tried to install STS 3.8.3 into Neon via the Marketplace a minute ago and it worked so far. Can you verify that you chose STS 3.8.3 from the Marketplace? I am also wondering why there is a bundle called "org.eclipse.net4j.jms.api" being installed. This is not used directly by the STS components, but maybe it is chosen by the underlying mechanism as a provider for jms packages? Maybe... Anyway, you could also try to install STS by using the update site directly in the "Install New Software" dialog (in case the marketplace entry continue to not work for you). Make sure you choose http://download.springsource.com/release/TOOLS/update/e4.6. It would also be useful to check the configured update sites in the preferences (Install/Update -> Available Update Sites) and make sure that there is not another, maybe wrong update site configured (in addition to the correct one, mentioned above).

nchowdhury's picture

*Eclipse Details*
Eclipse IDE for Java Developers
Version: Mars.2 Release (4.5.2)
Build id: 20160218-0600

*System Details*
Win 10 pro (x64)

*Error*
An error occurred while collecting items to be installed
session context was:(profile=J__Eclipse_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at (http://)dist.springsource.com/release/TOOLS/update/3.8.3.RELEASE/e4.5/plugins/org.springsource.ide.eclipse.commons.cloudfoundry.client_3.8.3.201612190658-RELEASE.jar
Read timed out

mlippert's picture

Can you try to remove the STS update site from the preferences (Available Update Sites), restart Eclipse, add it back, and try again? It looks like a temporary network issue, but that might have left stale cache data in the installation. The removal of the update site + restart should clean that up.

If that doesn't work, you can try to manually use the repo URL: http://download.springsource.com/release/TOOLS/update/e4.5

Hope that helps!!!

smonllordwl's picture

I use the following Eclipse Neon.2

  • Eclipse Java EE IDE for Web Developers
  • Version: Neon.2 Release (4.6.2)
  • Build id: 20161208-0600
  • Eclipse path: C:\eclipse-jee-neon

and get the following error:

An error occured during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.

session context was:(profile=C_eclipse-jee-neon_eclipse,phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
Error reading signed content.
Exception in opening zip file:
C:\Users\smo\.p2\pool\plugins\com.fasterxml.jackson.core.jackson-annotations_2.5.0.v201504151636.jar

Can anyone help me? Thank you in advance.

smonllordwl's picture

The problem was, that the following two .jar archives were corrupted:

com.fasterxml.jackson.core.jackson-annotations_2.5.0.v201504151636.jar
com.fasterxml.jackson.core.jackson-core_2.5.0.v201504151636.jar

The solution was:

1) Download the two artifacts manually for example from University of Kent UKMirror Service
2) Replace the two corrupted artifacts in C:\Users\smo.p2\pool\plugins\ with the manually downloaded ones
3) Reinstall the plugin over the Eclipse Marketplace

narinicheva's picture

Environment: Windows 7, Java 8 (Update 101), Eclipse Neon (4.6), Spring IDE 3.8.1.
When I open Spring Dashboard, Eclipse shuts down.
There are some details from the log file:

# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ILLEGAL_INSTRUCTION (0xc000001d) at pc=0x000007fee296ca90, pid=3464, tid=0x0000000000001b34
#
# JRE version: Java(TM) SE Runtime Environment (8.0_101-b13) (build 1.8.0_101-b13)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.101-b13 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C 0x000007fee296ca90
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

mlippert's picture

Hard to tell what is going wrong here. You might want to switch to the old dashboard (via the preferences) if this crash happens again. Does this crash happen every time?

vbudovskiy's picture

Use Luna Service Release 2 (4.4.2). After isntalling STS from eclipse marketplase i cannot find Spring Project Templates at menu (New->Other...) Can anyone tell me how can I fix it?

mlippert's picture

The wizard "Spring Project Templates" got replaced with "New Spring Legacy Project". You will find template projects there. But I would strongly recommend to create new Spring Boot projects instead, using the "New Spring Starter Project" and "Import Getting Started Content" wizards. They create up-to-date Spring projects. The templates are deprecated and no longer recommended. Therefore the wizard is already called "Legacy"... :-)

sjain0rk's picture

I am using Eclipse Mars.1 Release (4.5.1). I am trying to install this suite to my eclipse. I am getting this error every time.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at htt://dist.springsource.com/release/TOOLS/update/3.8.0.RELEASE/e4.5/plugins/org.eclipse.m2e.maven.runtime_1.7.0.20160603-1931.jar.
Read timed out
Unable to read repository at htt://dist.springsource.com/release/TOOLS/update/3.8.0.RELEASE/e4.5/plugins/org.aspectj.ajde_1.8.9.201604061446.jar.
Read timed out
Unable to read repository at htt://dist.springsource.com/release/TOOLS/update/3.8.0.RELEASE/e4.5/plugins/org.springsource.ide.eclipse.commons.cloudfoundry.client.v2_3.8.0.201606301005-RELEASE.jar.
Read timed out

Please help

PS: I deleted the 'p' from 'http' to post the comment without error

mlippert's picture

This looks like stale cache data from the p2 repositories. I would recommend to delete the STS repositories from the preferences (Update/Install -> Available Update Sites), restart STS, and add that update site again. That usually solves this issue.

nluittanloc's picture

After install newest STS, I can't create normal maven project anymore. It's not visible in new window. Does anyone know how to solve that problem?

hnguyen8g4's picture

I have the same problem after upgrading to the latest STS. The maven perspective/view is gone after upgrading to the new STS. Maven option is also removed from "Run As" and "Configure" menus.

mlippert's picture

I don't have an immediate fix for this problem at hand, but I would love to investigate this in more detail. Would you mind reporting an issue here: https://github.com/spring-projects/spring-ide/issues. That would be great. We could continue the discussion from there. I think I will have to ask for further details (like the state of certain bundles, etc.), so the GitHub issue would make a lot of sense. Thanks!!!