GNU MCU Eclipse

Add this URL to your Eclipse Installation to reach this solution's update site.

Oxygen (4.7)
Neon (4.6)
Photon (4.8)


Learn more...

Details Group Tabs

Wednesday, July 18, 2018 - 08:03
creckord's picture

The installation data for this entry is broken at the moment. All listed installable units are missing a ".feature" at the end, meaning they can't be found on the update site and therefore installation through the Marketplace Client fails with "The following solutions are not available: GNU MCU Eclipse 4.2.1".

lionescu's picture

I edited the marketplace page and added .feature at the end of each feature id, and now it seems ok.

 

Thank you for the hint,

 

Liviu

 

lionescu's picture

Thank you Carsten, I nticed that from a certain moment installing from the marketplace failed, but I don't remember doing anything special with my builds. I even registered a bug in bugzilla, but received no answer. Installing directly from the update site works as expected.

Can you be more specific on the missing `.feature` at the end? 

The feature projects do have a .feature at the end. And also the feature name, as defined in feature.xml, has a .feature at the end. (https://github.com/gnu-mcu-eclipse/eclipse-plugins/tree/develop/features).

Can you suggest a fix?

 

 

lionescu's picture

Thank you Carsten, I nticed that from a certain moment installing from the marketplace failed, but I don't remember doing anything special with my builds. I even registered a bug in bugzilla, but received no answer. Installing directly from the update site works as expected.

Can you be more specific on the missing `.feature` at the end? 

The feature projects do have a .feature at the end. And also the feature name, as defined in feature.xml, has a .feature at the end. (https://github.com/gnu-mcu-eclipse/eclipse-plugins/tree/develop/features).

Can you suggest a fix?