Error Report

Saturday, June 22, 2024 - 03:51 by Anonymous (not verified)
Read status
unread
Error code
4
Error message
Operation details
Installable Units Reported
org.springframework.tooling.boot.ls.feature.feature.group,4.23.1.202406141939
Detailed Message
Cannot complete the install because of a conflicting dependency.
Software being installed: Spring Boot Language Server Feature 4.23.1.202406141939 (org.springframework.tooling.boot.ls.feature.feature.group 4.23.1.202406141939)
Software currently installed: Eclipse IDE for Java Developers 4.15.0.20200313-1200 (epp.package.java 4.15.0.20200313-1200)
Only one of the following can be installed at once:
Core Runtime 3.17.100.v20200203-0917 (org.eclipse.core.runtime 3.17.100.v20200203-0917)
Core Runtime 3.31.100.v20240524-2010 (org.eclipse.core.runtime 3.31.100.v20240524-2010)
Cannot satisfy dependency:
From: Eclipse IDE for Java Developers 4.15.0.20200313-1200 (epp.package.java 4.15.0.20200313-1200)
To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.15.0.v20200305-0155,4.15.0.v20200305-0155]
Cannot satisfy dependency:
From: Notification API 0.7.200.v20240321-1245 (org.eclipse.jface.notifications 0.7.200.v20240321-1245)
To: osgi.bundle; org.eclipse.core.runtime 3.29.0
Cannot satisfy dependency:
From: Eclipse Platform 4.15.0.v20200305-0155 (org.eclipse.platform.feature.group 4.15.0.v20200305-0155)
To: org.eclipse.equinox.p2.iu; org.eclipse.core.runtime [3.17.100.v20200203-0917,3.17.100.v20200203-0917]
Cannot satisfy dependency:
From: Spring Boot Language Server 1.55.1.202406141939 (org.springframework.tooling.boot.ls 1.55.1.202406141939)
To: osgi.bundle; org.eclipse.jface.notifications 0.0.0
Cannot satisfy dependency:
From: Spring Boot Language Server Feature 4.23.1.202406141939 (org.springframework.tooling.boot.ls.feature.feature.group 4.23.1.202406141939)
To: org.eclipse.equinox.p2.iu; org.springframework.tooling.boot.ls [1.55.1.202406141939,1.55.1.202406141939]