Error Report

Wednesday, June 19, 2024 - 23:27 by Anonymous (not verified)
Read status
unread
Error code
4
Error message
Operation details
Installable Units Reported
org.springframework.boot.ide.main.feature.feature.group,4.23.1.202406150140
Detailed Message
Cannot complete the install because of a conflicting dependency.
Software being installed: Spring Boot Language Server Feature 4.23.1.202406141939 (org.springframework.tooling.boot.ls.feature.feature.group 4.23.1.202406141939)
Software currently installed: Eclipse IDE for Java EE Developers 4.5.2.20160218-0600 (epp.package.jee 4.5.2.20160218-0600)
Only one of the following can be installed at once:
Core Resource Management 3.10.0.v20150423-0755 (org.eclipse.core.resources 3.10.0.v20150423-0755)
Core Resource Management 3.10.1.v20150725-1910 (org.eclipse.core.resources 3.10.1.v20150725-1910)
Core Resource Management 3.20.200.v20240513-1323 (org.eclipse.core.resources 3.20.200.v20240513-1323)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 4.5.2.20160218-0600 (epp.package.jee 4.5.2.20160218-0600)
To: org.eclipse.epp.package.jee.feature.feature.group [4.5.2.20160218-0600]
Cannot satisfy dependency:
From: EPP Java EE IDE Feature 4.5.2.20160218-0600 (org.eclipse.epp.package.jee.feature.feature.group 4.5.2.20160218-0600)
To: org.eclipse.platform.feature.group [4.5.2.v20160212-1500]
Cannot satisfy dependency:
From: Eclipse Platform 4.5.2.v20160212-1500 (org.eclipse.platform.feature.group 4.5.2.v20160212-1500)
To: org.eclipse.core.resources [3.10.1.v20150725-1910]
Cannot satisfy dependency:
From: Spring Boot Language Server Feature 4.23.1.202406141939 (org.springframework.tooling.boot.ls.feature.feature.group 4.23.1.202406141939)
To: org.springframework.tooling.ls.eclipse.gotosymbol 0.0.0
Cannot satisfy dependency:
From: Goto Symbol Popup 4.23.1.202406141939 (org.springframework.tooling.ls.eclipse.gotosymbol 4.23.1.202406141939)
To: bundle org.eclipse.core.resources 3.12.0