Error Report

Wednesday, June 19, 2024 - 15:57 by Anonymous (not verified)
Read status
unread
Error code
4
Error message
Operation details
Installable Units Reported
org.springframework.boot.ide.main.feature.feature.group,4.23.1.202406150140
Detailed Message
Cannot complete the install because one or more required items could not be found.
Software being installed: Spring Tool Suite 4 Main Feature 4.23.1.202406150140 (org.springframework.boot.ide.main.feature.feature.group 4.23.1.202406150140)
Missing requirement: Equinox Provisioning Engine 2.10.200.v20240425-1316 (org.eclipse.equinox.p2.engine 2.10.200.v20240425-1316) requires 'package org.bouncycastle.openpgp 1.65.0' but it could not be found
Cannot satisfy dependency:
From: Generic and Extensible Text Editor 1.3.400.v20240511-1105 (org.eclipse.ui.genericeditor 1.3.400.v20240511-1105)
To: bundle org.eclipse.ui.ide 3.12.0
Cannot satisfy dependency:
From: Eclipse IDE UI 3.22.200.v20240524-2010 (org.eclipse.ui.ide 3.22.200.v20240524-2010)
To: bundle org.eclipse.equinox.p2.engine [2.8.0,3.0.0)
Cannot satisfy dependency:
From: Spring Tool Suite 4 Main Feature 4.23.1.202406150140 (org.springframework.boot.ide.main.feature.feature.group 4.23.1.202406150140)
To: org.springframework.ide.eclipse.boot.launch [4.23.1.202406150140]
Cannot satisfy dependency:
From: Boot Launch 4.23.1.202406150140 (org.springframework.ide.eclipse.boot.launch 4.23.1.202406150140)
To: bundle org.eclipse.ui.genericeditor 0.0.0