Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.roo.feature.feature.group,3.7.3.201602250914-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: Spring IDE Roo Support 3.7.3.201602250914-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.7.3.201602250914-RELEASE) Software currently installed: Eclipse Java Development Tools 3.13.1.v20171009-0410 (org.eclipse.jdt.feature.group 3.13.1.v20171009-0410) Only one of the following can be installed at once: Java Code Manipulation Functionality 1.9.0.v20161219-2145 (org.eclipse.jdt.core.manipulation 1.9.0.v20161219-2145) Java Code Manipulation Functionality 1.5.0.v20130605-1748 (org.eclipse.jdt.core.manipulation 1.5.0.v20130605-1748) Java Code Manipulation Functionality 1.9.50.v20170920-1015 (org.eclipse.jdt.core.manipulation 1.9.50.v20170920-1015) Cannot satisfy dependency: From: AspectJ Development Tools 2.2.4.e44x-20150610-1600 (org.eclipse.ajdt.feature.group 2.2.4.e44x-20150610-1600) To: org.eclipse.ajdt.ui [2.2.4.e44x-20150610-1600] Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.4.e44x-20150610-1600 (org.eclipse.ajdt.ui 2.2.4.e44x-20150610-1600) To: bundle org.eclipse.jdt.core.manipulation [1.3.0,1.7.0) Cannot satisfy dependency: From: Eclipse Java Development Tools 3.13.1.v20171009-0410 (org.eclipse.jdt.feature.group 3.13.1.v20171009-0410) To: org.eclipse.jdt.core.manipulation [1.9.50.v20170920-1015] Cannot satisfy dependency: From: Spring IDE Roo Support 3.7.3.201602250914-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.7.3.201602250914-RELEASE) To: org.eclipse.ajdt.feature.group 2.0.1