JiraConnector

Add this URL to your Eclipse Installation to reach this solution's update site.

2023-12 (4.30), 2023-09 (4.29), 2024-03 (4.31), 2024-06 (4.32)

https://gnl42.github.io/JiraConnector-update/

Learn more...
Solution Description

JiraConnector is a Mylyn Tasks connector that allows you to interact with a Atlassian Jira server.

It is a fork of the excellent Atlassian Connector for Eclipse and such should work with a current Jira/Bamboo Server or Data Center.

Supports Jira's Personal Access Token option

Jira Server/Data Canter 8,9, and Cloud supported

Updated 2023-11-26, version 5.0.0

 

Additional Details

Eclipse Versions: 2023-12 (4.30), 2023-09 (4.29), 2024-03 (4.31), 2024-06 (4.32)

Platform Support: Windows, Mac, Linux/GTK

Development Status: Production/Stable

Date Created: Monday, May 30, 2022 - 03:45

License: EPL

Date Updated: Sunday, November 26, 2023 - 15:37

Submitted by: George Lindholm

Screenshot
Date Ranking Installs Clickthroughs
June 2024 0/0 0 7
May 2024 0/0 0 20
April 2024 0/0 0 13
March 2024 0/0 0 6
February 2024 0/0 0 277
January 2024 291/691 52 10
December 2023 317/671 39 5
November 2023 272/686 64 14
October 2023 288/673 54 11
September 2023 276/663 55 7
August 2023 242/673 66 7
July 2023 275/668 50 10
View Data for all Listings

Unsuccessful Installs

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)

Marketplace Drag to Install Button

By adding the following code below to your website you will be able to add an install button for JiraConnector.

HTML Code:

Markdown Syntax:

Output:

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Reviews Add new review

Whenever I am trying to install, I am getting error as below.

Cannot complete the install because one or more required items could not be found.
 Software being installed: JiraConnector for Eclipse 4.3.0.v20221217-0902 (me.glindholm.connector.eclipse.feature.group 4.3.0.v20221217-0902)
 Missing requirement: Jira Rest Java Client 6.1.0.202212170902 (jira-rest-java-client-core 6.1.0.202212170902) requires 'osgi.bundle; org.slf4j.api 0.0.0' but it could not be found
 Cannot satisfy dependency:
   From: JiraConnector for Eclipse 4.3.0.v20221217-0902 (me.glindholm.connector.eclipse.feature.group 4.3.0.v20221217-0902)
   To: org.eclipse.equinox.p2.iu; me.glindholm.connector.eclipse.jira.feature.group [4.3.0.v20221217-0902,4.3.0.v20221217-0902]
 Cannot satisfy dependency:
   From: JiraConnector for Eclipse Jira Core 4.3.0.v20221217-0902 (me.glindholm.connector.eclipse.jira.core 4.3.0.v20221217-0902)
   To: osgi.bundle; jira-rest-java-client-core 6.1.0
 Cannot satisfy dependency:
   From: Atlassian JIRA Connector (Recommended) 4.3.0.v20221217-0902 (me.glindholm.connector.eclipse.jira.feature.group 4.3.0.v20221217-0902)
   To: org.eclipse.equinox.p2.iu; me.glindholm.connector.eclipse.jira.core [4.3.0.v20221217-0902,4.3.0.v20221217-0902]