Eclipse Foundation Member
IBM MobileFirst Platform Test Workbench

Add this URL to your Eclipse Installation to reach this Solution's Update Site.

Mars (4.5)
Luna (4.4)

Learn more...

Details Group Tabs

hvanderzwet's picture

When trying to install the Test Workbench (on linux Mint 17.3) I get the following error(s).
---------------------------------------
Cannot complete the install because one or more required items could not be found.
Software being installed: IBM MobileFirst Platform Test Workbench 8.7.0.v20160112_2203 (com.ibm.rtw.extension.feature.feature.group 8.7.0.v20160112_2203)
Missing requirement: Apache 5.0.0.v20150814_1720 (com.ibm.rational.test.lt.apache.kernel 5.0.0.v20150814_1720) requires 'bundle org.apache.httpcomponents.httpclient 4.3.6' but it could not be found
Cannot satisfy dependency:
From: Performance Schedule Execution 7.4.330.v20151110_1513 (com.ibm.rational.test.common.schedule.execution 7.4.330.v20151110_1513)
To: bundle com.ibm.rational.test.lt.apache.kernel 0.0.0
Cannot satisfy dependency:
From: Rational Performance Tester Core 8.7.10.v20151208_2051 (com.ibm.rational.test.lt.core.feature.feature.group 8.7.10.v20151208_2051)
To: com.ibm.rational.test.common.schedule.execution [7.4.330.v20151110_1513]
Cannot satisfy dependency:
From: IBM MobileFirst Platform Test Workbench 8.7.0.v20160112_2203 (com.ibm.rtw.extension.feature.feature.group 8.7.0.v20160112_2203)
To: com.ibm.rational.test.lt.core.feature.feature.group 0.0.0

mplatform's picture

Hello Hans,

Can you provide the Eclipse version you are using as well as the installation steps (i.e. did you accept the non-signed libraries?) taken during installation.

I was just now able to successfully install the MobileFirst Test Workbench on Mars running on x64 Ubuntu 14.04.3

Thanks!
Mark

hvanderzwet's picture

Hi Mark,

Thank you for your reply.

Yes, I accepted all non-signed libraries, and installing the Development Sudio was no problem.

I'm using the following environment:
- Linux Mint 17.3
- Eclipse Juno (as recommended per developer_ibm_com/mobilefirstplatform/install/#studio )

Regards,

Hans.

mplatform's picture

Hi Hans,

Thank you for getting back to us with your development environment details. MobileFirst Platform Studio supports a wider range of Eclipse versions than does the Test Workbench. The Test Workbench failure you encountered is expected when installing on Juno. Would you please upgrade your Eclipse to either Mars (4.5) or Luna (4.4) and then reinstall the Test Workbench.

Thanks!
Mark

hvanderzwet's picture

Hi Mark,

I've gone for the latest & greatest (aka Mars.2) ... I can confirm everything installs without a problem ...

Thank you very much for your time & efforts.

Regards,

Hans.