Tmar Plugin

Add this URL to your Eclipse Installation to reach this solution's update site.

Neon (4.6)
Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

This plugin is a complete set of tools dedicated to "Tmar", the new executable specifications framework:

  1. A smart specification editor (with syntax coloring, table auto-formating and copy-paste, keywords completion, etc...)
  2. Powerful commands for class and method generation (with customizable templates)
  3. A pure Tmar perspective to simplify eclipse menus and toolbars (for non-technical users)
  4. Test runner (markers, editor colors, tooltips, etc.)

Take a look at this video on youtube :

Tmar's full documentation is available here

Download Tmar library from Jspresso repository or simply let the plugin setup maven dependency for your project (see video below)

Checkout a project sample from svn here

Another video available here

Any question ? any issues ? Go to www.tmar-test.com

Additional Details
Eclipse Versions: 
Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Tue, 2014-01-07 16:18
Development Status: 
Production/Stable
License: 
Commercial - Free
Date Updated: 
Thu, 2018-08-23 15:08
Screenshots
Metrics
DateRankingInstallsClickthroughs
December 2018827/8761 (0%)0
June 2018933/9471 (0%)0
February 2018918/9401 (0%)0
View Data for all Listings
Errors

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Tmar Plugin.

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Monday, December 10, 2018 - 04:30
lmartin's picture

Installed into Elipse Kepler 4.3.2 (SR2):

java.lang.ClassCastException: org.eclipse.jdt.internal.core.CompilationUnit cannot be cast to org.codehaus.jdt.groovy.model.GroovyCompilationUnit
	at org.jspresso.contrib.sjsplugin.tmar.registry.RegProject.updateRegistry(RegProject.java:143)
	at org.jspresso.contrib.sjsplugin.tmar.registry.TmarRegistry.updateMarkersAssynchronously(TmarRegistry.java:466)
	at org.jspresso.contrib.sjsplugin.tmar.registry.TmarRegistry$2.run(TmarRegistry.java:430)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
mmisingnameu3o's picture

Hello Lars.
I was fixing the ClassCastException... but I think the issue reason is that you do not install the groovy plugin, is it true ? Please use jspresso mantis (http://mantis.jspresso.org/my_view_page.php) to report any problem or ask any question.
Kind regards
Maxime

lmartin's picture

Thanks, I will double check my installation. Lars