Eclipse Foundation Member
Spring IDE

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)


Luna (4.4)


Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)


Learn more...

Details Group Tabs

Details

Spring IDE is a set of plugins which are adding support for the popular application framework Spring Framework to the Eclipse platform.

Features:

  • Project nature which adds support of Spring projects
  • Incremental builders validating Spring bean config files
  • Image decorator which decorates all Spring projects, their config files and all Java classes which are used by these config files
  • View which displays all Spring projects and their Spring-related artifacts
  • Textual and graphical editors for Spring configuration files
  • Extension of Eclipse's search facility to search for Spring artifacts
  • Support for refactorings of Spring config files
  • Wizards for creating new Spring projects and config files
  • Support for Spring 2.0 name spaces
  • Support for Spring AOP
  • Support for Spring Web Flow
  • Support for Spring JavaConfig

For support for Eclipse Neon, Oxygen, and beyond, please refer to the successor of the Spring IDE component in the Eclipse Marketplace: the "Spring Tools", which include all the plugins that Spring IDE provided in the past and includes a few additional ones, including compatibility with the latest Eclipse versions.

Categories:
Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Mon, 2005-07-25 19:35
Development Status: 
Production/Stable
License: 
EPL
Date Updated: 
Thu, 2018-03-08 12:57
Metrics
DateRankingInstallsClickthroughs
December 201863/887761 (0.32%)25
November 201862/9391983 (0.32%)41
October 201857/9432165 (0.34%)79
September 201895/941980 (0.19%)30
August 2018109/939868 (0.17%)43
July 2018102/940996 (0.18%)42
June 201885/9471046 (0.21%)34
May 201883/9541190 (0.22%)34
April 201878/9461309 (0.24%)34
March 201866/9611559 (0.28%)45
February 201864/9401386 (0.3%)47
January 201861/9451530 (0.3%)59
View Data for all Listings
Errors

Unsuccessful Installs in the last 7 Days: 112

CountError Message
13Cannot complete the install because one or more required items could not be found....
13Cannot complete the install because one or more required items could not be found....
8Cannot complete the install because one or more required items could not be found....
7Cannot complete the install because one or more required items could not be found....
7Cannot continue the operation. There is another install operation in progress.
6Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because of a conflicting dependency....
3Cannot complete the install because of a conflicting dependency....
2Cannot complete the install because of a conflicting dependency....
2Cannot complete the install because one or more required items could not be found....
2Your original request has been modified....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because of a conflicting dependency....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
Download last 500 errors (CSV)
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Spring IDE.

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Wednesday, December 12, 2018 - 23:37
fnoori's picture

Hi 

I want to import two plugin Spring IDE and Hibernate. These two files are in my favorites account but when I want to import in favorites page, they didn't takeplace, why?

mlippert's picture

I am sorry, but I don't quite understand exactly what you are describing. What exactly are you trying to achieve? Installing both extensions into Eclipse (Spring IDE and Hibernate)? Via the marketplace? A more exact description with a few steps would probably help to understand what you are trying to do here. And please keep in mind that for supporting Spring application development in Eclipse, you should use the latest versions of the "Spring Tools" extension on the marketplace. The "Spring IDE" item is not compatible with the latest versions of Eclipse anymore and will not show up in the Marketplace Client of your Eclipse installation if you are running a recent Eclipse version.

uguptatto's picture

if we want to make a CRUD spring hibernate project, do we need to install this and work on this only or can we do the same on eclipse EE version without downloading this?

also , what should i insall so that the  annotations start working (@service, @repository, etc) ?

mlippert's picture

You don't need to install the plugins in order to work with Spring in Eclipse. You can also use a plain Eclipse installation and go from there. And you certainly don't need anything specific from your IDE in order to write a project that reads/write some data from/to a database. A nice example how to access data with Spring is here: https://spring.io/guides/gs/accessing-data-jpa/

dchute's picture

I am using Eclipse Oxygen and trying to install Spring IDE but when I search for it in MarketPlace it does not show in the List.

 

Cant install. Please help

 

Thanks in advanced

 

mlippert's picture

That is correct, the Spring IDE entry doesn't show up for Eclipse Oxygen or Eclipse Neon anymore, it got replaced with this: https://marketplace.eclipse.org/content/spring-tools-aka-spring-ide-and-...

pbanicevic's picture

Missing: "Generate Spring ORM Classes" wizard to generate DAOs and Spring Services. Is there another plugin needed now to get that feature ?

mlippert's picture

There are no such wizards in Spring IDE and I am not sure how much value they would provide. Most of the classes you write in a Spring app are plain old Java objects, so there is not much this wizard could/should generate. However, if you have specific ideas in mind and find certain tasks cumbersome, I would be very interested in hearing more details. Maybe we can find ways to support those tasks and add those features to Spring IDE in the future. Please feel free to report enhancement requests to https://issuetracker.springsource.com/browse/STS, maybe attach a small sample project, and let us know what is cumbersome and should be supported by a wizard or something like that. That would be awesome.

mzako's picture

Spring project not available as stated in description... (installed with Eclipse 4.4)

dmisingnamefi5's picture

I was trying to make a Minecraft clone with this IDE but I had trouble getting it installed.

mmisingnamejn6's picture

When is the compatible version for Helios going to come?

vmisingname1ov's picture

link provided to install plug-ins for spring in eclipse 3.4 does not work. it is giving no repository found error.

tteck's picture

The update site URL had been changed to: http://dist.springframework.org/release/IDE

tgladh's picture

Even though I was not trying to download the OSGi, I got the following errors, so I couldn't install it at all:

An error occurred while collecting items to be installed
No repository found containing: javax.jws/osgi.bundle/2.0.0.v200905261939
No repository found containing: javax.xml.bind/osgi.bundle/2.1.9.v200905050702
No repository found containing: javax.xml.ws/osgi.bundle/2.1.0.v200902101523
No repository found containing: org.apache.velocity/osgi.bundle/1.5.0.v200905192330

vmisingname1ov's picture

I have tried this link but giving the following error:

Error occurred while collecting the items to be installed:

An error occurred while collecting items to be installed
Error closing the output stream for org.aspectj.ajde/osgi.bundle/1.6.6.20090930185500 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.aspectj.ajde_1.6.6.200909301855005519344253559059773.jar: Invalid zip file format
Error closing the output stream for org.aspectj.runtime/osgi.bundle/1.6.6.20090930185500 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.aspectj.runtime_1.6.6.200909301855008056000282106402818.jar: Invalid zip file format
Error closing the output stream for org.aspectj.weaver/osgi.bundle/1.6.6.20090930185500 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.aspectj.weaver_1.6.6.200909301855006858145651434066916.jar: Invalid zip file format
Problems downloading artifact: osgi.bundle,org.eclipse.ajdt.core,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Problems downloading artifact: osgi.bundle,org.eclipse.ajdt.doc.user,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for org.eclipse.ajdt.examples/osgi.bundle/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.ajdt.examples_2.0.1.e34x-20090930-12003766172143994951692.jar: Invalid zip file format
Error closing the output stream for org.eclipse.ajdt/org.eclipse.update.feature/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.ajdt_2.0.1.e34x-20090930-12006776184923469857595.jar: Invalid zip file format
Problems downloading artifact: osgi.bundle,org.eclipse.ajdt.mylyn.ui,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for org.eclipse.ajdt.source/osgi.bundle/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.ajdt.source_2.0.1.e34x-20090930-1200185166513131008565.jar: Invalid zip file format
Error closing the output stream for org.eclipse.ajdt.source/org.eclipse.update.feature/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.ajdt.source_2.0.1.e34x-20090930-1200303566091852263761.jar: Invalid zip file format
Problems downloading artifact: osgi.bundle,org.eclipse.ajdt.ui,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Problems downloading artifact: osgi.bundle,org.eclipse.aspectj,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Problems downloading artifact: osgi.bundle,org.eclipse.contribution.visualiser,2.2.0.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for org.eclipse.contribution.weaving/org.eclipse.update.feature/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.contribution.weaving_2.0.1.e34x-20090930-12006976203287525977220.jar: Invalid zip file format
Problems downloading artifact: osgi.bundle,org.eclipse.contribution.weaving.jdt,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for org.eclipse.contribution.weaving.source/osgi.bundle/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.contribution.weaving.source_2.0.1.e34x-20090930-12006863079585788313937.jar: Invalid zip file format
Error closing the output stream for org.eclipse.contribution.weaving.source/org.eclipse.update.feature/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.contribution.weaving.source_2.0.1.e34x-20090930-1200915227782386720441.jar: Invalid zip file format
Problems downloading artifact: osgi.bundle,org.eclipse.contribution.xref.core,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for org.eclipse.contribution.xref/org.eclipse.update.feature/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.contribution.xref_2.0.1.e34x-20090930-12004573393270511198918.jar: Invalid zip file format
Error closing the output stream for org.eclipse.contribution.xref.source/osgi.bundle/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.contribution.xref.source_2.0.1.e34x-20090930-12006631633370853663647.jar: Invalid zip file format
Error closing the output stream for org.eclipse.contribution.xref.source/org.eclipse.update.feature/2.0.1.e34x-20090930-1200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.contribution.xref.source_2.0.1.e34x-20090930-12002458544472036738973.jar: Invalid zip file format
Problems downloading artifact: osgi.bundle,org.eclipse.contribution.xref.ui,2.0.1.e34x-20090930-1200.
Downloaded stream not a valid archive. Check the server.
Problems downloading artifact: osgi.bundle,org.eclipse.equinox.weaving.aspectj,1.0.0.200906171200.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for org.eclipse.equinox.weaving/org.eclipse.update.feature/1.0.0.200906171200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.equinox.weaving_1.0.0.200906171200892982632677803483.jar: Invalid zip file format
Problems downloading artifact: osgi.bundle,org.eclipse.equinox.weaving.hook,1.0.0.200905261348.
Downloaded stream not a valid archive. Check the server.
Error closing the output stream for org.eclipse.equinox.weaving.source/osgi.bundle/1.0.0.200906171200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.equinox.weaving.source_1.0.0.2009061712008932742285210520119.jar: Invalid zip file format
Error closing the output stream for org.eclipse.equinox.weaving.source/org.eclipse.update.feature/1.0.0.200906171200 on repository file:/F:/Birdi/eclipse/.
Error unzipping C:\DOCUME~1\puneet\LOCALS~1\Temp\org.eclipse.equinox.weaving.source_1.0.0.2009061712004013092111863746458.jar: Invalid zip file format