Sourcecode Visualizer

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)


Learn more...

Details Group Tabs

srayan's picture

Unable to read repository at<!.. reository url..>
Received fatal alert: handshake_failure</p>
This error I got when I try to install.</p>

aalimoglu's picture

@Lucian Ilie I have done your latest suggestion but it did not help. It still cannot perform the operation.Cannot complete the install because one or more required items could not be found.
Software being installed: Sourcecode Visualizer 4.5.0.201508311741 (com.drgarbage.sourcecodevisualizer.feature.group 4.5.0.201508311741)
Missing requirement: Dr. Garbage Core Package 4.5.0.201508311741 (com.drgarbage.core.plugin 4.5.0.201508311741) requires 'bundle org.eclipse.gef [3.7.0,3.11.0)' but it could not be found
Cannot satisfy dependency:
From: Sourcecode Visualizer 4.5.0.201508311741 (com.drgarbage.sourcecodevisualizer.feature.group 4.5.0.201508311741)
To: com.drgarbage.core.plugin [4.5.0.201508311741]

lilie's picture

Workaround for this is to manually download the JAR files from sourceforge.net/project/drgarbagetools/eclipse/4.5/stable/, including the ones from the folders "features" and "plugins".
After you have them locally, using the same folder structure, you can install them from Eclipse, using Help > Install new software > Add > Local and select the main folder where you have the files.

aalimoglu's picture

I have tried your suggestion but it did not help. Eclipse gives error as operation cannot be performed. It also tries alternative solutions but did not ended up in success.
Cannot complete the install because one or more required items could not be found.
Software being installed: Bytecode Visualizer 4.5.0.201508311741 (com.drgarbage.bytecodevisualizer.feature.group 4.5.0.201508311741)
Missing requirement: Dr. Garbage Core Package 4.5.0.201508311741 (com.drgarbage.core.plugin 4.5.0.201508311741) requires 'bundle org.eclipse.gef [3.7.0,3.11.0)' but it could not be found
Cannot satisfy dependency:
From: Bytecode Visualizer 4.5.0.201508311741 (com.drgarbage.bytecodevisualizer.feature.group 4.5.0.201508311741)
To: com.drgarbage.core.plugin [4.5.0.201508311741]

lilie's picture

Key to your error is this stacktrace part: requires 'bundle org.eclipse.gef [3.7.0,3.11.0)'...

This bundle should be included in the Eclipse installation. You can go in your Eclipse instance, to Help > Installation details > Plugins and search for Graphical Editing Framework.
You must have it installed and you must have a version between 3.7.0 and 3.11.0, for it to work.

fricciuow's picture

No repository found at sourceforge.net/projects/drgarbagetools/files/eclipse/4.5/stable/.

ztsekash74's picture

Missing the site.xml file in order for Eclipse to install software product

lraja's picture

Can't able to install . I'm using 4.4.2 . Just wanted to know if it is supported.

dkhan066's picture

At Least 3 lines of documentation should have been provided to help us figure out how to use this in eclipse after installation. Cannot even find where it is installed.

salekseev's picture

Eclipse 4.3 (Kepler) is now supported

pverest's picture

Can't install on 3.8.2 or 4.3.0.RC1
What are Eclipse version requirements?

salekseev's picture

The currently supported versions of eclipse are 3.7 (Indigo) 4.2 (Juno).
The release for 4.3 is planned for july.

dsack16r's picture

this is a totally usuable tool.

salekseev's picture

Sourcecode Visualizer is available now as an open source project on http://sourceforge.net/projects/drgarbagetools/