Eclipse Foundation Member
SAP NetWeaver Server Adapter for Eclipse

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

The SAP NetWeaver Server Adapter for Eclipse plug-in implements a server runtime environment for the SAP NetWeaver Application Server. It enables the development of Java EE applications for the SAP NetWeaver Application Server from within any IDE based on Eclipse WTP.

New in version 0.7.2:

  • Several major bugs fixed regarding the publishing mechanism. Details.

Main features:

  • Supports Eclipse Europa and all later releases
  • Supports SAP NetWeaver CE/PI 7.1 and all later releases
  • Supports J2EE 1.4 and Java EE 5 applications
  • Server lifecycle operations implemented
    • start, stop, restart
    • enable debugging, disable debugging
  • Publish operations implemented:
    • deploy and undeploy of EAR archives
    • deploy and undeploy of standalone WAR archives
  • Basic server editor capabilities
Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Wed, 2009-12-09 03:31
Development Status: 
Beta
License: 
EPL
Date Updated: 
Thu, 2018-08-23 15:06
Metrics
DateRankingInstallsClickthroughs
December 2018483/88716 (0.01%)14
November 2018486/93939 (0.01%)17
October 2018495/94336 (0.01%)23
September 2018471/94140 (0.01%)14
August 2018505/93934 (0.01%)11
July 2018459/94047 (0.01%)10
June 2018464/94743 (0.01%)23
May 2018516/95435 (0.01%)16
April 2018474/94644 (0.01%)9
March 2018476/96143 (0.01%)11
February 2018522/94032 (0.01%)5
January 2018479/94541 (0.01%)8
View Data for all Listings
Errors
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for SAP NetWeaver Server Adapter for Eclipse.

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Thursday, December 13, 2018 - 14:27