PTI - PHP Tool Integration

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)


Learn more...

Details Group Tabs

Installs Last Update: 
Friday, June 22, 2018 - 08:00
rfischerc28's picture

I used this plugin a lot worked perfectly, but unfortunately is the website down since several days so I can't install it anymore in my new eclipse setup

mbounya's picture

When opening settings and going to PHP Tools -> PHP Code-Sniffer an alert appears with the following message:

The currently displayed page contains invalid values.

After clicking OK, this appears:

An error has occured. See error log for more details.
java.lang.NullPointerException

I'm using Eclipse Oxygen under Ubuntu

rengaw83's picture

The current displayed page containes invalid values.

An error has occurred. See error log for more details.
java.lang.NullPointerException
whakim's picture

it is not working on Oxygen (4.7)

 Error:

The current displayed page containes invalid values.

rengaw83's picture

Same Problem here in Eclipse Oxygen.1a Release (4.7.1a)

The current displayed page containes invalid values.

An error has occurred. See error log for more details.
java.lang.NullPointerException
whakim's picture

Hello , is it possible to add new codesniffer standard? i want PSR1 or PSR2, etc..

imerayo's picture

Nice plugin to use PHPUnit.

Good job!!!!

srakholiya's picture

Its really very useful PHP Tools for PDT......Thanks