Eclipse Foundation Member
Maven Integration for Eclipse (Luna and newer)

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

m2e provides comprehensive Maven integration for Eclipse. You can use m2e to manage both simple and multi-module Maven projects, execute Maven builds via the Eclipse interface, and interact with Maven repositories. m2e makes development easier by integrating data from a project’s Object Model with Eclipse IDE features. With m2e, you can use Maven within Eclipse in a natural and intuitive interface.

Here is a list of features available in m2e:

  • Creating and importing Maven projects
  • Dependency management and integration with the Eclipse classpath
  • Automatic dependency downloads and updates
  • Artifact Javadoc and source resolution
  • Creating projects with Maven Archetypes
  • Browsing and searching remote Maven repositories
  • POM management with automatic update to dependency list
  • Materializing a project from a Maven POM
  • Adapting nested multi-module Maven projects to the Eclipse IDE
  • Form-based and text-based POM Editor
  • GUI Presentation of Dependency Tree and Resolved Dependencies
Categories:
Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Wed, 2006-08-30 11:09
Development Status: 
Production/Stable
License: 
EPL
Date Updated: 
Thu, 2018-08-23 15:05
Metrics
DateRankingInstallsClickthroughs
December 2018162/902263 (0.09%)32
November 2018152/939573 (0.09%)40
October 2018153/943631 (0.1%)37
September 2018142/941597 (0.11%)40
August 2018133/939611 (0.12%)26
July 2018136/940665 (0.12%)26
June 2018150/947515 (0.1%)34
May 2018149/954579 (0.11%)35
April 2018155/946560 (0.1%)32
March 2018130/961683 (0.12%)21
February 2018144/940554 (0.12%)30
January 2018140/945602 (0.12%)65
View Data for all Listings
Errors

Unsuccessful Installs in the last 7 Days: 55

CountError Message
6Cannot complete the install because one or more required items could not be found....
5Cannot complete the install because one or more required items could not be found....
5Cannot complete the install because one or more required items could not be found....
5Cannot complete the install because one or more required items could not be found....
4Cannot continue the operation. There is another install operation in progress.
3Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Your original request has been modified....
2Cannot complete the install because one or more required items could not be found....
2Your original request has been modified....
2Cannot complete the install because one or more required items could not be found....
2Your original request has been modified....
2Your original request has been modified....
1Cannot complete the install because of a conflicting dependency....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
1?????????????...
1Your original request has been modified....
1Your original request has been modified....
1Cannot complete the install because one or more required items could not be found....
Download last 500 errors (CSV)
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Maven Integration for Eclipse (Luna and newer).

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Sunday, December 16, 2018 - 18:56
hcrachat's picture

I'm here to try and download the plugin again, with no success because i tried to use JRebel to "bypass" deployment to my WAS...DO NOT INSTALL JREBEL

nsingh600's picture

Was facing the same issue, please try uninstalling from market place and reinstalling it again.

It worked for me, some files wre missing in standard installation

abihir4n's picture

Cannot complete the install because one or more required items could not be found.
Software being installed: m2e - Maven Integration for Eclipse (includes Incubating components) 1.5.0.20140606-0033 (org.eclipse.m2e.feature.feature.group 1.5.0.20140606-0033)
Missing requirement: Maven Integration for Eclipse 1.5.0.20140606-0033 (org.eclipse.m2e.core 1.5.0.20140606-0033) requires 'bundle org.slf4j.api 1.6.2' but it could not be found
Cannot satisfy dependency:
From: Maven POM XML Editor 1.5.0.20140606-0033 (org.eclipse.m2e.editor.xml 1.5.0.20140606-0033)
To: bundle org.eclipse.m2e.core [1.5.0,1.6.0)
Cannot satisfy dependency:
From: m2e - Maven Integration for Eclipse (includes Incubating components) 1.5.0.20140606-0033 (org.eclipse.m2e.feature.feature.group 1.5.0.20140606-0033)
To: org.eclipse.m2e.editor.xml [1.5.0.20140606-0033]

useneviratne's picture

Suddenly maven was disappeared all of my work spaces. All the maven goals were not available. I tried to recover by uninstalling and re installing m2e, but didn't work. Finally I did a 'mvn clean' from the command line and restarted the eclipse. All the maven profiles were available again

nsood's picture

Could not calculate build plan: Plugin com.sap.ui5.tools.build:build-helper-maven-plugin:1.26.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.sap.ui5.tools.build:build-helper-maven-plugin:jar:1.26.2
Plugin com.sap.ui5.tools.build:build-helper-maven-plugin:1.26.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.sap.ui5.tools.build:build-helper-maven-plugin:jar:1.26.2

rdogar's picture

Hey .. I am newer to building REST web services .. i just know how to download and import jersey library in my maven project ?
Note : maven is auto configure with eclipse ..
Thanks for help

njamesart's picture

Am using Eclipse luna and i tried to run my maven project by right clicking the project -> run as-> .... but "maven package" is not exist in run as. so i tried to run by using run configuration and create a goal but am getting some or other errors like "LifecyclePhaseNotFoundException" or "MojoExecutionException". Please help how to solve this problem

hjainwq0's picture

Nancy, did you get any solution to your problem. I have downloaded MARS EE M4 64 bit edition and facing the same issue that maven in not available, though it is installed.

mhernandezv85's picture

Guys, I downloaded the m2e for Juno from the market place on my mac 64 and restarted eclipse. I still don't see any Maven options like run as or as a project choice. What gives? Am I missing something to activate it?

nickb's picture

Java 8 support is available in m2e 1.4.1.20140328-1905.

https://marketplace.eclipse.org/content/java%E2%84%A2-8-support-m2e-ecli...

bryu's picture

Does anyone who knows about this problem? It seems to be a problem with download it in market place.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at http://download.eclipse.org/technology/m2e/releases/1.3/1.3.1.20130219-1....
Connection reset
Unable to read repository at http://download.eclipse.org/technology/m2e/releases/1.3/1.3.1.20130219-1....
Connection reset

emisingname4ok's picture

Anyone else having trouble downloading/installing? I get to 49% and then get a read error:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at http://download.eclipse.org/technology/m2e/releases/1.3/1.3.1.20130219-1....
Read timed out

kmg203's picture

Hi

I am running Juno on a Win7 64-bit machine and have installed the Maven Integration for Eclipse package plus the WTP integration package via the Eclipse MArketplace and Discovery dialogues respectively.

I have created a very simple app. with the maven-archetype-quistart archetype then selected Run As../Maven build .... I then clicked on "Select" to retrieve a list of available targets and received the message:

"No entries available"

I'd be grateful if anyone can clarify how to put this right. I suspect I have missed a step?? Or is there an issue with 64-bit platforms?

Regards

dschulzec8k's picture

I've been waiting for what seems like forever for the built in installer to finish calculating requirements and dependencies. In several places it has stopped with 0B/s download speed. I had to abort one install because it was taking forever. I thought the problem was on my end, but speedtest.org shows > 20 MB/s download speed and other software downloads just fine.

You need a manual download / install procedure for this plugin because your built in install takes forever.

tnath's picture

I am not able to download the plugin. It keeps on downloading from all the mirrors one by one.

Eclipse Version: Indigo Service Release 2
Eclipse Build id: 20120216-1857

fmisingnamecxy's picture

I make a setup of M2e in a last version of eclipse indigo , for a first time it's okey but , when i make a setup of Birt framwork , maven was gone , i dont know why .
if i test a logo of maven in a help toolbar of eclipse , i see it , but when i test it in perefernce window , i dont find it ...........
So it's a bug or a worst thing in setup .....

smisingnamew0w's picture

I experienced a similar problem. A solution/workaround can be found here: http://blog.subshell.com/devblog/2011/06/changing-from-m2eclipse-to-m2e-...

Apparently, it's about Win7/Vista permissions. I know it's annoying but nontheless it worked fine for me.

rmisingnameexq's picture

Can someone please provide explicit directions for updating to the latest version of m2e. Indigo doesn't work with the Eclipse Market Place. Please don't assume statements like go to the update site are understood. These type of failures should hav explicit directions to resolve the install issue.

Cannot complete the install because one or more required items could not be found.
Software currently installed: Shared profile 1.0.0.1308119157680 (SharedProfile_epp.package.java 1.0.0.1308119157680)
Missing requirement: Shared profile 1.0.0.1308119157680 (SharedProfile_epp.package.java 1.0.0.1308119157680) requires 'org.maven.ide.eclipse [1.0.0.20110607-2117]' but it could not be found

hpost0rr's picture

I was still not able to install the Maven plugin into Helios Win7-64, using the direct url. A collegue suggested using Yoxos which worked great!

jk10's picture

http://m2eclipse.sonatype.org/sites/m2e was the site to add then I was able to install m2eclipse in HELIOS.

Thank you, thank you, thank you Mr. Smith!

jk10's picture

Is anyone else having problems installing Maven Integration for Eclipse on MACOSX from the Marketplace?

jk10's picture

This has been mentioned before and there was a message implying it was remedied.

I pulled a fresh Eclipse Helios (64 bit) for Mac osx and when you bring up the Eclipse Marketplace and search for "Maven Integration eclipse" you will see at least 2 related entries (core and extras). Neither item has an install button. Instead there is a 'learn more...' link.

Is there a non-marketplace way to install m2eclipse?

m2eclipse is a fantastic plugin - thanks to sonatype for the hard work. Please help resolve this issue.

Thanks :-)

rsmithg6r's picture

In Helios you can go to the install new software area and select http://m2eclipse.sonatype.org/sites/m2e from the select the avalailable software link. M2Eclipse will then be available for installation. I was able to install Sonar from the marketplace after doing this so it appears to work just fine.

Rick

tmisingname82j's picture

Instead of the 'Install' button, it shows a 'Learn More' link that leads here...

mmisingnameii7's picture

Because of this bug (https://issues.sonatype.org/browse/MNGECLIPSE-2191), m2eclipse is unusable with Helios. Any chance to release a bug fix release within the next few days ?

tobrieng0x's picture

I can't give a timeline for an unrelease feature. It is against our policy of predicting release dates, but I can tell you that the problem has been identified and that a release is currently being staged and tested. Think sooner rather than later. Apologies for the inconvenience.

mmisingnameii7's picture

and thank you for this great tool... I will wait few more days then before using Helios. m2eclipse is definitively one of the plugins I can't live without in my Eclipse distro. Keep going the excellent work !

pdavis147's picture

This plugin cannot be installed through the marketplace.

tobrieng0x's picture

Paul, we just updated the plugin information. You can now install this plugin via the Marketplace.

chen@sep24th.com's picture

When will you support Helios (3.6.0)?

thank you.

tobrieng0x's picture

Sonatype is currently testing a build that will be compatible with Helios. You can install it today via the Eclipse Marketplace, but there are some problems launch the Maven process.

tmisingnameiv3's picture

Hi,

the m2eclipse (also the Maevn Integration for Ecplipse Extrans) plugin still not available fpr install in helios 20100617-1415 marketplace.
Like already shown above there is no "Install button" for Maven Integration for Eclipse" /2eclipse, only an info link.

Fullfillimg the process described here "http://www.sonatype.com/people/2010/07/installing-m2eclipse-with-the-ecl..." is not possible, because thet is no install button.

The Eclipse Sonar Plugin has an "install button" but fails with dependency errors when trying to install,.

Would you please fix that instables plugins, cause we can't proceed using maven/nexus/sonar if not working with helios release.

Tx in advance.

mmisingnamek2i's picture

Same thing.

Thanks,
-Rick

david.hergert@paetec.com's picture

I am experiencing the same isseue. In the marketplace, I cannot Install the plugin. I have to manually add it as an update site.

Could it be that the marketplace is still 'publishing' 0.10.0 (which isnt compatible) and hasnt been updated to carry 0.10.2 (which is)?