Eclipse Foundation Member
Maven Integration for Eclipse (Luna)

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

m2e provides comprehensive Maven integration for Eclipse. You can use m2e to manage both simple and multi-module Maven projects, execute Maven builds via the Eclipse interface, and interact with Maven repositories. m2e makes development easier by integrating data from a project’s Object Model with Eclipse IDE features. With m2e, you can use Maven within Eclipse in a natural and intuitive interface.

Here is a list of features available in m2e:

  • Creating and importing Maven projects
  • Dependency management and integration with the Eclipse classpath
  • Automatic dependency downloads and updates
  • Artifact Javadoc and source resolution
  • Creating projects with Maven Archetypes
  • Browsing and searching remote Maven repositories
  • POM management with automatic update to dependency list
  • Materializing a project from a Maven POM
  • Adapting nested multi-module Maven projects to the Eclipse IDE
  • Form-based and text-based POM Editor
  • GUI Presentation of Dependency Tree and Resolved Dependencies

Version 1.5 includes Maven Profiles Management
and other enhancements.

Categories:
Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Mon, 2014-06-30 04:34
Development Status: 
Mature
License: 
EPL
Date Updated: 
Thu, 2018-08-23 15:05
Metrics
DateRankingInstallsClickthroughs
December 2018115/902414 (0.14%)20
November 2018114/939910 (0.15%)31
October 2018113/943939 (0.15%)23
September 201891/9411049 (0.2%)16
August 201890/9391045 (0.2%)16
July 2018103/940962 (0.18%)13
June 2018106/947880 (0.18%)21
May 2018103/954933 (0.17%)22
April 2018107/946918 (0.17%)14
March 201896/9611094 (0.2%)12
February 201894/940924 (0.2%)43
January 201890/9451055 (0.21%)21
View Data for all Listings
Errors

Unsuccessful Installs in the last 7 Days: 285

CountError Message
128Cannot complete the install because one or more required items could not be found....
13Cannot complete the install because one or more required items could not be found....
11Your original request has been modified....
10Cannot complete the install because one or more required items could not be found....
9Cannot continue the operation. There is another install operation in progress.
9Cannot complete the install because one or more required items could not be found....
9Cannot complete the install because one or more required items could not be found....
7Cannot complete the install because one or more required items could not be found....
6Cannot complete the install because one or more required items could not be found....
4Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
3Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Cannot complete the install because one or more required items could not be found....
2Your original request has been modified....
2Cannot complete the request. See the error log for details....
2Your original request has been modified....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Your original request has been modified....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
1Cannot complete the install because one or more required items could not be found....
Download last 500 errors (CSV)
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Maven Integration for Eclipse (Luna).

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Sunday, December 16, 2018 - 11:02