Liquibase Eclipse Plugin

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

The Liquibase Eclipse Plugin simplifies database schema management and migration from within the Eclipse IDE. It provides integration between the powerful Liquibase library and the Eclipse Data Tools package allowing you to manage deployment of scripts to multiple databases with just a few clicks.

Supports Liquibase v2.0.5 and v3.0.2
Run scripts against multiple Eclipse Data Sources.
Generate changelogs from existing schemas.
Drop all items in a schema.
View deployed change sets.
View available scripts in the workspace.
Rollback multiple scripts at once.
Rollback specific change sets.
Content assist support for XML editor.

Source code and issue tracking are available on the google code project page:

https://code.google.com/p/liquibase-eclipse-plugin/

Categories:
Tags:
Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Fri, 2013-02-22 14:03
Development Status: 
Production/Stable
License: 
Apache 2.0
Date Updated: 
Thu, 2018-08-23 15:03
Metrics
DateRankingInstallsClickthroughs
View Data for all Listings
Errors

Unsuccessful Installs in the last 7 Days: 0

Download last 500 errors (CSV)
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Liquibase Eclipse Plugin.

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Wednesday, December 12, 2018 - 06:00
mlazzoni's picture

Getting the error "No repository found at "liquibase-eclipse-plugin.googlecode.com/svn/trunk/com.svcdelivery.liquibase.eclipse.site". Please resolve

gmadacs's picture

liquibase-eclipse-plugin.googlecode.com is not exists (404), this product is unaccessible!

mangelo's picture

No repository found at liquibase-eclipse-plugin.googlecode.com/svn/trunk/com.svcdelivery.liquibase.eclipse.site./