Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.osgi.feature.feature.group,3.6.3.201411271034-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: Spring IDE Maven Support 3.6.3.201411271034-RELEASE (org.springframework.ide.eclipse.maven.feature.feature.group 3.6.3.201411271034-RELEASE) Software being installed: Spring IDE Roo Support 3.6.3.201411271034-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.3.201411271034-RELEASE) Software currently installed: Groovy-Eclipse Feature 2.9.1.xx-201411061336-e43-RELEASE (org.codehaus.groovy.eclipse.feature.feature.group 2.9.1.xx-201411061336-e43-RELEASE) Only one of the following can be installed at once: Object Teams Development Tooling Core 3.8.1.v_OTDT_r210_201206090452 (org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452) Object Teams Development Tooling Core 3.8.3.v_OTDT_r212_201301271217 (org.eclipse.jdt.core 3.8.3.v_OTDT_r212_201301271217) Java Development Tools Core 3.8.1.v20120531-0637 (org.eclipse.jdt.core 3.8.1.v20120531-0637) Object Teams Development Tooling Core 3.8.2.v_OTDT_r211_201209011847 (org.eclipse.jdt.core 3.8.2.v_OTDT_r211_201209011847) Java Development Tools Core 3.9.2.xx-201801081619-e43-RELEASE (org.eclipse.jdt.core 3.9.2.xx-201801081619-e43-RELEASE) Java Development Tools Core 3.8.2.v20120814-155456 (org.eclipse.jdt.core 3.8.2.v20120814-155456) Java Development Tools Core 3.9.2.xx-201411061336-e43-RELEASE (org.eclipse.jdt.core 3.9.2.xx-201411061336-e43-RELEASE) Java Development Tools Core 3.8.3.v20130121-145325 (org.eclipse.jdt.core 3.8.3.v20130121-145325) Java Development Tools Core 3.8.3.xx-201406301609-e42 (org.eclipse.jdt.core 3.8.3.xx-201406301609-e42) Cannot satisfy dependency: From: Groovy-Eclipse Compilerless Feature 2.9.1.xx-201411061336-e43-RELEASE (org.codehaus.groovy.compilerless.feature.feature.group 2.9.1.xx-201411061336-e43-RELEASE) To: org.codehaus.groovy.headless.feature.feature.group [2.9.1.xx-201411061336-e43-RELEASE] Cannot satisfy dependency: From: Groovy-Eclipse Feature 2.9.1.xx-201411061336-e43-RELEASE (org.codehaus.groovy.eclipse.feature.feature.group 2.9.1.xx-201411061336-e43-RELEASE) To: org.codehaus.groovy.compilerless.feature.feature.group [2.9.1.xx-201411061336-e43-RELEASE] Cannot satisfy dependency: From: Groovy-Eclipse Headless Feature 2.9.1.xx-201411061336-e43-RELEASE (org.codehaus.groovy.headless.feature.feature.group 2.9.1.xx-201411061336-e43-RELEASE) To: org.codehaus.groovy.jdt.patch.feature.group [2.9.1.xx-201411061336-e43-RELEASE] Cannot satisfy dependency: From: AspectJ Development Tools 2.2.3.e42x-RELEASE-20130625-1400 (org.eclipse.ajdt.feature.group 2.2.3.e42x-RELEASE-20130625-1400) To: org.eclipse.ajdt.ui [2.2.3.e42x-RELEASE-20130625-1400] Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.3.e42x-RELEASE-20130625-1400 (org.eclipse.ajdt.ui 2.2.3.e42x-RELEASE-20130625-1400) To: bundle org.eclipse.jdt.core [3.6.0,3.9.0) Cannot satisfy dependency: From: Spring IDE Core (required) 3.6.3.201411271034-RELEASE (org.springframework.ide.eclipse.feature.feature.group 3.6.3.201411271034-RELEASE) To: org.eclipse.jdt.feature.group 3.3.0 Cannot satisfy dependency: From: Spring IDE Maven Support 3.6.3.201411271034-RELEASE (org.springframework.ide.eclipse.maven.feature.feature.group 3.6.3.201411271034-RELEASE) To: org.springframework.ide.eclipse.feature.feature.group 0.0.0 Cannot satisfy dependency: From: Spring IDE Roo Support 3.6.3.201411271034-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.3.201411271034-RELEASE) To: org.eclipse.ajdt.feature.group 2.0.1 Cannot satisfy dependency: From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.9.1.xx-201411061336-e43-RELEASE Eclipse Java Development Tools 3.8.0.v20120525-1249-8-8nFqlFNOfwKDRGz-pXLdGxEM83 (org.eclipse.jdt.feature.group 3.8.0.v20120525-1249-8-8nFqlFNOfwKDRGz-pXLdGxEM83) To: org.eclipse.jdt.core [3.9.2.xx-201411061336-e43-RELEASE] Cannot satisfy dependency: From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.9.1.xx-201411061336-e43-RELEASE Eclipse Java Development Tools 3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83 (org.eclipse.jdt.feature.group 3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83) To: org.eclipse.jdt.core [3.9.2.xx-201411061336-e43-RELEASE] Cannot satisfy dependency: From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.9.1.xx-201411061336-e43-RELEASE Eclipse Java Development Tools 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83 (org.eclipse.jdt.feature.group 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83) To: org.eclipse.jdt.core [3.9.2.xx-201411061336-e43-RELEASE]