Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.eclipse.jgit.feature.group,4.11.0.201803080745-r
Detailed Message: 
Your original request has been modified. "Java implementation of Git" is already installed, so an update will be performed instead. Cannot complete the install because of a conflicting dependency. Software being installed: Java implementation of Git 4.11.0.201803080745-r (org.eclipse.jgit.feature.group 4.11.0.201803080745-r) Software currently installed: Spring Tool Suite 3.4.0.201310051818-RELEASE-e38 (org.springsource.sts.ide 3.4.0.201310051818-RELEASE-e38) Only one of the following can be installed at once: Git Team Provider Core 3.1.0.201310021548-r (org.eclipse.egit.core 3.1.0.201310021548-r) Git integration for Eclipse - Core 4.11.0.201803080745-r (org.eclipse.egit.core 4.11.0.201803080745-r) Only one of the following can be installed at once: Java implementation of Git 3.1.0.201310021548-r (org.eclipse.jgit.feature.jar 3.1.0.201310021548-r) Java implementation of Git 4.11.0.201803080745-r (org.eclipse.jgit.feature.jar 4.11.0.201803080745-r) Cannot satisfy dependency: From: Eclipse Git Team Provider 3.1.0.201310021548-r (org.eclipse.egit.feature.group 3.1.0.201310021548-r) To: org.eclipse.jgit.feature.group [3.1.0,3.2.0) Cannot satisfy dependency: From: Git integration for Eclipse 4.11.0.201803080745-r (org.eclipse.egit.feature.group 4.11.0.201803080745-r) To: org.eclipse.egit.core [4.11.0.201803080745-r] Cannot satisfy dependency: From: Java implementation of Git 3.1.0.201310021548-r (org.eclipse.jgit.feature.group 3.1.0.201310021548-r) To: org.eclipse.jgit.feature.jar [3.1.0.201310021548-r] Cannot satisfy dependency: From: Java implementation of Git 4.11.0.201803080745-r (org.eclipse.jgit.feature.group 4.11.0.201803080745-r) To: org.eclipse.jgit.feature.jar [4.11.0.201803080745-r] Cannot satisfy dependency: From: Eclipse GitHub integration with task focused interface 3.1.0.201310021548-r (org.eclipse.mylyn.github.feature.feature.group 3.1.0.201310021548-r) To: org.eclipse.mylyn.github.ui [3.1.0.201310021548-r] Cannot satisfy dependency: From: Mylyn GitHub Connector UI 3.1.0.201310021548-r (org.eclipse.mylyn.github.ui 3.1.0.201310021548-r) To: package org.eclipse.egit.core [3.1.0,3.2.0) Cannot satisfy dependency: From: Spring Tool Suite 3.4.0.201310051818-RELEASE-e38 (org.springsource.sts.ide 3.4.0.201310051818-RELEASE-e38) To: org.springsource.sts.package.feature.group [3.4.0.201310051818-RELEASE-e38] Cannot satisfy dependency: From: Spring Tool Suite Package 3.4.0.201310051818-RELEASE-e38 (org.springsource.sts.package.feature.group 3.4.0.201310051818-RELEASE-e38) To: org.eclipse.egit.feature.group 0.0.0 Cannot satisfy dependency: From: Spring Tool Suite Package 3.4.0.201310051818-RELEASE-e38 (org.springsource.sts.package.feature.group 3.4.0.201310051818-RELEASE-e38) To: org.eclipse.mylyn.github.feature.feature.group 0.0.0