Error Report

unread
Error Code: 
4
Error Message: 
?????
Installable Units Reported: 
org.springframework.ide.eclipse.osgi.feature.feature.group,2.9.2.201205070117-RELEASE
Detailed Message: 
1 ????????????????????????????????? Software being installed: SpringSource Tool Suite Tutorials 2.9.2.201205071000-RELEASE (com.springsource.sts.tutorials.feature.group 2.9.2.201205071000-RELEASE) Software currently installed: Eclipse IDE for Java EE Developers 1.4.2.20120213-0813 (epp.package.jee 1.4.2.20120213-0813) Missing requirement: Java Development Tools UI 3.9.50.v20140317-1811 (org.eclipse.jdt.ui 3.9.50.v20140317-1811) requires 'bundle org.eclipse.equinox.bidi [0.10.0,2.0.0)' but it could not be found Only one of the following can be installed at once: Default Text Editor 3.6.1.r361_v20100825-0800 (org.eclipse.ui.editors 3.6.1.r361_v20100825-0800) Default Text Editor 3.6.0.v20100520-0800 (org.eclipse.ui.editors 3.6.0.v20100520-0800) Default Text Editor 3.7.0.v20110517-0800 (org.eclipse.ui.editors 3.7.0.v20110517-0800) Default Text Editor 3.7.0.v20110928-1504 (org.eclipse.ui.editors 3.7.0.v20110928-1504) Cannot satisfy dependency: From: SpringSource Tool Suite Help and Support 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.help 2.9.2.201205071000-RELEASE) To: bundle com.springsource.sts.ide.ui 0.0.0 Cannot satisfy dependency: From: SpringSource Tool Suite (UI) 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.ui 2.9.2.201205071000-RELEASE) To: bundle org.eclipse.ajdt.ui 0.0.0 Cannot satisfy dependency: From: SpringSource Tool Suite Tutorials 2.9.2.201205071000-RELEASE (com.springsource.sts.tutorials.feature.group 2.9.2.201205071000-RELEASE) To: com.springsource.sts.ide.help [2.9.2.201205071000-RELEASE] Cannot satisfy dependency: From: Eclipse IDE for Java EE Developers 1.4.2.20120213-0813 (epp.package.jee 1.4.2.20120213-0813) To: org.eclipse.epp.package.jee.feature.feature.group [1.4.2.20120213-0813] Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.0.e36x-20111207-1200 (org.eclipse.ajdt.ui 2.2.0.e36x-20111207-1200) To: bundle org.eclipse.ui.editors [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.0.e36x-20120507-1400 (org.eclipse.ajdt.ui 2.2.0.e36x-20120507-1400) To: bundle org.eclipse.ui.editors [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.ui 2.2.4.e43yJ8-20140523-1400) To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0) Cannot satisfy dependency: From: Java EE IDE Feature 1.4.2.20120213-0813 (org.eclipse.epp.package.jee.feature.feature.group 1.4.2.20120213-0813) To: org.eclipse.platform.feature.group [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q] Cannot satisfy dependency: From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q) To: org.eclipse.ui.editors [3.7.0.v20110928-1504]