Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.maven.feature.feature.group,3.9.3.201803200843-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: Spring IDE AJDT Integration (optional) 3.9.3.201803200843-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 3.9.3.201803200843-RELEASE) Software currently installed: Eclipse Java Development Tools 3.14.0.v20180308-0630 (org.eclipse.jdt.feature.group 3.14.0.v20180308-0630) Only one of the following can be installed at once: Object Teams Development Tooling Core 3.12.2.v_OTDT_r252_201612071657 (org.eclipse.jdt.core 3.12.2.v_OTDT_r252_201612071657) Java Development Tools Core 3.6.2.v_A76_R36x (org.eclipse.jdt.core 3.6.2.v_A76_R36x) Java Development Tools Core 3.13.100.v20171123-1049 (org.eclipse.jdt.core 3.13.100.v20171123-1049) Object Teams Development Tooling Core 3.13.101.v_OTDT_r262_201803031341 (org.eclipse.jdt.core 3.13.101.v_OTDT_r262_201803031341) Object Teams Development Tooling Core 3.13.100.v_OTDT_r261_201712031505 (org.eclipse.jdt.core 3.13.100.v_OTDT_r261_201712031505) Java Development Tools Core 3.12.0.v20160516-2131 (org.eclipse.jdt.core 3.12.0.v20160516-2131) Java Development Tools Core 3.6.0.v_A58 (org.eclipse.jdt.core 3.6.0.v_A58) Java Development Tools Core 3.14.0.v20180305-0940 (org.eclipse.jdt.core 3.14.0.v20180305-0940) Object Teams Development Tooling Core 3.12.3.v_OTDT_r253_201703071318 (org.eclipse.jdt.core 3.12.3.v_OTDT_r253_201703071318) Object Teams Development Tooling Core 3.14.0.v_OTDT_r270_201803131721 (org.eclipse.jdt.core 3.14.0.v_OTDT_r270_201803131721) Java Development Tools Core 3.13.0.v20170516-1929 (org.eclipse.jdt.core 3.13.0.v20170516-1929) Java Development Tools Core 3.13.50.v20171007-0855 (org.eclipse.jdt.core 3.13.50.v20171007-0855) Object Teams Development Tooling Core 3.12.0.v_OTDT_r250_201606070956 (org.eclipse.jdt.core 3.12.0.v_OTDT_r250_201606070956) Java Development Tools Core 3.12.3.v20170228-1205 (org.eclipse.jdt.core 3.12.3.v20170228-1205) Object Teams Development Tooling Core 3.12.1.v_OTDT_r251_201609131451 (org.eclipse.jdt.core 3.12.1.v_OTDT_r251_201609131451) Java Development Tools Core 3.6.2.xx-20120301-1300-e36-RELEASE (org.eclipse.jdt.core 3.6.2.xx-20120301-1300-e36-RELEASE) Java Development Tools Core 3.12.2.v20161117-1814 (org.eclipse.jdt.core 3.12.2.v20161117-1814) Java Development Tools Core 3.14.0.v20180123-1707 (org.eclipse.jdt.core 3.14.0.v20180123-1707) Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x) Java Development Tools Core 3.12.1.v20160829-0950 (org.eclipse.jdt.core 3.12.1.v20160829-0950) Java Development Tools Core 3.13.101.v20180215-0725 (org.eclipse.jdt.core 3.13.101.v20180215-0725) Only one of the following can be installed at once: Java Code Manipulation Functionality 1.7.0.v20160419-0705 (org.eclipse.jdt.core.manipulation 1.7.0.v20160419-0705) Java Code Manipulation Functionality 1.9.100.v20171116-1149 (org.eclipse.jdt.core.manipulation 1.9.100.v20171116-1149) Java Code Manipulation Functionality 1.9.0.v20161219-2145 (org.eclipse.jdt.core.manipulation 1.9.0.v20161219-2145) Java Code Manipulation Functionality 1.10.0.v20180302-1956 (org.eclipse.jdt.core.manipulation 1.10.0.v20180302-1956) Java Code Manipulation Functionality 1.3.0.v20100520-0800 (org.eclipse.jdt.core.manipulation 1.3.0.v20100520-0800) Java Code Manipulation Functionality 1.9.50.v20170920-1015 (org.eclipse.jdt.core.manipulation 1.9.50.v20170920-1015) Cannot satisfy dependency: From: AspectJ Development Tools Core 2.2.0.e36x-20111207-1200 (org.eclipse.ajdt.core 2.2.0.e36x-20111207-1200) To: osgi.bundle; org.eclipse.jdt.core [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools Core 2.2.0.e36x-20120507-1400 (org.eclipse.ajdt.core 2.2.0.e36x-20120507-1400) To: osgi.bundle; org.eclipse.jdt.core [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools Core 2.2.4.201801301622 (org.eclipse.ajdt.core 2.2.4.201801301622) To: osgi.bundle; org.eclipse.jdt.core.manipulation [1.3.0,1.10.0) Cannot satisfy dependency: From: Eclipse Java Development Tools 3.14.0.v20180308-0630 (org.eclipse.jdt.feature.group 3.14.0.v20180308-0630) To: org.eclipse.equinox.p2.iu; org.eclipse.jdt.core [3.14.0.v20180305-0940,3.14.0.v20180305-0940] Cannot satisfy dependency: From: Eclipse Java Development Tools 3.14.0.v20180308-0630 (org.eclipse.jdt.feature.group 3.14.0.v20180308-0630) To: org.eclipse.equinox.p2.iu; org.eclipse.jdt.core.manipulation [1.10.0.v20180302-1956,1.10.0.v20180302-1956] Cannot satisfy dependency: From: Spring IDE AJDT Integration (optional) 3.9.3.201803200843-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 3.9.3.201803200843-RELEASE) To: org.eclipse.equinox.p2.iu; org.springframework.ide.eclipse.ajdt.ui.xref [3.9.3.201803200843-RELEASE,3.9.3.201803200843-RELEASE] Cannot satisfy dependency: From: Spring IDE AOP Xref UI 3.9.3.201803200843-RELEASE (org.springframework.ide.eclipse.ajdt.ui.xref 3.9.3.201803200843-RELEASE) To: java.package; org.eclipse.ajdt.core 0.0.0