Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
com.springsource.sts.feature.group,2.9.2.201205071000-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE) Software currently installed: IBM Software Delivery Platform 2017.8.28.161204 (IBM Software Delivery Platform com.ibm.sdp.eclipse.ide 2017.8.28.161204) Only one of the following can be installed at once: Core Runtime 3.8.0.v20120912-155025 (org.eclipse.core.runtime 3.8.0.v20120912-155025) Core Runtime 3.6.0.v20100505 (org.eclipse.core.runtime 3.6.0.v20100505) Cannot satisfy dependency: From: IBM Software Delivery Platform 2017.8.28.161204 (IBM Software Delivery Platform com.ibm.sdp.eclipse.ide 2017.8.28.161204) To: org.eclipse.e4.rcp.feature.group [1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS] Cannot satisfy dependency: From: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE) To: com.springsource.sts.ide.ui [2.9.2.201205071000-RELEASE] Cannot satisfy dependency: From: SpringSource Tool Suite (UI) 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.ui 2.9.2.201205071000-RELEASE) To: bundle org.eclipse.ajdt.ui 0.0.0 Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.0.e36x-20111207-1200 (org.eclipse.ajdt.ui 2.2.0.e36x-20111207-1200) To: bundle org.eclipse.core.runtime [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.0.e36x-20120507-1400 (org.eclipse.ajdt.ui 2.2.0.e36x-20120507-1400) To: bundle org.eclipse.core.runtime [3.6.0,3.7.0) Cannot satisfy dependency: From: Eclipse e4 Rich Client Platform 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS (org.eclipse.e4.rcp.feature.group 1.1.2.v20130130-191718-91FUvGP7GIX2Kgz-z-gvjMvXV1NS) To: org.eclipse.core.runtime [3.8.0.v20120912-155025]