Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.osgi.feature.feature.group,2.9.2.201205070117-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: Spring IDE AJDT Integration (optional) 2.9.2.201205070117-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 2.9.2.201205070117-RELEASE) Software currently installed: IBM Software Delivery Platform 2017.8.28.161204 (IBM Software Delivery Platform com.ibm.sdp.eclipse.ide 2017.8.28.161204) Only one of the following can be installed at once: Default Text Editor 3.6.1.r361_v20100825-0800 (org.eclipse.ui.editors 3.6.1.r361_v20100825-0800) Default Text Editor 3.8.0.v20120523-1540 (org.eclipse.ui.editors 3.8.0.v20120523-1540) Default Text Editor 3.6.0.v20100520-0800 (org.eclipse.ui.editors 3.6.0.v20100520-0800) Cannot satisfy dependency: From: IBM Software Delivery Platform 2017.8.28.161204 (IBM Software Delivery Platform com.ibm.sdp.eclipse.ide 2017.8.28.161204) To: org.eclipse.platform.feature.group [4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7] Cannot satisfy dependency: From: AspectJ Development Tools 2.2.0.e36x-20111207-1200 (org.eclipse.ajdt.feature.group 2.2.0.e36x-20111207-1200) To: org.eclipse.ui.editors [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools 2.2.0.e36x-20120507-1400 (org.eclipse.ajdt.feature.group 2.2.0.e36x-20120507-1400) To: org.eclipse.ui.editors [3.6.0,3.7.0) Cannot satisfy dependency: From: Eclipse Platform 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7 (org.eclipse.platform.feature.group 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7) To: org.eclipse.ui.editors [3.8.0.v20120523-1540] Cannot satisfy dependency: From: Spring IDE AJDT Integration (optional) 2.9.2.201205070117-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 2.9.2.201205070117-RELEASE) To: org.eclipse.ajdt.feature.group 0.0.0