Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.eclipse.recommenders.rcp.feature.feature.group,2.4.10.v20170911-1410
Detailed Message: 
Your original request has been modified. "Code Recommenders for Java Developers" is already installed, so an update will be performed instead. Cannot complete the install because of a conflicting dependency. Software being installed: Code Recommenders for Java Developers 2.4.10.v20170911-1410 (org.eclipse.recommenders.rcp.feature.feature.group 2.4.10.v20170911-1410) Software currently installed: Eclipse IDE for Java Developers 2.0.1.20130919-0803 (epp.package.java 2.0.1.20130919-0803) Only one of the following can be installed at once: Code Recommenders: Core Runtime 1.0.4.v20130612-1006-b77 (org.eclipse.recommenders.rcp 1.0.4.v20130612-1006-b77) Code Recommenders UI 2.4.10.v20170911-1410 (org.eclipse.recommenders.rcp 2.4.10.v20170911-1410) Code Recommenders: Core Runtime 1.0.5.v20130822-0858-b90 (org.eclipse.recommenders.rcp 1.0.5.v20130822-0858-b90) Cannot satisfy dependency: From: Eclipse IDE for Java Developers 2.0.1.20130919-0803 (epp.package.java 2.0.1.20130919-0803) To: org.eclipse.epp.package.java.feature.feature.group [2.0.1.20130919-0803] Cannot satisfy dependency: From: EPP Java Package 2.0.1.20130919-0803 (org.eclipse.epp.package.java.feature.feature.group 2.0.1.20130919-0803) To: org.eclipse.recommenders.feature.rcp.feature.group 0.0.0 Cannot satisfy dependency: From: Code Recommenders: Core Runtime 1.0.4.v20130612-1006-b77 (org.eclipse.recommenders.feature.rcp.core.feature.group 1.0.4.v20130612-1006-b77) To: org.eclipse.recommenders.rcp [1.0.4.v20130612-1006-b77] Cannot satisfy dependency: From: Code Recommenders: Core Runtime 1.0.5.v20130822-0858-b90 (org.eclipse.recommenders.feature.rcp.core.feature.group 1.0.5.v20130822-0858-b90) To: org.eclipse.recommenders.rcp [1.0.5.v20130822-0858-b90] Cannot satisfy dependency: From: Code Recommenders Developer Tools 1.0.4.v20130612-1006-b77 (org.eclipse.recommenders.feature.rcp.feature.group 1.0.4.v20130612-1006-b77) To: org.eclipse.recommenders.feature.rcp.core.feature.group [1.0.4.v20130612-1006-b77] Cannot satisfy dependency: From: Code Recommenders Developer Tools 1.0.5.v20130822-0858-b90 (org.eclipse.recommenders.feature.rcp.feature.group 1.0.5.v20130822-0858-b90) To: org.eclipse.recommenders.feature.rcp.core.feature.group [1.0.5.v20130822-0858-b90] Cannot satisfy dependency: From: Code Recommenders for Java Developers 2.4.10.v20170911-1410 (org.eclipse.recommenders.rcp.feature.feature.group 2.4.10.v20170911-1410) To: org.eclipse.recommenders.rcp [2.4.10.v20170911-1410]