Error Report

unread
Listings: 
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.autowire.feature.feature.group,3.6.4.201503051146-RELEASE
Detailed Message: 
Your original request has been modified. "Spring IDE Autowire Extension (optional)" is already installed, so an update will be performed instead. "Spring IDE Integration, Flex and Web Services Extension (optional)" is already installed, so an update will be performed instead. "Spring IDE Security Extension (optional)" is already installed, so an update will be performed instead. "Spring IDE Core (required)" is already installed, so an update will be performed instead. "Spring IDE Web Flow Extension (optional)" is already installed, so an update will be performed instead. Cannot complete the install because one or more required items could not be found. Software being installed: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE) Software currently installed: Eclipse IDE for Java EE Developers 1.4.1.20110909-1818 (epp.package.jee 1.4.1.20110909-1818) Missing requirement: Java Development Tools Launching Support 3.7.50.v20140317-1921 (org.eclipse.jdt.launching 3.7.50.v20140317-1921) requires 'bundle org.eclipse.debug.core [3.8.0,4.0.0)' but it could not be found Missing requirement: Java Development Tools UI 3.9.50.v20140317-1811 (org.eclipse.jdt.ui 3.9.50.v20140317-1811) requires 'bundle org.eclipse.jface [3.9.0,4.0.0)' but it could not be found Only one of the following can be installed at once: OSGi System Bundle 3.7.1.R37x_v20110808-1106 (org.eclipse.osgi 3.7.1.R37x_v20110808-1106) OSGi System Bundle 3.7.0.v20110613 (org.eclipse.osgi 3.7.0.v20110613) OSGi System Bundle 3.8.2.v20130124-134944 (org.eclipse.osgi 3.8.2.v20130124-134944) OSGi System Bundle 3.7.2.v20120110-1415 (org.eclipse.osgi 3.7.2.v20120110-1415) Cannot satisfy dependency: From: Eclipse IDE for Java EE Developers 1.4.1.20110909-1818 (epp.package.jee 1.4.1.20110909-1818) To: org.eclipse.epp.package.jee.feature.feature.group [1.4.1.20110909-1818] Cannot satisfy dependency: From: AspectJ Development Tools 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.feature.group 2.2.4.e43yJ8-20140523-1400) To: org.eclipse.ajdt.ui [2.2.4.e43yJ8-20140523-1400] Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.ui 2.2.4.e43yJ8-20140523-1400) To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0) Cannot satisfy dependency: From: Java EE IDE Feature 1.4.1.20110909-1818 (org.eclipse.epp.package.jee.feature.feature.group 1.4.1.20110909-1818) To: org.eclipse.platform.feature.group [3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK] Cannot satisfy dependency: From: Java Development Tools Launching Support 3.6.101.v20130111-183046 (org.eclipse.jdt.launching 3.6.101.v20130111-183046) To: bundle org.eclipse.osgi [3.8.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.8.2.v20130107-165834 (org.eclipse.jdt.ui 3.8.2.v20130107-165834) To: bundle org.eclipse.jdt.launching [3.6.100,4.0.0) Cannot satisfy dependency: From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK) To: org.eclipse.rcp.feature.group [3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A] Cannot satisfy dependency: From: Eclipse RCP 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A (org.eclipse.rcp.feature.group 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A) To: org.eclipse.osgi [3.7.1.R37x_v20110808-1106] Cannot satisfy dependency: From: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE) To: org.eclipse.ajdt.feature.group 2.0.1