Error Report

unread
Listings: 
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.autowire.feature.feature.group,3.6.4.201503051146-RELEASE
Detailed Message: 
Your original request has been modified. "Spring IDE Core (required)" is already installed, so an update will be performed instead. Cannot complete the install because of a conflicting dependency. Software being installed: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE) Software currently installed: Eclipse Platform 3.7.1.M20110909-1335 (org.eclipse.platform.ide 3.7.1.M20110909-1335) Only one of the following can be installed at once: OSGi System Bundle 3.7.1.R37x_v20110808-1106 (org.eclipse.osgi 3.7.1.R37x_v20110808-1106) OSGi System Bundle 3.7.0.v20110613 (org.eclipse.osgi 3.7.0.v20110613) OSGi System Bundle 3.10.2.v20150203-1939 (org.eclipse.osgi 3.10.2.v20150203-1939) OSGi System Bundle 3.10.0.v20140606-1445 (org.eclipse.osgi 3.10.0.v20140606-1445) OSGi System Bundle 3.10.1.v20140909-1633 (org.eclipse.osgi 3.10.1.v20140909-1633) OSGi System Bundle 3.7.2.v20120110-1415 (org.eclipse.osgi 3.7.2.v20120110-1415) Cannot satisfy dependency: From: AspectJ Development Tools 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.feature.group 2.2.4.e43yJ8-20140523-1400) To: org.eclipse.ajdt.ui [2.2.4.e43yJ8-20140523-1400] Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.ui 2.2.4.e43yJ8-20140523-1400) To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0) Cannot satisfy dependency: From: Java Development Tools Launching Support 3.7.100.v20140428-1912 (org.eclipse.jdt.launching 3.7.100.v20140428-1912) To: bundle org.eclipse.osgi [3.8.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools Launching Support 3.7.101.v20140825-1922 (org.eclipse.jdt.launching 3.7.101.v20140825-1922) To: bundle org.eclipse.osgi [3.8.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools Launching Support 3.7.102.v20141111-0953 (org.eclipse.jdt.launching 3.7.102.v20141111-0953) To: bundle org.eclipse.osgi [3.8.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools Launching Support 3.7.50.v20140317-1921 (org.eclipse.jdt.launching 3.7.50.v20140317-1921) To: bundle org.eclipse.osgi [3.8.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.10.0.v20140604-1403 (org.eclipse.jdt.ui 3.10.0.v20140604-1403) To: bundle org.eclipse.jdt.launching [3.6.100,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.10.1.v20140817-1500 (org.eclipse.jdt.ui 3.10.1.v20140817-1500) To: bundle org.eclipse.jdt.launching [3.6.100,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.10.2.v20141014-1419 (org.eclipse.jdt.ui 3.10.2.v20141014-1419) To: bundle org.eclipse.jdt.launching [3.6.100,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.9.50.v20140317-1811 (org.eclipse.jdt.ui 3.9.50.v20140317-1811) To: bundle org.eclipse.jdt.launching [3.6.100,4.0.0) Cannot satisfy dependency: From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK) To: org.eclipse.rcp.feature.group [3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A] Cannot satisfy dependency: From: Eclipse Platform 3.7.1.M20110909-1335 (org.eclipse.platform.ide 3.7.1.M20110909-1335) To: org.eclipse.platform.feature.group [3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK] Cannot satisfy dependency: From: Eclipse RCP 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A (org.eclipse.rcp.feature.group 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A) To: org.eclipse.osgi [3.7.1.R37x_v20110808-1106] Cannot satisfy dependency: From: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE) To: org.eclipse.ajdt.feature.group 2.0.1