Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.feature.feature.group,2.9.2.201205070117-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: Spring IDE AJDT Integration (optional) 2.9.2.201205070117-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 2.9.2.201205070117-RELEASE) Software currently installed: Eclipse Java Development Tools 3.12.0.v20160606-1100 (org.eclipse.jdt.feature.group 3.12.0.v20160606-1100) Only one of the following can be installed at once: Object Teams Development Tooling Core 3.12.2.v_OTDT_r252_201612071657 (org.eclipse.jdt.core 3.12.2.v_OTDT_r252_201612071657) Object Teams Development Tooling Core 3.12.0.v_OTDT_r250_201606070956 (org.eclipse.jdt.core 3.12.0.v_OTDT_r250_201606070956) Java Development Tools Core 3.12.3.v20170228-1205 (org.eclipse.jdt.core 3.12.3.v20170228-1205) Object Teams Development Tooling Core 3.12.1.v_OTDT_r251_201609131451 (org.eclipse.jdt.core 3.12.1.v_OTDT_r251_201609131451) Java Development Tools Core 3.6.2.v_A76_R36x (org.eclipse.jdt.core 3.6.2.v_A76_R36x) Java Development Tools Core 3.6.2.xx-20120301-1300-e36-RELEASE (org.eclipse.jdt.core 3.6.2.xx-20120301-1300-e36-RELEASE) Java Development Tools Core 3.12.2.v20161117-1814 (org.eclipse.jdt.core 3.12.2.v20161117-1814) Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x) Java Development Tools Core 3.12.0.v20160516-2131 (org.eclipse.jdt.core 3.12.0.v20160516-2131) Java Development Tools Core 3.6.0.v_A58 (org.eclipse.jdt.core 3.6.0.v_A58) Java Development Tools Core 3.12.1.v20160829-0950 (org.eclipse.jdt.core 3.12.1.v20160829-0950) Object Teams Development Tooling Core 3.12.3.v_OTDT_r253_201703071318 (org.eclipse.jdt.core 3.12.3.v_OTDT_r253_201703071318) Cannot satisfy dependency: From: AspectJ Development Tools Core 2.2.0.e36x-20111207-1200 (org.eclipse.ajdt.core 2.2.0.e36x-20111207-1200) To: bundle org.eclipse.jdt.core [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools Core 2.2.0.e36x-20120507-1400 (org.eclipse.ajdt.core 2.2.0.e36x-20120507-1400) To: bundle org.eclipse.jdt.core [3.6.0,3.7.0) Cannot satisfy dependency: From: Eclipse Java Development Tools 3.12.0.v20160606-1100 (org.eclipse.jdt.feature.group 3.12.0.v20160606-1100) To: org.eclipse.jdt.core [3.12.0.v20160516-2131] Cannot satisfy dependency: From: Spring IDE AJDT Integration (optional) 2.9.2.201205070117-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feature.group 2.9.2.201205070117-RELEASE) To: org.springframework.ide.eclipse.ajdt.ui.xref [2.9.2.201205070117-RELEASE] Cannot satisfy dependency: From: Spring IDE AOP Xref UI 2.9.2.201205070117-RELEASE (org.springframework.ide.eclipse.ajdt.ui.xref 2.9.2.201205070117-RELEASE) To: package org.eclipse.ajdt.core 0.0.0