Error Report

unread
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.osgi.feature.feature.group,2.9.2.201205070117-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: SpringSource Tool Suite Tutorials 2.9.2.201205071000-RELEASE (com.springsource.sts.tutorials.feature.group 2.9.2.201205071000-RELEASE) Software currently installed: HBuilder 8.1.3.201705121932 (io.hbuilder.www 8.1.3.201705121932) Only one of the following can be installed at once: Eclipse UI 3.6.1.M20100826-1330 (org.eclipse.ui 3.6.1.M20100826-1330) Eclipse UI 3.7.0.v20110928-1505 (org.eclipse.ui 3.7.0.v20110928-1505) Eclipse UI 3.6.2.M20110203-1100 (org.eclipse.ui 3.6.2.M20110203-1100) Cannot satisfy dependency: From: Aptana Studio 3 RCP 8.1.3.201705121932 (com.aptana.feature.rcp.feature.group 8.1.3.201705121932) To: org.eclipse.ui [3.7.0.v20110928-1505] Cannot satisfy dependency: From: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE) To: com.springsource.sts.ide.ui [2.9.2.201205071000-RELEASE] Cannot satisfy dependency: From: SpringSource Tool Suite (UI) 2.9.2.201205071000-RELEASE (com.springsource.sts.ide.ui 2.9.2.201205071000-RELEASE) To: bundle org.eclipse.ajdt.ui 0.0.0 Cannot satisfy dependency: From: SpringSource Tool Suite Tutorials 2.9.2.201205071000-RELEASE (com.springsource.sts.tutorials.feature.group 2.9.2.201205071000-RELEASE) To: com.springsource.sts.feature.group [2.9.2,2.10.0) Cannot satisfy dependency: From: HBuilder 8.1.3.201705121932 (io.hbuilder.www 8.1.3.201705121932) To: com.aptana.feature.rcp.feature.group [8.1.3.201705121932] Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.0.e36x-20111207-1200 (org.eclipse.ajdt.ui 2.2.0.e36x-20111207-1200) To: bundle org.eclipse.ui [3.6.0,3.7.0) Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.0.e36x-20120507-1400 (org.eclipse.ajdt.ui 2.2.0.e36x-20120507-1400) To: bundle org.eclipse.ui [3.6.0,3.7.0)